Unf.Dhcp.Smo Namespace

DHCP Server Management Objects
Unf.Dhcp.Smo Namespace
Send Feedback
Unf.Dhcp.Smo is the root namespace of the DHCP Server Manage Objects (SMO) library. This library is a collection of objects is used configure and manage a Microsoft DHCP server. The Unf.Dhcp.Smo.Interop members interface with the DHCPSAPI library via System.Runtime.InteropServices classes, also known as Platform Invoke. Classes in the Unf.Dhcp.Smo namespace consume these interop methods, structures and classes to create a DHCPSAPI managed code wrapper .

Classes

Class | Description
BootpIpRange | Defines a BOOTP IP range, an extension of a DHCP IP range
DhcpClient | DhcpClient defines a client lease in the DHCP server database
DhcpClientFilter | Defines a set of regular expression as search terms
DhcpException | Dhcp specific exception object
DhcpIpAddress | Provides an IP address for the DHCP SMO library
DhcpIpRange | Defines a IP range used for a subnet element (feature)
DhcpIpReservation | Defines a DHCP IP reservation subenet element
DhcpMacAddress | Provides a MAC address for the DHCP SMO library
DhcpOption | Defines a DHCP Option on a DHCP Server. See DhcpOptionValue to assign values to DHCP Options.
DhcpOptionClassHash | Helper class to convert SMO enum option class types to native type strings
DhcpOptionData | Base class for all DhcpOptionData* types
DhcpOptionDataByte | Defines DHCP option data of byte type
DhcpOptionDataDword | Defines DHCP option data of UInt32 type
DhcpOptionDataDwordDword | Defines DHCP option data of UInt64 type
DhcpOptionDataIp | Defines DHCP option data of DhcpIpAddress type
DhcpOptionDataString | Defines DHCP option data of string type
DhcpOptionDataWord | Defines DHCP option data of UInt16 type
DhcpOptionScope | Defines an assignment scope for DHCP options
DhcpOptionValue | Defines a DHCP Option's value(s). See DhcpOption for DHCP Option definitions.
DhcpReservation | Define a DHCP reservation. A wrapper class of information combined from a client lease and IP reservation object
DhcpSearchInfo | Defines search terms used by DhcpClient methods searching for client leases
DhcpSubnet | Defines a DHCP subnet
DhcpSubnetElement | Defines an element that describe feature of a DHCP subnet
DhcpSubnetElementData | Base class that defines a DhcpSubnetElement data

Enumerations

Enumeration | Description
DhcpOptionClassType | Option class types
DhcpOptionDataType | DHCP option data types
DhcpOptionScopeType | DHCP option scope types
DhcpSearchInfoType | Search by type
DhcpSubnetClientType | Client Types
DhcpSubnetElementDataType | Types of DhcpSubnetElementData
DhcpSubnetState | DHCP Subnet state

Send comments on this topic to jrupard (at) unf edu

University of North Florida, School of Computing, Jason Rupard


BootpIpRange Class

BootpIpRange Class
Members See Also Send Feedback
Defines a BOOTP IP range, an extension of a DHCP IP range

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class BootpIpRange : DhcpIpRange

Remarks

This class supports types: DhcpIpRangesBootpOnly, DhcpIpRangesDhcpBootp

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnetElementData
Unf.Dhcp.Smo..::.DhcpIpRange
Unf.Dhcp.Smo..::.BootpIpRange

See Also

BootpIpRange Members
Unf.Dhcp.Smo Namespace


BootpIpRange Members

[image]

DHCP Server Management Objects
BootpIpRange Members
BootpIpRange Class Constructors Methods Fields See Also Send Feedback

The BootpIpRange type exposes the following members.

Constructors

Name | Description
BootpIpRange | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpIpRange ..::. ConvertToNative(MemManager).)

Fields

Name | Description
BootpAllocated | Specifies the number of BOOTP clients with addresses served from this range.
EndAddress | End IP of range (Inherited from DhcpIpRange.)
MaxBootpAllowed | Specifies the maximum number of BOOTP clients this range is allowed to serve.
StartAddress | Start IP of range (Inherited from DhcpIpRange.)
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


BootpIpRange Constructor

[image]

DHCP Server Management Objects
BootpIpRange Constructor
BootpIpRange Class See Also Send Feedback

Overload List

Name | Description
BootpIpRange()()() | Dummy constructor
BootpIpRange(DHCP_SUBNET_ELEMENT_DATA_V5) | Internal constructor to create a SMO BootpIpRange from its native form
BootpIpRange(DhcpSubnetElementDataType) | Sets new BootpIpRange to type

See Also

BootpIpRange Class
BootpIpRange Members
Unf.Dhcp.Smo Namespace


BootpIpRange Constructor

BootpIpRange Constructor
BootpIpRange Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BootpIpRange()

See Also

BootpIpRange Class
BootpIpRange Overload
Unf.Dhcp.Smo Namespace


BootpIpRange Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)

BootpIpRange Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)
BootpIpRange Class See Also Send Feedback
Internal constructor to create a SMO BootpIpRange from its native form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal BootpIpRange(
    DHCP_SUBNET_ELEMENT_DATA_V5 nativeElement
)

Parameters

nativeElement
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5
A native BOOTP IP range subnet element

See Also

BootpIpRange Class
BootpIpRange Overload
Unf.Dhcp.Smo Namespace


BootpIpRange Constructor (DhcpSubnetElementDataType)

BootpIpRange Constructor (DhcpSubnetElementDataType)
BootpIpRange Class See Also Send Feedback
Sets new BootpIpRange to type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public BootpIpRange(
    DhcpSubnetElementDataType type
)

Parameters

type
Type: Unf.Dhcp.Smo..::.DhcpSubnetElementDataType
Type of new BootpIpRange

See Also

BootpIpRange Class
BootpIpRange Overload
Unf.Dhcp.Smo Namespace


BootpIpRange Fields

[image]

DHCP Server Management Objects
BootpIpRange Fields
BootpIpRange Class See Also Send Feedback

The BootpIpRange type exposes the following members.

Fields

Name | Description
BootpAllocated | Specifies the number of BOOTP clients with addresses served from this range.
EndAddress | End IP of range (Inherited from DhcpIpRange.)
MaxBootpAllowed | Specifies the maximum number of BOOTP clients this range is allowed to serve.
StartAddress | Start IP of range (Inherited from DhcpIpRange.)
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


BootpAllocated Field

BootpIpRange..::.BootpAllocated Field
BootpIpRange Class See Also Send Feedback
Specifies the number of BOOTP clients with addresses served from this range.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint BootpAllocated

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


MaxBootpAllowed Field

BootpIpRange..::.MaxBootpAllowed Field
BootpIpRange Class See Also Send Feedback
Specifies the maximum number of BOOTP clients this range is allowed to serve.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint MaxBootpAllowed

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


BootpIpRange Methods

[image]

DHCP Server Management Objects
BootpIpRange Methods
BootpIpRange Class See Also Send Feedback

The BootpIpRange type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpIpRange ..::. ConvertToNative(MemManager).)

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

BootpIpRange..::.ConvertToNative Method
BootpIpRange Class See Also Send Feedback
Converts this object to its native subnet element form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_SUBNET_ELEMENT_DATA_V5 ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memeroy allocations

Return Value

A native BOOTP IP range subnet element

Remarks

Requires StartAddress, EndAddress and proper type to be set before calling

See Also

BootpIpRange Class
Unf.Dhcp.Smo Namespace


DhcpClient Class

DhcpClient Class
Members See Also Send Feedback
DhcpClient defines a client lease in the DHCP server database

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpClient

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpClient

See Also

DhcpClient Members
Unf.Dhcp.Smo Namespace


DhcpClient Members

[image]

DHCP Server Management Objects
DhcpClient Members
DhcpClient Class Constructors Methods Fields See Also Send Feedback

The DhcpClient type exposes the following members.

Constructors

Name | Description
DhcpClient | Dummy constructor

Methods

Name | Description
ConvertFromNative | Converts a native client lease to an SMO client lease
ConvertToNative | Converts this client object to its native representation
Create | Create this object on DHCP server
Delete | Delete client lease on DHCP server
EnumAll | Enumeration all client leases found in subnet on DHCP server
Get | Get client lease from DHCP server
Update | Update this object on DHCP server

Fields

Name | Description
Comment | Description string for client
IpAddress | IP address of client
LeaseExpires | Date and time client lease will expire
MacAddress | MAC address of client
Name | Hostname of client
SubnetMask | Subnet mask of client

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


DhcpClient Constructor

DhcpClient Constructor
DhcpClient Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpClient()

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


DhcpClient Fields

[image]

DHCP Server Management Objects
DhcpClient Fields
DhcpClient Class See Also Send Feedback

The DhcpClient type exposes the following members.

Fields

Name | Description
Comment | Description string for client
IpAddress | IP address of client
LeaseExpires | Date and time client lease will expire
MacAddress | MAC address of client
Name | Hostname of client
SubnetMask | Subnet mask of client

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Comment Field

DhcpClient..::.Comment Field
DhcpClient Class See Also Send Feedback
Description string for client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Comment

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


IpAddress Field

DhcpClient..::.IpAddress Field
DhcpClient Class See Also Send Feedback
IP address of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress IpAddress

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


LeaseExpires Field

DhcpClient..::.LeaseExpires Field
DhcpClient Class See Also Send Feedback
Date and time client lease will expire

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime LeaseExpires

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


MacAddress Field

DhcpClient..::.MacAddress Field
DhcpClient Class See Also Send Feedback
MAC address of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress MacAddress

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Name Field

DhcpClient..::.Name Field
DhcpClient Class See Also Send Feedback
Hostname of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


SubnetMask Field

DhcpClient..::.SubnetMask Field
DhcpClient Class See Also Send Feedback
Subnet mask of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress SubnetMask

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


DhcpClient Methods

[image]

DHCP Server Management Objects
DhcpClient Methods
DhcpClient Class See Also Send Feedback

The DhcpClient type exposes the following members.

Methods

Name | Description
ConvertFromNative | Converts a native client lease to an SMO client lease
ConvertToNative | Converts this client object to its native representation
Create | Create this object on DHCP server
Delete | Delete client lease on DHCP server
EnumAll | Enumeration all client leases found in subnet on DHCP server
Get | Get client lease from DHCP server
Update | Update this object on DHCP server

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


ConvertFromNative Method

DhcpClient..::.ConvertFromNative Method
DhcpClient Class See Also Send Feedback
Converts a native client lease to an SMO client lease

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static DhcpClient ConvertFromNative(
    DHCP_CLIENT_INFO nativeClient
)

Parameters

nativeClient
Type: Unf.Dhcp.Smo.Interop..::.DHCP_CLIENT_INFO
Native client to convert

Return Value

SMO client lease

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpClient..::.ConvertToNative Method
DhcpClient Class See Also Send Feedback
Converts this client object to its native representation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DHCP_CLIENT_INFO ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Used to track memory allocations

Return Value

Native form of a client lease

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Create Method

DhcpClient..::.Create Method
DhcpClient Class See Also Send Feedback
Create this object on DHCP server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Create(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

IpAddress, SubnetMask, MacAddress, and LeaseExpires must be set before calling Create()

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Delete Method

DhcpClient..::.Delete Method
DhcpClient Class See Also Send Feedback
Delete client lease on DHCP server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Delete(
    DhcpIpAddress server,
    DhcpSearchInfo term
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP
term
Type: Unf.Dhcp.Smo..::.DhcpSearchInfo
Search term describing client to delete (deletes first match)

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


EnumAll Method

DhcpClient..::.EnumAll Method
DhcpClient Class See Also Send Feedback
Enumeration all client leases found in subnet on DHCP server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpClient> EnumAll(
    DhcpIpAddress server,
    DhcpIpAddress subnet
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP
subnet
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet IP to enumerate

Return Value

A list of client leases or an empty list

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Get Method

DhcpClient..::.Get Method
DhcpClient Class See Also Send Feedback
Get client lease from DHCP server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient Get(
    DhcpIpAddress server,
    DhcpSearchInfo term
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server to query
term
Type: Unf.Dhcp.Smo..::.DhcpSearchInfo
Search term used to find client

Return Value

Returns first match based on term

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


Update Method

DhcpClient..::.Update Method
DhcpClient Class See Also Send Feedback
Update this object on DHCP server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Update(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

IpAddress, SubnetMask, MacAddress, and LeaseExpires must be set before calling Update()

See Also

DhcpClient Class
Unf.Dhcp.Smo Namespace


DhcpClientFilter Class

DhcpClientFilter Class
Members See Also Send Feedback
Defines a set of regular expression as search terms

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpClientFilter

Remarks

Pattern strings are marked with IgnoreCase. Please see Regex

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpClientFilter

See Also

DhcpClientFilter Members
Unf.Dhcp.Smo Namespace
Regular Expression Language Elements


DhcpClientFilter Members

[image]

DHCP Server Management Objects
DhcpClientFilter Members
DhcpClientFilter Class Constructors Methods Properties See Also Send Feedback

The DhcpClientFilter type exposes the following members.

Constructors

Name | Description
DhcpClientFilter | Dummy constructor

Methods

Name | Description
Filter | Filter predicate used by List<DhcpClient> Find and FindAll methods

Properties

Name | Description
IpRegEx | IP regex pattern string
MacRegEx | MAC regex pattern string
NameRegEx | Hostname regex pattern string

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


DhcpClientFilter Constructor

DhcpClientFilter Constructor
DhcpClientFilter Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpClientFilter()

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


DhcpClientFilter Methods

[image]

DHCP Server Management Objects
DhcpClientFilter Methods
DhcpClientFilter Class See Also Send Feedback

The DhcpClientFilter type exposes the following members.

Methods

Name | Description
Filter | Filter predicate used by List<DhcpClient> Find and FindAll methods

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


Filter Method

DhcpClientFilter..::.Filter Method
DhcpClientFilter Class See Also Send Feedback
Filter predicate used by List<DhcpClient> Find and FindAll methods

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool Filter(
    DhcpClient c
)

Parameters

c
Type: Unf.Dhcp.Smo..::.DhcpClient
Client to match

Return Value

True if match, otherwise false

Remarks

This filter matches based on a logical AND condition of non-null/non-empty regex members

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


DhcpClientFilter Properties

[image]

DHCP Server Management Objects
DhcpClientFilter Properties
DhcpClientFilter Class See Also Send Feedback

The DhcpClientFilter type exposes the following members.

Properties

Name | Description
IpRegEx | IP regex pattern string
MacRegEx | MAC regex pattern string
NameRegEx | Hostname regex pattern string

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


IpRegEx Property

DhcpClientFilter..::.IpRegEx Property
DhcpClientFilter Class See Also Send Feedback
IP regex pattern string

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string IpRegEx { get; set; }

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


MacRegEx Property

DhcpClientFilter..::.MacRegEx Property
DhcpClientFilter Class See Also Send Feedback
MAC regex pattern string

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MacRegEx { get; set; }

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


NameRegEx Property

DhcpClientFilter..::.NameRegEx Property
DhcpClientFilter Class See Also Send Feedback
Hostname regex pattern string

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string NameRegEx { get; set; }

See Also

DhcpClientFilter Class
Unf.Dhcp.Smo Namespace


DhcpException Class

DhcpException Class
Members See Also Send Feedback
Dhcp specific exception object

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpException : ApplicationException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.ApplicationException
Unf.Dhcp.Smo..::.DhcpException

See Also

DhcpException Members
Unf.Dhcp.Smo Namespace


DhcpException Members

[image]

DHCP Server Management Objects
DhcpException Members
DhcpException Class Constructors Properties See Also Send Feedback

The DhcpException type exposes the following members.

Constructors

Name | Description
DhcpException | Create a new DhcpException based on error code

Properties

Name | Description
Message | Message string based on error code from constructor (Overrides Exception ..::. Message.)

See Also

DhcpException Class
Unf.Dhcp.Smo Namespace


DhcpException Constructor

DhcpException Constructor
DhcpException Class See Also Send Feedback
Create a new DhcpException based on error code

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpException(
    uint code
)

Parameters

code
Type: System..::.UInt32
A DHCPSAPI or WIN32 error code

See Also

DhcpException Class
Unf.Dhcp.Smo Namespace


DhcpException Properties

[image]

DHCP Server Management Objects
DhcpException Properties
DhcpException Class See Also Send Feedback

The DhcpException type exposes the following members.

Properties

Name | Description
Message | Message string based on error code from constructor (Overrides Exception ..::. Message.)

See Also

DhcpException Class
Unf.Dhcp.Smo Namespace


Message Property

DhcpException..::.Message Property
DhcpException Class See Also Send Feedback
Message string based on error code from constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string Message { get; }

Implements

_Exception..::.Message

See Also

DhcpException Class
Unf.Dhcp.Smo Namespace


DhcpIpAddress Class

DhcpIpAddress Class
Members See Also Send Feedback
Provides an IP address for the DHCP SMO library

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpIpAddress

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpIpAddress

See Also

DhcpIpAddress Members
Unf.Dhcp.Smo Namespace


DhcpIpAddress Members

[image]

DHCP Server Management Objects
DhcpIpAddress Members
DhcpIpAddress Class Constructors Methods Properties See Also Send Feedback

The DhcpIpAddress type exposes the following members.

Constructors

Name | Description
DhcpIpAddress | Overloaded.

Methods

Name | Description
GetUIntAddress | Gets this Ip in uint form
Str2UInt | Converts a string form IP address to its uint form
ToString | IP address in string form w.x.y.z (Overrides Object ..::. ToString()()().)
UInt2Str | Converts a uint form IP address to its string form

Properties

Name | Description
Ip | IP address in string form w.x.y.z

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


DhcpIpAddress Constructor

[image]

DHCP Server Management Objects
DhcpIpAddress Constructor
DhcpIpAddress Class See Also Send Feedback

Overload List

Name | Description
DhcpIpAddress()()() | Sets Ip string to 0.0.0.0
DhcpIpAddress(String) | Sets Ip to IpString
DhcpIpAddress(UInt32) | Sets Ip from an UInt representation

See Also

DhcpIpAddress Class
DhcpIpAddress Members
Unf.Dhcp.Smo Namespace


DhcpIpAddress Constructor

DhcpIpAddress Constructor
DhcpIpAddress Class See Also Send Feedback
Sets Ip string to 0.0.0.0

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress()

See Also

DhcpIpAddress Class
DhcpIpAddress Overload
Unf.Dhcp.Smo Namespace


DhcpIpAddress Constructor (String)

DhcpIpAddress Constructor (String)
DhcpIpAddress Class See Also Send Feedback
Sets Ip to IpString

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress(
    string IpString
)

Parameters

IpString
Type: System..::.String
IP address in string form

See Also

DhcpIpAddress Class
DhcpIpAddress Overload
Unf.Dhcp.Smo Namespace


DhcpIpAddress Constructor (UInt32)

DhcpIpAddress Constructor (UInt32)
DhcpIpAddress Class See Also Send Feedback
Sets Ip from an UInt representation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress(
    uint IpUInt
)

Parameters

IpUInt
Type: System..::.UInt32
IP address in uint form

See Also

DhcpIpAddress Class
DhcpIpAddress Overload
Unf.Dhcp.Smo Namespace


DhcpIpAddress Methods

[image]

DHCP Server Management Objects
DhcpIpAddress Methods
DhcpIpAddress Class See Also Send Feedback

The DhcpIpAddress type exposes the following members.

Methods

Name | Description
GetUIntAddress | Gets this Ip in uint form
Str2UInt | Converts a string form IP address to its uint form
ToString | IP address in string form w.x.y.z (Overrides Object ..::. ToString()()().)
UInt2Str | Converts a uint form IP address to its string form

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


GetUIntAddress Method

DhcpIpAddress..::.GetUIntAddress Method
DhcpIpAddress Class See Also Send Feedback
Gets this Ip in uint form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint GetUIntAddress()

Return Value

IP address in uint form

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


Str2UInt Method

DhcpIpAddress..::.Str2UInt Method
DhcpIpAddress Class See Also Send Feedback
Converts a string form IP address to its uint form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static uint Str2UInt(
    string IpString
)

Parameters

IpString
Type: System..::.String
String IP to convert

Return Value

IP address converted to unit form

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


ToString Method

DhcpIpAddress..::.ToString Method
DhcpIpAddress Class See Also Send Feedback
IP address in string form w.x.y.z

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()

Return Value

IP address in string form w.x.y.z

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


UInt2Str Method

DhcpIpAddress..::.UInt2Str Method
DhcpIpAddress Class See Also Send Feedback
Converts a uint form IP address to its string form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string UInt2Str(
    uint IpUInt
)

Parameters

IpUInt
Type: System..::.UInt32
Uint IP to convert

Return Value

IP address converted to string form

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


DhcpIpAddress Properties

[image]

DHCP Server Management Objects
DhcpIpAddress Properties
DhcpIpAddress Class See Also Send Feedback

The DhcpIpAddress type exposes the following members.

Properties

Name | Description
Ip | IP address in string form w.x.y.z

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


Ip Property

DhcpIpAddress..::.Ip Property
DhcpIpAddress Class See Also Send Feedback
IP address in string form w.x.y.z

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Ip { get; set; }

See Also

DhcpIpAddress Class
Unf.Dhcp.Smo Namespace


DhcpIpRange Class

DhcpIpRange Class
Members See Also Send Feedback
Defines a IP range used for a subnet element (feature)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpIpRange : DhcpSubnetElementData

Remarks

This class supports types: DhcpIpRanges, DhcpExcludedIpRanges, or DhcpIpRangesDhcpOnly

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnetElementData
Unf.Dhcp.Smo..::.DhcpIpRange
Unf.Dhcp.Smo..::.BootpIpRange

See Also

DhcpIpRange Members
Unf.Dhcp.Smo Namespace


DhcpIpRange Members

[image]

DHCP Server Management Objects
DhcpIpRange Members
DhcpIpRange Class Constructors Methods Fields See Also Send Feedback

The DhcpIpRange type exposes the following members.

Constructors

Name | Description
DhcpIpRange | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpSubnetElementData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
EndAddress | End IP of range
StartAddress | Start IP of range
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


DhcpIpRange Constructor

[image]

DHCP Server Management Objects
DhcpIpRange Constructor
DhcpIpRange Class See Also Send Feedback

Overload List

Name | Description
DhcpIpRange()()() | Dummy constructor
DhcpIpRange(DHCP_SUBNET_ELEMENT_DATA_V5) | Internal constructor to create a SMO DhcpIpRange from its native form
DhcpIpRange(DhcpSubnetElementDataType) | Sets new DhcpIpRange to type

See Also

DhcpIpRange Class
DhcpIpRange Members
Unf.Dhcp.Smo Namespace


DhcpIpRange Constructor

DhcpIpRange Constructor
DhcpIpRange Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpRange()

See Also

DhcpIpRange Class
DhcpIpRange Overload
Unf.Dhcp.Smo Namespace


DhcpIpRange Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)

DhcpIpRange Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)
DhcpIpRange Class See Also Send Feedback
Internal constructor to create a SMO DhcpIpRange from its native form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpIpRange(
    DHCP_SUBNET_ELEMENT_DATA_V5 nativeElement
)

Parameters

nativeElement
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5
A native DHCP IP range subnet element

See Also

DhcpIpRange Class
DhcpIpRange Overload
Unf.Dhcp.Smo Namespace


DhcpIpRange Constructor (DhcpSubnetElementDataType)

DhcpIpRange Constructor (DhcpSubnetElementDataType)
DhcpIpRange Class See Also Send Feedback
Sets new DhcpIpRange to type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpRange(
    DhcpSubnetElementDataType type
)

Parameters

type
Type: Unf.Dhcp.Smo..::.DhcpSubnetElementDataType
Type of new DhcpIpRange

See Also

DhcpIpRange Class
DhcpIpRange Overload
Unf.Dhcp.Smo Namespace


DhcpIpRange Fields

[image]

DHCP Server Management Objects
DhcpIpRange Fields
DhcpIpRange Class See Also Send Feedback

The DhcpIpRange type exposes the following members.

Fields

Name | Description
EndAddress | End IP of range
StartAddress | Start IP of range
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


EndAddress Field

DhcpIpRange..::.EndAddress Field
DhcpIpRange Class See Also Send Feedback
End IP of range

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress EndAddress

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


StartAddress Field

DhcpIpRange..::.StartAddress Field
DhcpIpRange Class See Also Send Feedback
Start IP of range

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress StartAddress

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


DhcpIpRange Methods

[image]

DHCP Server Management Objects
DhcpIpRange Methods
DhcpIpRange Class See Also Send Feedback

The DhcpIpRange type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpSubnetElementData ..::. ConvertToNative(MemManager).)

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpIpRange..::.ConvertToNative Method
DhcpIpRange Class See Also Send Feedback
Converts this object to its native subnet element form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_SUBNET_ELEMENT_DATA_V5 ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memeroy allocations

Return Value

A native DHCP IP range subnet element

Remarks

Requires StartAddress, EndAddress and proper type to be set before calling

See Also

DhcpIpRange Class
Unf.Dhcp.Smo Namespace


DhcpIpReservation Class

DhcpIpReservation Class
Members See Also Send Feedback
Defines a DHCP IP reservation subenet element

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpIpReservation : DhcpSubnetElementData

Remarks

This class supports type: DhcpReservedIps

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnetElementData
Unf.Dhcp.Smo..::.DhcpIpReservation

See Also

DhcpIpReservation Members
Unf.Dhcp.Smo Namespace


DhcpIpReservation Members

[image]

DHCP Server Management Objects
DhcpIpReservation Members
DhcpIpReservation Class Constructors Methods Fields See Also Send Feedback

The DhcpIpReservation type exposes the following members.

Constructors

Name | Description
DhcpIpReservation | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpSubnetElementData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
bAllowedClientTypes | Reservation client type (DHCP, BOOTP, or Both)
ReservedIp | Reservation IP address
ReservedMac | Reservation MAC address
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


DhcpIpReservation Constructor

[image]

DHCP Server Management Objects
DhcpIpReservation Constructor
DhcpIpReservation Class See Also Send Feedback

Overload List

Name | Description
DhcpIpReservation()()() | Dummy constructor
DhcpIpReservation(DHCP_SUBNET_ELEMENT_DATA_V5) | Internal constructor to create a SMO DhcpIpReservation from its native form

See Also

DhcpIpReservation Class
DhcpIpReservation Members
Unf.Dhcp.Smo Namespace


DhcpIpReservation Constructor

DhcpIpReservation Constructor
DhcpIpReservation Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpReservation()

See Also

DhcpIpReservation Class
DhcpIpReservation Overload
Unf.Dhcp.Smo Namespace


DhcpIpReservation Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)

DhcpIpReservation Constructor (DHCP_SUBNET_ELEMENT_DATA_V5)
DhcpIpReservation Class See Also Send Feedback
Internal constructor to create a SMO DhcpIpReservation from its native form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpIpReservation(
    DHCP_SUBNET_ELEMENT_DATA_V5 nativeElement
)

Parameters

nativeElement
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5
A native DHCP IP Reservation subnet element

See Also

DhcpIpReservation Class
DhcpIpReservation Overload
Unf.Dhcp.Smo Namespace


DhcpIpReservation Fields

[image]

DHCP Server Management Objects
DhcpIpReservation Fields
DhcpIpReservation Class See Also Send Feedback

The DhcpIpReservation type exposes the following members.

Fields

Name | Description
bAllowedClientTypes | Reservation client type (DHCP, BOOTP, or Both)
ReservedIp | Reservation IP address
ReservedMac | Reservation MAC address
Type | Subnet element data type (Inherited from DhcpSubnetElementData.)

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


bAllowedClientTypes Field

DhcpIpReservation..::.bAllowedClientTypes Field
DhcpIpReservation Class See Also Send Feedback
Reservation client type (DHCP, BOOTP, or Both)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetClientType bAllowedClientTypes

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


ReservedIp Field

DhcpIpReservation..::.ReservedIp Field
DhcpIpReservation Class See Also Send Feedback
Reservation IP address

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress ReservedIp

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


ReservedMac Field

DhcpIpReservation..::.ReservedMac Field
DhcpIpReservation Class See Also Send Feedback
Reservation MAC address

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress ReservedMac

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


DhcpIpReservation Methods

[image]

DHCP Server Management Objects
DhcpIpReservation Methods
DhcpIpReservation Class See Also Send Feedback

The DhcpIpReservation type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to its native subnet element form (Overrides DhcpSubnetElementData ..::. ConvertToNative(MemManager).)

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpIpReservation..::.ConvertToNative Method
DhcpIpReservation Class See Also Send Feedback
Converts this object to its native subnet element form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_SUBNET_ELEMENT_DATA_V5 ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memeroy allocations

Return Value

A native DHCP IP Reservation subnet element

Remarks

Requires ReservedIp, ReservedMac and proper type to be set before calling

See Also

DhcpIpReservation Class
Unf.Dhcp.Smo Namespace


DhcpMacAddress Class

DhcpMacAddress Class
Members See Also Send Feedback
Provides a MAC address for the DHCP SMO library

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpMacAddress

Remarks

Accepted formats: 00:01:02:0a:0B:0c, 00-01-02-0a-0B-0c, or 0001020a0B0c

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpMacAddress

See Also

DhcpMacAddress Members
Unf.Dhcp.Smo Namespace


DhcpMacAddress Members

[image]

DHCP Server Management Objects
DhcpMacAddress Members
DhcpMacAddress Class Constructors Methods Properties See Also Send Feedback

The DhcpMacAddress type exposes the following members.

Constructors

Name | Description
DhcpMacAddress | Overloaded.

Methods

Name | Description
GetByteArray | Gets Mac address in byte array form
ToString | Mac address in string form (Overrides Object ..::. ToString()()().)

Properties

Name | Description
Mac | Mac address in string form 0001020A0B0C

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


DhcpMacAddress Constructor

[image]

DHCP Server Management Objects
DhcpMacAddress Constructor
DhcpMacAddress Class See Also Send Feedback

Overload List

Name | Description
DhcpMacAddress()()() | Sets Mac to zeros
DhcpMacAddress(array<Byte>[]()[]) | Sets Mac to MacBytes
DhcpMacAddress(String) | Sets Mac to MacString

See Also

DhcpMacAddress Class
DhcpMacAddress Members
Unf.Dhcp.Smo Namespace


DhcpMacAddress Constructor

DhcpMacAddress Constructor
DhcpMacAddress Class See Also Send Feedback
Sets Mac to zeros

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress()

See Also

DhcpMacAddress Class
DhcpMacAddress Overload
Unf.Dhcp.Smo Namespace


DhcpMacAddress Constructor (Byte[])

DhcpMacAddress Constructor (array<Byte>[]()[])
DhcpMacAddress Class See Also Send Feedback
Sets Mac to MacBytes

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress(
    byte[] MacBytes
)

Parameters

MacBytes
Type: array< System..::.Byte >[]()[]
Array of bytes

See Also

DhcpMacAddress Class
DhcpMacAddress Overload
Unf.Dhcp.Smo Namespace


DhcpMacAddress Constructor (String)

DhcpMacAddress Constructor (String)
DhcpMacAddress Class See Also Send Feedback
Sets Mac to MacString

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress(
    string MacString
)

Parameters

MacString
Type: System..::.String
String form of Mac address

Remarks

Accepted formats: 00:01:02:0a:0B:0c, 00-01-02-0a-0B-0c, or 0001020a0B0c

See Also

DhcpMacAddress Class
DhcpMacAddress Overload
Unf.Dhcp.Smo Namespace


DhcpMacAddress Methods

[image]

DHCP Server Management Objects
DhcpMacAddress Methods
DhcpMacAddress Class See Also Send Feedback

The DhcpMacAddress type exposes the following members.

Methods

Name | Description
GetByteArray | Gets Mac address in byte array form
ToString | Mac address in string form (Overrides Object ..::. ToString()()().)

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


GetByteArray Method

DhcpMacAddress..::.GetByteArray Method
DhcpMacAddress Class See Also Send Feedback
Gets Mac address in byte array form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte[] GetByteArray()

Return Value

Byte array form of Mac

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


ToString Method

DhcpMacAddress..::.ToString Method
DhcpMacAddress Class See Also Send Feedback
Mac address in string form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()

Return Value

Mac address in string form

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


DhcpMacAddress Properties

[image]

DHCP Server Management Objects
DhcpMacAddress Properties
DhcpMacAddress Class See Also Send Feedback

The DhcpMacAddress type exposes the following members.

Properties

Name | Description
Mac | Mac address in string form 0001020A0B0C

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


Mac Property

DhcpMacAddress..::.Mac Property
DhcpMacAddress Class See Also Send Feedback
Mac address in string form 0001020A0B0C

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Mac { get; set; }

See Also

DhcpMacAddress Class
Unf.Dhcp.Smo Namespace


DhcpOption Class

DhcpOption Class
Members See Also Send Feedback
Defines a DHCP Option on a DHCP Server. See DhcpOptionValue to assign values to DHCP Options.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOption

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOption

See Also

DhcpOption Members
Unf.Dhcp.Smo Namespace


DhcpOption Members

[image]

DHCP Server Management Objects
DhcpOption Members
DhcpOption Class Constructors Methods Fields See Also Send Feedback

The DhcpOption type exposes the following members.

Constructors

Name | Description
DhcpOption | Dummy constructor

Methods

Name | Description
ConvertFromNative | Convert a native DHCP_OPTION to its SMO form
EnumAll | Enumeration all possible DHCP option on server

Fields

Name | Description
Comment | Option description
DataType | Option data type
isArray | Is option value an array of values
Name | Option name
OptionId | DHCP Option ID, see rfc2132

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


DhcpOption Constructor

DhcpOption Constructor
DhcpOption Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOption()

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


DhcpOption Fields

[image]

DHCP Server Management Objects
DhcpOption Fields
DhcpOption Class See Also Send Feedback

The DhcpOption type exposes the following members.

Fields

Name | Description
Comment | Option description
DataType | Option data type
isArray | Is option value an array of values
Name | Option name
OptionId | DHCP Option ID, see rfc2132

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


Comment Field

DhcpOption..::.Comment Field
DhcpOption Class See Also Send Feedback
Option description

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Comment

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


DataType Field

DhcpOption..::.DataType Field
DhcpOption Class See Also Send Feedback
Option data type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataType DataType

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


isArray Field

DhcpOption..::.isArray Field
DhcpOption Class See Also Send Feedback
Is option value an array of values

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool isArray

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


Name Field

DhcpOption..::.Name Field
DhcpOption Class See Also Send Feedback
Option name

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


OptionId Field

DhcpOption..::.OptionId Field
DhcpOption Class See Also Send Feedback
DHCP Option ID, see rfc2132

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint OptionId

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


DhcpOption Methods

[image]

DHCP Server Management Objects
DhcpOption Methods
DhcpOption Class See Also Send Feedback

The DhcpOption type exposes the following members.

Methods

Name | Description
ConvertFromNative | Convert a native DHCP_OPTION to its SMO form
EnumAll | Enumeration all possible DHCP option on server

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


ConvertFromNative Method

DhcpOption..::.ConvertFromNative Method
DhcpOption Class See Also Send Feedback
Convert a native DHCP_OPTION to its SMO form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static DhcpOption ConvertFromNative(
    DHCP_OPTION nativeOption
)

Parameters

nativeOption
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION
Native option to convert

Return Value

SMO DHCP option

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


EnumAll Method

DhcpOption..::.EnumAll Method
DhcpOption Class See Also Send Feedback
Enumeration all possible DHCP option on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOption[] EnumAll(
    DhcpIpAddress server,
    DhcpOptionClassType OptionClass
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to enumerate
OptionClass
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
Class of options

Return Value

An array of DHCP option found on server

See Also

DhcpOption Class
Unf.Dhcp.Smo Namespace


DhcpOptionClassHash Class

DhcpOptionClassHash Class
Members See Also Send Feedback
Helper class to convert SMO enum option class types to native type strings

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static class DhcpOptionClassHash

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionClassHash

See Also

DhcpOptionClassHash Members
Unf.Dhcp.Smo Namespace


DhcpOptionClassHash Members

[image]

DHCP Server Management Objects
DhcpOptionClassHash Members
DhcpOptionClassHash Class Fields See Also Send Feedback

The DhcpOptionClassHash type exposes the following members.

Fields

Name | Description
ht | Mapping table

See Also

DhcpOptionClassHash Class
Unf.Dhcp.Smo Namespace


DhcpOptionClassHash Fields

[image]

DHCP Server Management Objects
DhcpOptionClassHash Fields
DhcpOptionClassHash Class See Also Send Feedback

The DhcpOptionClassHash type exposes the following members.

Fields

Name | Description
ht | Mapping table

See Also

DhcpOptionClassHash Class
Unf.Dhcp.Smo Namespace


ht Field

DhcpOptionClassHash..::.ht Field
DhcpOptionClassHash Class See Also Send Feedback
Mapping table

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static Hashtable ht

See Also

DhcpOptionClassHash Class
Unf.Dhcp.Smo Namespace


DhcpOptionClassType Enumeration

DhcpOptionClassType Enumeration
See Also Send Feedback
Option class types

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpOptionClassType

Members

Member name | Description
Dhcp | DHCP standard option class
Bootp | BOOTP standard option class
Routing | Routing and Remote Access standard option class

See Also

Unf.Dhcp.Smo Namespace


DhcpOptionData Class

DhcpOptionData Class
Members See Also Send Feedback
Base class for all DhcpOptionData* types

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataByte
Unf.Dhcp.Smo..::.DhcpOptionDataIp
Unf.Dhcp.Smo..::.DhcpOptionDataWord
Unf.Dhcp.Smo..::.DhcpOptionDataDword
Unf.Dhcp.Smo..::.DhcpOptionDataDwordDword
Unf.Dhcp.Smo..::.DhcpOptionDataString

See Also

DhcpOptionData Members
Unf.Dhcp.Smo Namespace


DhcpOptionData Members

[image]

DHCP Server Management Objects
DhcpOptionData Members
DhcpOptionData Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionData type exposes the following members.

Constructors

Name | Description
DhcpOptionData | Overloaded.

Methods

Name | Description
ConvertToNative | Each OptionData* converts their own data type of a native type
CovertFromNative | Converts a native option data to its SMO representation based on type

Fields

Name | Description
Type | Data type

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


DhcpOptionData Constructor

[image]

DHCP Server Management Objects
DhcpOptionData Constructor
DhcpOptionData Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionData()()() | Dummy constructor
DhcpOptionData(DhcpOptionDataType) | Create base option data and type

See Also

DhcpOptionData Class
DhcpOptionData Members
Unf.Dhcp.Smo Namespace


DhcpOptionData Constructor

DhcpOptionData Constructor
DhcpOptionData Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionData()

See Also

DhcpOptionData Class
DhcpOptionData Overload
Unf.Dhcp.Smo Namespace


DhcpOptionData Constructor (DhcpOptionDataType)

DhcpOptionData Constructor (DhcpOptionDataType)
DhcpOptionData Class See Also Send Feedback
Create base option data and type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionData(
    DhcpOptionDataType type
)

Parameters

type
Type: Unf.Dhcp.Smo..::.DhcpOptionDataType
Type of data

See Also

DhcpOptionData Class
DhcpOptionData Overload
Unf.Dhcp.Smo Namespace


DhcpOptionData Fields

[image]

DHCP Server Management Objects
DhcpOptionData Fields
DhcpOptionData Class See Also Send Feedback

The DhcpOptionData type exposes the following members.

Fields

Name | Description
Type | Data type

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


Type Field

DhcpOptionData..::.Type Field
DhcpOptionData Class See Also Send Feedback
Data type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataType Type

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


DhcpOptionData Methods

[image]

DHCP Server Management Objects
DhcpOptionData Methods
DhcpOptionData Class See Also Send Feedback

The DhcpOptionData type exposes the following members.

Methods

Name | Description
ConvertToNative | Each OptionData* converts their own data type of a native type
CovertFromNative | Converts a native option data to its SMO representation based on type

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionData..::.ConvertToNative Method
DhcpOptionData Class See Also Send Feedback
Each OptionData* converts their own data type of a native type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal abstract DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations

Return Value

A native DHCP option data

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


CovertFromNative Method

DhcpOptionData..::.CovertFromNative Method
DhcpOptionData Class See Also Send Feedback
Converts a native option data to its SMO representation based on type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static DhcpOptionData CovertFromNative(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native option data to be converted

Return Value

SMO option data

See Also

DhcpOptionData Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Class

DhcpOptionDataByte Class
Members See Also Send Feedback
Defines DHCP option data of byte type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataByte : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataByte

See Also

DhcpOptionDataByte Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Members

[image]

DHCP Server Management Objects
DhcpOptionDataByte Members
DhcpOptionDataByte Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataByte type exposes the following members.

Constructors

Name | Description
DhcpOptionDataByte | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of byte data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataByte Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataByte Constructor
DhcpOptionDataByte Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataByte()()() | Creates null data
DhcpOptionDataByte(array<Byte>[]()[]) | Sets Data with bytes
DhcpOptionDataByte(DHCP_OPTION_DATA) | Create object using native option data

See Also

DhcpOptionDataByte Class
DhcpOptionDataByte Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Constructor

DhcpOptionDataByte Constructor
DhcpOptionDataByte Class See Also Send Feedback
Creates null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataByte()

See Also

DhcpOptionDataByte Class
DhcpOptionDataByte Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Constructor (Byte[])

DhcpOptionDataByte Constructor (array<Byte>[]()[])
DhcpOptionDataByte Class See Also Send Feedback
Sets Data with bytes

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataByte(
    byte[] bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
Byte array to set data with

See Also

DhcpOptionDataByte Class
DhcpOptionDataByte Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Constructor (DHCP_OPTION_DATA)

DhcpOptionDataByte Constructor (DHCP_OPTION_DATA)
DhcpOptionDataByte Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataByte(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataByte Class
DhcpOptionDataByte Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Fields

[image]

DHCP Server Management Objects
DhcpOptionDataByte Fields
DhcpOptionDataByte Class See Also Send Feedback

The DhcpOptionDataByte type exposes the following members.

Fields

Name | Description
Data | Array of byte data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataByte Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataByte..::.Data Field
DhcpOptionDataByte Class See Also Send Feedback
Array of byte data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte[] Data

See Also

DhcpOptionDataByte Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataByte Methods

[image]

DHCP Server Management Objects
DhcpOptionDataByte Methods
DhcpOptionDataByte Class See Also Send Feedback

The DhcpOptionDataByte type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataByte Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataByte..::.ConvertToNative Method
DhcpOptionDataByte Class See Also Send Feedback
Converts this object to native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataByte Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Class

DhcpOptionDataDword Class
Members See Also Send Feedback
Defines DHCP option data of UInt32 type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataDword : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataDword

See Also

DhcpOptionDataDword Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Members

[image]

DHCP Server Management Objects
DhcpOptionDataDword Members
DhcpOptionDataDword Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataDword type exposes the following members.

Constructors

Name | Description
DhcpOptionDataDword | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and DWORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of UInt32 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataDword Constructor
DhcpOptionDataDword Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataDword()()() | Create null data
DhcpOptionDataDword(array<UInt32>[]()[]) | Sets Data to dwords array
DhcpOptionDataDword(DHCP_OPTION_DATA) | Create object using native option data

See Also

DhcpOptionDataDword Class
DhcpOptionDataDword Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Constructor

DhcpOptionDataDword Constructor
DhcpOptionDataDword Class See Also Send Feedback
Create null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataDword()

See Also

DhcpOptionDataDword Class
DhcpOptionDataDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Constructor (UInt32[])

DhcpOptionDataDword Constructor (array<UInt32>[]()[])
DhcpOptionDataDword Class See Also Send Feedback
Sets Data to dwords array

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataDword(
    uint[] dwords
)

Parameters

dwords
Type: array< System..::.UInt32 >[]()[]
Array of UInt32 to set Data with

See Also

DhcpOptionDataDword Class
DhcpOptionDataDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Constructor (DHCP_OPTION_DATA)

DhcpOptionDataDword Constructor (DHCP_OPTION_DATA)
DhcpOptionDataDword Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataDword(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataDword Class
DhcpOptionDataDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Fields

[image]

DHCP Server Management Objects
DhcpOptionDataDword Fields
DhcpOptionDataDword Class See Also Send Feedback

The DhcpOptionDataDword type exposes the following members.

Fields

Name | Description
Data | Array of UInt32 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataDword Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataDword..::.Data Field
DhcpOptionDataDword Class See Also Send Feedback
Array of UInt32 data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint[] Data

See Also

DhcpOptionDataDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDword Methods

[image]

DHCP Server Management Objects
DhcpOptionDataDword Methods
DhcpOptionDataDword Class See Also Send Feedback

The DhcpOptionDataDword type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and DWORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataDword Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataDword..::.ConvertToNative Method
DhcpOptionDataDword Class See Also Send Feedback
Converts this object to native option data and DWORD type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Class

DhcpOptionDataDwordDword Class
Members See Also Send Feedback
Defines DHCP option data of UInt64 type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataDwordDword : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataDwordDword

See Also

DhcpOptionDataDwordDword Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Members

[image]

DHCP Server Management Objects
DhcpOptionDataDwordDword Members
DhcpOptionDataDwordDword Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataDwordDword type exposes the following members.

Constructors

Name | Description
DhcpOptionDataDwordDword | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and DWORD_DWORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of UInt64 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataDwordDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataDwordDword Constructor
DhcpOptionDataDwordDword Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataDwordDword()()() | Create null data
DhcpOptionDataDwordDword(array<UInt64>[]()[]) | Set Data to array of ddwords
DhcpOptionDataDwordDword(DHCP_OPTION_DATA) | Create object using native option data

See Also

DhcpOptionDataDwordDword Class
DhcpOptionDataDwordDword Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Constructor

DhcpOptionDataDwordDword Constructor
DhcpOptionDataDwordDword Class See Also Send Feedback
Create null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataDwordDword()

See Also

DhcpOptionDataDwordDword Class
DhcpOptionDataDwordDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Constructor (UInt64[])

DhcpOptionDataDwordDword Constructor (array<UInt64>[]()[])
DhcpOptionDataDwordDword Class See Also Send Feedback
Set Data to array of ddwords

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataDwordDword(
    ulong[] ddwords
)

Parameters

ddwords
Type: array< System..::.UInt64 >[]()[]
Array of UInt64 to set Data with

See Also

DhcpOptionDataDwordDword Class
DhcpOptionDataDwordDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Constructor (DHCP_OPTION_DATA)

DhcpOptionDataDwordDword Constructor (DHCP_OPTION_DATA)
DhcpOptionDataDwordDword Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataDwordDword(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataDwordDword Class
DhcpOptionDataDwordDword Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Fields

[image]

DHCP Server Management Objects
DhcpOptionDataDwordDword Fields
DhcpOptionDataDwordDword Class See Also Send Feedback

The DhcpOptionDataDwordDword type exposes the following members.

Fields

Name | Description
Data | Array of UInt64 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataDwordDword Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataDwordDword..::.Data Field
DhcpOptionDataDwordDword Class See Also Send Feedback
Array of UInt64 data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ulong[] Data

See Also

DhcpOptionDataDwordDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataDwordDword Methods

[image]

DHCP Server Management Objects
DhcpOptionDataDwordDword Methods
DhcpOptionDataDwordDword Class See Also Send Feedback

The DhcpOptionDataDwordDword type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and DWORD_DWORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataDwordDword Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataDwordDword..::.ConvertToNative Method
DhcpOptionDataDwordDword Class See Also Send Feedback
Converts this object to native option data and DWORD_DWORD type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataDwordDword Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Class

DhcpOptionDataIp Class
Members See Also Send Feedback
Defines DHCP option data of DhcpIpAddress type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataIp : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataIp

See Also

DhcpOptionDataIp Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Members

[image]

DHCP Server Management Objects
DhcpOptionDataIp Members
DhcpOptionDataIp Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataIp type exposes the following members.

Constructors

Name | Description
DhcpOptionDataIp | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and IpAdress type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of DhcpIpAddres data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataIp Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataIp Constructor
DhcpOptionDataIp Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataIp()()() | Creates null data
DhcpOptionDataIp(DHCP_OPTION_DATA) | Create object using native option data
DhcpOptionDataIp(array<DhcpIpAddress>[]()[]) | Sets Data with address array

See Also

DhcpOptionDataIp Class
DhcpOptionDataIp Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Constructor

DhcpOptionDataIp Constructor
DhcpOptionDataIp Class See Also Send Feedback
Creates null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataIp()

See Also

DhcpOptionDataIp Class
DhcpOptionDataIp Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Constructor (DHCP_OPTION_DATA)

DhcpOptionDataIp Constructor (DHCP_OPTION_DATA)
DhcpOptionDataIp Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataIp(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataIp Class
DhcpOptionDataIp Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Constructor (DhcpIpAddress[])

DhcpOptionDataIp Constructor (array<DhcpIpAddress>[]()[])
DhcpOptionDataIp Class See Also Send Feedback
Sets Data with address array

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataIp(
    DhcpIpAddress[] ips
)

Parameters

ips
Type: array< Unf.Dhcp.Smo..::.DhcpIpAddress >[]()[]
Array of DhcpIpAddress to set Data with

See Also

DhcpOptionDataIp Class
DhcpOptionDataIp Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Fields

[image]

DHCP Server Management Objects
DhcpOptionDataIp Fields
DhcpOptionDataIp Class See Also Send Feedback

The DhcpOptionDataIp type exposes the following members.

Fields

Name | Description
Data | Array of DhcpIpAddres data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataIp Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataIp..::.Data Field
DhcpOptionDataIp Class See Also Send Feedback
Array of DhcpIpAddres data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress[] Data

See Also

DhcpOptionDataIp Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataIp Methods

[image]

DHCP Server Management Objects
DhcpOptionDataIp Methods
DhcpOptionDataIp Class See Also Send Feedback

The DhcpOptionDataIp type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and IpAdress type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataIp Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataIp..::.ConvertToNative Method
DhcpOptionDataIp Class See Also Send Feedback
Converts this object to native option data and IpAdress type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataIp Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Class

DhcpOptionDataString Class
Members See Also Send Feedback
Defines DHCP option data of string type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataString : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataString

See Also

DhcpOptionDataString Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Members

[image]

DHCP Server Management Objects
DhcpOptionDataString Members
DhcpOptionDataString Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataString type exposes the following members.

Constructors

Name | Description
DhcpOptionDataString | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and String type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of String data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataString Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataString Constructor
DhcpOptionDataString Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataString()()() | Create null data
DhcpOptionDataString(array<String>[]()[]) | Sets Data to array of Strings
DhcpOptionDataString(DHCP_OPTION_DATA) | Create object using native option data

See Also

DhcpOptionDataString Class
DhcpOptionDataString Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Constructor

DhcpOptionDataString Constructor
DhcpOptionDataString Class See Also Send Feedback
Create null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataString()

See Also

DhcpOptionDataString Class
DhcpOptionDataString Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Constructor (String[])

DhcpOptionDataString Constructor (array<String>[]()[])
DhcpOptionDataString Class See Also Send Feedback
Sets Data to array of Strings

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataString(
    string[] strings
)

Parameters

strings
Type: array< System..::.String >[]()[]
Array of Stings to set Data with

See Also

DhcpOptionDataString Class
DhcpOptionDataString Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Constructor (DHCP_OPTION_DATA)

DhcpOptionDataString Constructor (DHCP_OPTION_DATA)
DhcpOptionDataString Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataString(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataString Class
DhcpOptionDataString Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Fields

[image]

DHCP Server Management Objects
DhcpOptionDataString Fields
DhcpOptionDataString Class See Also Send Feedback

The DhcpOptionDataString type exposes the following members.

Fields

Name | Description
Data | Array of String data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataString Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataString..::.Data Field
DhcpOptionDataString Class See Also Send Feedback
Array of String data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string[] Data

See Also

DhcpOptionDataString Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataString Methods

[image]

DHCP Server Management Objects
DhcpOptionDataString Methods
DhcpOptionDataString Class See Also Send Feedback

The DhcpOptionDataString type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and String type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataString Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataString..::.ConvertToNative Method
DhcpOptionDataString Class See Also Send Feedback
Converts this object to native option data and String type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataString Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataType Enumeration

DhcpOptionDataType Enumeration
See Also Send Feedback
DHCP option data types

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpOptionDataType

Members

Member name | Description
ByteType | Option data of byte type
WordType | Option data of UInt16 type
DWordType | Option data of UInt32 type
DWordDWordType | Option data of UInt64 type
IpAddressType | Option data of DhcpIpAddress type
StringDataType | Option data of string type

Remarks

BinaryDataType, EncapsulatedDataType, and Ipv6AddressType not implemented

See Also

Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Class

DhcpOptionDataWord Class
Members See Also Send Feedback
Defines DHCP option data of UInt16 type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionDataWord : DhcpOptionData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionData
Unf.Dhcp.Smo..::.DhcpOptionDataWord

See Also

DhcpOptionDataWord Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Members

[image]

DHCP Server Management Objects
DhcpOptionDataWord Members
DhcpOptionDataWord Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionDataWord type exposes the following members.

Constructors

Name | Description
DhcpOptionDataWord | Overloaded.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and WORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

Fields

Name | Description
Data | Array of UInt16 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataWord Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Constructor

[image]

DHCP Server Management Objects
DhcpOptionDataWord Constructor
DhcpOptionDataWord Class See Also Send Feedback

Overload List

Name | Description
DhcpOptionDataWord()()() | Create null data
DhcpOptionDataWord(array<UInt16>[]()[]) | Set Data to words array
DhcpOptionDataWord(DHCP_OPTION_DATA) | Create object using native option data

See Also

DhcpOptionDataWord Class
DhcpOptionDataWord Members
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Constructor

DhcpOptionDataWord Constructor
DhcpOptionDataWord Class See Also Send Feedback
Create null data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataWord()

See Also

DhcpOptionDataWord Class
DhcpOptionDataWord Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Constructor (UInt16[])

DhcpOptionDataWord Constructor (array<UInt16>[]()[])
DhcpOptionDataWord Class See Also Send Feedback
Set Data to words array

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionDataWord(
    ushort[] words
)

Parameters

words
Type: array< System..::.UInt16 >[]()[]
Array of UInt16 to set Data with

See Also

DhcpOptionDataWord Class
DhcpOptionDataWord Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Constructor (DHCP_OPTION_DATA)

DhcpOptionDataWord Constructor (DHCP_OPTION_DATA)
DhcpOptionDataWord Class See Also Send Feedback
Create object using native option data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DhcpOptionDataWord(
    DHCP_OPTION_DATA NativeOptData
)

Parameters

NativeOptData
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA
Native DHCP option data

See Also

DhcpOptionDataWord Class
DhcpOptionDataWord Overload
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Fields

[image]

DHCP Server Management Objects
DhcpOptionDataWord Fields
DhcpOptionDataWord Class See Also Send Feedback

The DhcpOptionDataWord type exposes the following members.

Fields

Name | Description
Data | Array of UInt16 data
Type | Data type (Inherited from DhcpOptionData.)

See Also

DhcpOptionDataWord Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpOptionDataWord..::.Data Field
DhcpOptionDataWord Class See Also Send Feedback
Array of UInt16 data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ushort[] Data

See Also

DhcpOptionDataWord Class
Unf.Dhcp.Smo Namespace


DhcpOptionDataWord Methods

[image]

DHCP Server Management Objects
DhcpOptionDataWord Methods
DhcpOptionDataWord Class See Also Send Feedback

The DhcpOptionDataWord type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to native option data and WORD type (Overrides DhcpOptionData ..::. ConvertToNative(MemManager).)

See Also

DhcpOptionDataWord Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionDataWord..::.ConvertToNative Method
DhcpOptionDataWord Class See Also Send Feedback
Converts this object to native option data and WORD type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal override DHCP_OPTION_DATA ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations to free later

Return Value

A native DHCP option data

See Also

DhcpOptionDataWord Class
Unf.Dhcp.Smo Namespace


DhcpOptionScope Class

DhcpOptionScope Class
Members See Also Send Feedback
Defines an assignment scope for DHCP options

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionScope

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionScope

See Also

DhcpOptionScope Members
Unf.Dhcp.Smo Namespace


DhcpOptionScope Members

[image]

DHCP Server Management Objects
DhcpOptionScope Members
DhcpOptionScope Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionScope type exposes the following members.

Constructors

Name | Description
DhcpOptionScope | Dummy constructor

Methods

Name | Description
ConvertToNative | Convert this object to its native form

Fields

Name | Description
ReservationIp | Reserveration IP address (used if reservation type)
SubnetIp | Subnet network IP address (used if subnet or reservation type)
type | Type of scope (Server, Subnet, Reservation)

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


DhcpOptionScope Constructor

DhcpOptionScope Constructor
DhcpOptionScope Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionScope()

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


DhcpOptionScope Fields

[image]

DHCP Server Management Objects
DhcpOptionScope Fields
DhcpOptionScope Class See Also Send Feedback

The DhcpOptionScope type exposes the following members.

Fields

Name | Description
ReservationIp | Reserveration IP address (used if reservation type)
SubnetIp | Subnet network IP address (used if subnet or reservation type)
type | Type of scope (Server, Subnet, Reservation)

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


ReservationIp Field

DhcpOptionScope..::.ReservationIp Field
DhcpOptionScope Class See Also Send Feedback
Reserveration IP address (used if reservation type)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress ReservationIp

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


SubnetIp Field

DhcpOptionScope..::.SubnetIp Field
DhcpOptionScope Class See Also Send Feedback
Subnet network IP address (used if subnet or reservation type)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress SubnetIp

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


type Field

DhcpOptionScope..::.type Field
DhcpOptionScope Class See Also Send Feedback
Type of scope (Server, Subnet, Reservation)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionScopeType type

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


DhcpOptionScope Methods

[image]

DHCP Server Management Objects
DhcpOptionScope Methods
DhcpOptionScope Class See Also Send Feedback

The DhcpOptionScope type exposes the following members.

Methods

Name | Description
ConvertToNative | Convert this object to its native form

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpOptionScope..::.ConvertToNative Method
DhcpOptionScope Class See Also Send Feedback
Convert this object to its native form

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DHCP_OPTION_SCOPE_INFO ConvertToNative()

Return Value

A native scope info

See Also

DhcpOptionScope Class
Unf.Dhcp.Smo Namespace


DhcpOptionScopeType Enumeration

DhcpOptionScopeType Enumeration
See Also Send Feedback
DHCP option scope types

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpOptionScopeType

Members

Member name | Description
Server | Server options
Subnet | Subnet options
Reservation | Reservation options

See Also

Unf.Dhcp.Smo Namespace


DhcpOptionValue Class

DhcpOptionValue Class
Members See Also Send Feedback
Defines a DHCP Option's value(s). See DhcpOption for DHCP Option definitions.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpOptionValue

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpOptionValue

See Also

DhcpOptionValue Members
Unf.Dhcp.Smo Namespace


DhcpOptionValue Members

[image]

DHCP Server Management Objects
DhcpOptionValue Members
DhcpOptionValue Class Constructors Methods Fields See Also Send Feedback

The DhcpOptionValue type exposes the following members.

Constructors

Name | Description
DhcpOptionValue | Dummy constructor

Methods

Name | Description
EnumAll | Enumerates all option values on server based on scope and class
Get | Get DHCP option value from server
Remove | Removes DHCP option from server
Set | Sets DHCP option value on server

Fields

Name | Description
ClassType | DHCP option class (Dhcp, Bootp, Routing)
OptionData | Option data value(s)
OptionId | DHCP Option ID, see rfc2132
OptionScope | Scope option value belongs to (Server, Subnet, Reservation)

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


DhcpOptionValue Constructor

DhcpOptionValue Constructor
DhcpOptionValue Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionValue()

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


DhcpOptionValue Fields

[image]

DHCP Server Management Objects
DhcpOptionValue Fields
DhcpOptionValue Class See Also Send Feedback

The DhcpOptionValue type exposes the following members.

Fields

Name | Description
ClassType | DHCP option class (Dhcp, Bootp, Routing)
OptionData | Option data value(s)
OptionId | DHCP Option ID, see rfc2132
OptionScope | Scope option value belongs to (Server, Subnet, Reservation)

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


ClassType Field

DhcpOptionValue..::.ClassType Field
DhcpOptionValue Class See Also Send Feedback
DHCP option class (Dhcp, Bootp, Routing)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionClassType ClassType

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


OptionData Field

DhcpOptionValue..::.OptionData Field
DhcpOptionValue Class See Also Send Feedback
Option data value(s)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionData OptionData

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


OptionId Field

DhcpOptionValue..::.OptionId Field
DhcpOptionValue Class See Also Send Feedback
DHCP Option ID, see rfc2132

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint OptionId

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


OptionScope Field

DhcpOptionValue..::.OptionScope Field
DhcpOptionValue Class See Also Send Feedback
Scope option value belongs to (Server, Subnet, Reservation)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOptionScope OptionScope

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


DhcpOptionValue Methods

[image]

DHCP Server Management Objects
DhcpOptionValue Methods
DhcpOptionValue Class See Also Send Feedback

The DhcpOptionValue type exposes the following members.

Methods

Name | Description
EnumAll | Enumerates all option values on server based on scope and class
Get | Get DHCP option value from server
Remove | Removes DHCP option from server
Set | Sets DHCP option value on server

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


EnumAll Method

DhcpOptionValue..::.EnumAll Method
DhcpOptionValue Class See Also Send Feedback
Enumerates all option values on server based on scope and class

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOptionValue[] EnumAll(
    DhcpIpAddress Server,
    DhcpOptionClassType OptionClass,
    DhcpOptionScope Scope
)

Parameters

Server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP
OptionClass
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
Class type to enumerate
Scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Defined scope to enumerate

Return Value

An array of DHCP option values

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


Get Method

DhcpOptionValue..::.Get Method
DhcpOptionValue Class See Also Send Feedback
Get DHCP option value from server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Get(
    DhcpIpAddress Server
)

Parameters

Server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

OptionId, OptionScope, and ClassType must be set before calling Get(). OptionData will be set after call

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


Remove Method

DhcpOptionValue..::.Remove Method
DhcpOptionValue Class See Also Send Feedback
Removes DHCP option from server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Remove(
    DhcpIpAddress Server
)

Parameters

Server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

Remove all values from option. OptionId, OptionScope, and ClassType must be set before calling Remove()

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


Set Method

DhcpOptionValue..::.Set Method
DhcpOptionValue Class See Also Send Feedback
Sets DHCP option value on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Set(
    DhcpIpAddress Server
)

Parameters

Server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

Set() creates or updates value. All fields must be set before calling Set()

See Also

DhcpOptionValue Class
Unf.Dhcp.Smo Namespace


DhcpReservation Class

DhcpReservation Class
Members See Also Send Feedback
Define a DHCP reservation. A wrapper class of information combined from a client lease and IP reservation object

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpReservation

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpReservation

See Also

DhcpReservation Members
Unf.Dhcp.Smo Namespace


DhcpReservation Members

[image]

DHCP Server Management Objects
DhcpReservation Members
DhcpReservation Class Constructors Fields See Also Send Feedback

The DhcpReservation type exposes the following members.

Constructors

Name | Description
DhcpReservation | Dummy constructor

Fields

Name | Description
bAllowedClientTypes | Reservation client type (DHCP, BOOTP, or Both)
Comment | Description of reservation
Name | Name of reservation (will be replaced by hostname client get lease)
ReservedIp | IP addres of reservation
ReservedMac | MAC address of reservation

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


DhcpReservation Constructor

DhcpReservation Constructor
DhcpReservation Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpReservation()

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


DhcpReservation Fields

[image]

DHCP Server Management Objects
DhcpReservation Fields
DhcpReservation Class See Also Send Feedback

The DhcpReservation type exposes the following members.

Fields

Name | Description
bAllowedClientTypes | Reservation client type (DHCP, BOOTP, or Both)
Comment | Description of reservation
Name | Name of reservation (will be replaced by hostname client get lease)
ReservedIp | IP addres of reservation
ReservedMac | MAC address of reservation

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


bAllowedClientTypes Field

DhcpReservation..::.bAllowedClientTypes Field
DhcpReservation Class See Also Send Feedback
Reservation client type (DHCP, BOOTP, or Both)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetClientType bAllowedClientTypes

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


Comment Field

DhcpReservation..::.Comment Field
DhcpReservation Class See Also Send Feedback
Description of reservation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Comment

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


Name Field

DhcpReservation..::.Name Field
DhcpReservation Class See Also Send Feedback
Name of reservation (will be replaced by hostname client get lease)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


ReservedIp Field

DhcpReservation..::.ReservedIp Field
DhcpReservation Class See Also Send Feedback
IP addres of reservation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress ReservedIp

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


ReservedMac Field

DhcpReservation..::.ReservedMac Field
DhcpReservation Class See Also Send Feedback
MAC address of reservation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress ReservedMac

See Also

DhcpReservation Class
Unf.Dhcp.Smo Namespace


DhcpSearchInfo Class

DhcpSearchInfo Class
Members See Also Send Feedback
Defines search terms used by DhcpClient methods searching for client leases

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpSearchInfo

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSearchInfo

See Also

DhcpSearchInfo Members
Unf.Dhcp.Smo Namespace


DhcpSearchInfo Members

[image]

DHCP Server Management Objects
DhcpSearchInfo Members
DhcpSearchInfo Class Constructors Methods Fields See Also Send Feedback

The DhcpSearchInfo type exposes the following members.

Constructors

Name | Description
DhcpSearchInfo |

Methods

Name | Description
ConvertToNative | Converts this object to its native representation

Fields

Name | Description
IpAddress | IP address of client
MacAddress | MAC address of client
Name | Hostname of client
Type | Search by type (IpAddress, HardwareAddress, or Name)

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


DhcpSearchInfo Constructor

DhcpSearchInfo Constructor
DhcpSearchInfo Class See Also Send Feedback
Initializes a new instance of the DhcpSearchInfo class.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSearchInfo()

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


DhcpSearchInfo Fields

[image]

DHCP Server Management Objects
DhcpSearchInfo Fields
DhcpSearchInfo Class See Also Send Feedback

The DhcpSearchInfo type exposes the following members.

Fields

Name | Description
IpAddress | IP address of client
MacAddress | MAC address of client
Name | Hostname of client
Type | Search by type (IpAddress, HardwareAddress, or Name)

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


IpAddress Field

DhcpSearchInfo..::.IpAddress Field
DhcpSearchInfo Class See Also Send Feedback
IP address of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress IpAddress

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


MacAddress Field

DhcpSearchInfo..::.MacAddress Field
DhcpSearchInfo Class See Also Send Feedback
MAC address of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpMacAddress MacAddress

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


Name Field

DhcpSearchInfo..::.Name Field
DhcpSearchInfo Class See Also Send Feedback
Hostname of client

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


Type Field

DhcpSearchInfo..::.Type Field
DhcpSearchInfo Class See Also Send Feedback
Search by type (IpAddress, HardwareAddress, or Name)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSearchInfoType Type

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


DhcpSearchInfo Methods

[image]

DHCP Server Management Objects
DhcpSearchInfo Methods
DhcpSearchInfo Class See Also Send Feedback

The DhcpSearchInfo type exposes the following members.

Methods

Name | Description
ConvertToNative | Converts this object to its native representation

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpSearchInfo..::.ConvertToNative Method
DhcpSearchInfo Class See Also Send Feedback
Converts this object to its native representation

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal DHCP_SEARCH_INFO ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Used to track memory allocations

Return Value

A native search info structure

See Also

DhcpSearchInfo Class
Unf.Dhcp.Smo Namespace


DhcpSearchInfoType Enumeration

DhcpSearchInfoType Enumeration
See Also Send Feedback
Search by type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpSearchInfoType

Members

Member name | Description
IpAddress | Search by IP address
HardwareAddress | Search by MAC address
Name | Search by client hostname

See Also

Unf.Dhcp.Smo Namespace


DhcpSubnet Class

DhcpSubnet Class
Members See Also Send Feedback
Defines a DHCP subnet

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpSubnet

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnet

See Also

DhcpSubnet Members
Unf.Dhcp.Smo Namespace


DhcpSubnet Members

[image]

DHCP Server Management Objects
DhcpSubnet Members
DhcpSubnet Class Constructors Methods Fields See Also Send Feedback

The DhcpSubnet type exposes the following members.

Constructors

Name | Description
DhcpSubnet | Dummy constructor

Methods

Name | Description
Create | Creates a subnet on server
Delete | Deletes a subnet on server
EnumAll | Enumerate all subnets on server
Get | Gets a subnet on server
Update | Update subnet on server

Fields

Name | Description
Address | Subnet network IP address
Comment | Subnet description value
Mask | Subnet network mask address
Name | Subnet name value
State | Subnet state (Enable, Disabled,...)

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


DhcpSubnet Constructor

DhcpSubnet Constructor
DhcpSubnet Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnet()

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


DhcpSubnet Fields

[image]

DHCP Server Management Objects
DhcpSubnet Fields
DhcpSubnet Class See Also Send Feedback

The DhcpSubnet type exposes the following members.

Fields

Name | Description
Address | Subnet network IP address
Comment | Subnet description value
Mask | Subnet network mask address
Name | Subnet name value
State | Subnet state (Enable, Disabled,...)

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Address Field

DhcpSubnet..::.Address Field
DhcpSubnet Class See Also Send Feedback
Subnet network IP address

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress Address

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Comment Field

DhcpSubnet..::.Comment Field
DhcpSubnet Class See Also Send Feedback
Subnet description value

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Comment

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Mask Field

DhcpSubnet..::.Mask Field
DhcpSubnet Class See Also Send Feedback
Subnet network mask address

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress Mask

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Name Field

DhcpSubnet..::.Name Field
DhcpSubnet Class See Also Send Feedback
Subnet name value

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Name

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


State Field

DhcpSubnet..::.State Field
DhcpSubnet Class See Also Send Feedback
Subnet state (Enable, Disabled,...)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetState State

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


DhcpSubnet Methods

[image]

DHCP Server Management Objects
DhcpSubnet Methods
DhcpSubnet Class See Also Send Feedback

The DhcpSubnet type exposes the following members.

Methods

Name | Description
Create | Creates a subnet on server
Delete | Deletes a subnet on server
EnumAll | Enumerate all subnets on server
Get | Gets a subnet on server
Update | Update subnet on server

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Create Method

DhcpSubnet..::.Create Method
DhcpSubnet Class See Also Send Feedback
Creates a subnet on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Create(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

Address, Mask, and Name fields must be set before calling Create()

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Delete Method

DhcpSubnet..::.Delete Method
DhcpSubnet Class See Also Send Feedback
Deletes a subnet on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Delete(
    DhcpIpAddress server,
    bool force
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP
force
Type: System..::.Boolean
Force deletion of subnet child elements

Remarks

Address field must be set before calling Delete()

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


EnumAll Method

DhcpSubnet..::.EnumAll Method
DhcpSubnet Class See Also Send Feedback
Enumerate all subnets on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpSubnet> EnumAll(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Return Value

A list of DhcpSubnets on server or an empty list

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Get Method

DhcpSubnet..::.Get Method
DhcpSubnet Class See Also Send Feedback
Gets a subnet on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Get(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

Address field must be set before calling Get(). After call object fields will be set based on address

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


Update Method

DhcpSubnet..::.Update Method
DhcpSubnet Class See Also Send Feedback
Update subnet on server

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Update(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

Address, Mask, and Name fields must be set before calling Update()

See Also

DhcpSubnet Class
Unf.Dhcp.Smo Namespace


DhcpSubnetClientType Enumeration

DhcpSubnetClientType Enumeration
See Also Send Feedback
Client Types

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpSubnetClientType

Members

Member name | Description
Dhcp | DHCP client
Bootp | BOOTP client
Both | DHCP and BOOTP client

See Also

Unf.Dhcp.Smo Namespace


DhcpSubnetElement Class

DhcpSubnetElement Class
Members See Also Send Feedback
Defines an element that describe feature of a DHCP subnet

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpSubnetElement

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnetElement

See Also

DhcpSubnetElement Members
Unf.Dhcp.Smo Namespace


DhcpSubnetElement Members

[image]

DHCP Server Management Objects
DhcpSubnetElement Members
DhcpSubnetElement Class Constructors Methods Fields See Also Send Feedback

The DhcpSubnetElement type exposes the following members.

Constructors

Name | Description
DhcpSubnetElement | Dummy constructor

Methods

Name | Description
Add | Add this element to server's subnet (defined by SubnetAddress)
EnumAll | Enumerate all elements based on Data's type
Remove | Remove this element from server's subnet (defined by SubnetAddress)

Fields

Name | Description
Data | Element data that describes the feature.
SubnetAddress | Subnet network IP address.

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElement Constructor

DhcpSubnetElement Constructor
DhcpSubnetElement Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElement()

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElement Fields

[image]

DHCP Server Management Objects
DhcpSubnetElement Fields
DhcpSubnetElement Class See Also Send Feedback

The DhcpSubnetElement type exposes the following members.

Fields

Name | Description
Data | Element data that describes the feature.
SubnetAddress | Subnet network IP address.

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


Data Field

DhcpSubnetElement..::.Data Field
DhcpSubnetElement Class See Also Send Feedback
Element data that describes the feature.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElementData Data

Remarks

Data can be one of three types: DhcpIpReservation, DhcpIpRange, or BootpIpRange

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


SubnetAddress Field

DhcpSubnetElement..::.SubnetAddress Field
DhcpSubnetElement Class See Also Send Feedback
Subnet network IP address.

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress SubnetAddress

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElement Methods

[image]

DHCP Server Management Objects
DhcpSubnetElement Methods
DhcpSubnetElement Class See Also Send Feedback

The DhcpSubnetElement type exposes the following members.

Methods

Name | Description
Add | Add this element to server's subnet (defined by SubnetAddress)
EnumAll | Enumerate all elements based on Data's type
Remove | Remove this element from server's subnet (defined by SubnetAddress)

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


Add Method

DhcpSubnetElement..::.Add Method
DhcpSubnetElement Class See Also Send Feedback
Add this element to server's subnet (defined by SubnetAddress)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Add(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Remarks

SubnetAddress and Data must be defined before calling Add()

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


EnumAll Method

DhcpSubnetElement..::.EnumAll Method
DhcpSubnetElement Class See Also Send Feedback
Enumerate all elements based on Data's type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElementData[] EnumAll(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP

Return Value

An array of subnet elements

Remarks

SubnetAddress and Data must be defined before calling EnumAll()

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


Remove Method

DhcpSubnetElement..::.Remove Method
DhcpSubnetElement Class See Also Send Feedback
Remove this element from server's subnet (defined by SubnetAddress)

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Remove(
    DhcpIpAddress server,
    bool force
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP
force
Type: System..::.Boolean
Force deletion of element's affected clients

Remarks

SubnetAddress and Data must be defined before calling Remove()

See Also

DhcpSubnetElement Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Class

DhcpSubnetElementData Class
Members See Also Send Feedback
Base class that defines a DhcpSubnetElement data

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DhcpSubnetElementData

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo..::.DhcpSubnetElementData
Unf.Dhcp.Smo..::.DhcpIpRange
Unf.Dhcp.Smo..::.DhcpIpReservation

See Also

DhcpSubnetElementData Members
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Members

[image]

DHCP Server Management Objects
DhcpSubnetElementData Members
DhcpSubnetElementData Class Constructors Methods Fields See Also Send Feedback

The DhcpSubnetElementData type exposes the following members.

Constructors

Name | Description
DhcpSubnetElementData | Overloaded.

Methods

Name | Description
ConvertToNative | Derived classes must implement a conversion from their type to their native equivalent
CovertFromNative | Converts the native subnet element type its SMO form based on type

Fields

Name | Description
Type | Subnet element data type

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Constructor

[image]

DHCP Server Management Objects
DhcpSubnetElementData Constructor
DhcpSubnetElementData Class See Also Send Feedback

Overload List

Name | Description
DhcpSubnetElementData()()() | Dummy constructor
DhcpSubnetElementData(DhcpSubnetElementDataType) | Set base to type

See Also

DhcpSubnetElementData Class
DhcpSubnetElementData Members
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Constructor

DhcpSubnetElementData Constructor
DhcpSubnetElementData Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElementData()

See Also

DhcpSubnetElementData Class
DhcpSubnetElementData Overload
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Constructor (DhcpSubnetElementDataType)

DhcpSubnetElementData Constructor (DhcpSubnetElementDataType)
DhcpSubnetElementData Class See Also Send Feedback
Set base to type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElementData(
    DhcpSubnetElementDataType type
)

Parameters

type
Type: Unf.Dhcp.Smo..::.DhcpSubnetElementDataType
Type of subnet element data

See Also

DhcpSubnetElementData Class
DhcpSubnetElementData Overload
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Fields

[image]

DHCP Server Management Objects
DhcpSubnetElementData Fields
DhcpSubnetElementData Class See Also Send Feedback

The DhcpSubnetElementData type exposes the following members.

Fields

Name | Description
Type | Subnet element data type

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


Type Field

DhcpSubnetElementData..::.Type Field
DhcpSubnetElementData Class See Also Send Feedback
Subnet element data type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSubnetElementDataType Type

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElementData Methods

[image]

DHCP Server Management Objects
DhcpSubnetElementData Methods
DhcpSubnetElementData Class See Also Send Feedback

The DhcpSubnetElementData type exposes the following members.

Methods

Name | Description
ConvertToNative | Derived classes must implement a conversion from their type to their native equivalent
CovertFromNative | Converts the native subnet element type its SMO form based on type

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


ConvertToNative Method

DhcpSubnetElementData..::.ConvertToNative Method
DhcpSubnetElementData Class See Also Send Feedback
Derived classes must implement a conversion from their type to their native equivalent

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal abstract DHCP_SUBNET_ELEMENT_DATA_V5 ConvertToNative(
    MemManager Mem
)

Parameters

Mem
Type: Unf.Dhcp.Smo.Interop..::.MemManager
Tracks memory allocations

Return Value

The native equivalent

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


CovertFromNative Method

DhcpSubnetElementData..::.CovertFromNative Method
DhcpSubnetElementData Class See Also Send Feedback
Converts the native subnet element type its SMO form based on type

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static DhcpSubnetElementData CovertFromNative(
    DHCP_SUBNET_ELEMENT_DATA_V5 nativeElement
)

Parameters

nativeElement
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5
A native subnet element

Return Value

The converted SMO

See Also

DhcpSubnetElementData Class
Unf.Dhcp.Smo Namespace


DhcpSubnetElementDataType Enumeration

DhcpSubnetElementDataType Enumeration
See Also Send Feedback
Types of DhcpSubnetElementData

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpSubnetElementDataType

Members

Member name | Description
DhcpIpRanges | This type seems to not be used and replaced by 'DhcpIpRangeDhcpOnly'
DhcpReservedIps | This type represents a reservation on a subnet
DhcpExcludedIpRanges | This type represents an exclusion address pool
DhcpIpRangesDhcpOnly | This type represents the default range of a DHCP subnet of type DHCP only
DhcpIpRangesDhcpBootp | This type represents the default address pool of a DHCP subnet of both DHCP/BOOTP types.
DhcpIpRangesBootpOnly | This type represents the default range of a DHCP subnet of type BOOTP only

Remarks

Use type 'DhcpIpRangesDhcpBootp' when the default address pool type is unknown, for example on an EnumAll() call

See Also

Unf.Dhcp.Smo Namespace


DhcpSubnetState Enumeration

DhcpSubnetState Enumeration
See Also Send Feedback
DHCP Subnet state

Namespace: Unf.Dhcp.Smo
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpSubnetState

Members

Member name | Description
Enabled | Subnet is enabled
Disabled | Subnet is disabled
EnabledSwitched | Subnet is enabled and the gateway of clients
DisabledSwitched | Subnet is enable and the gateway of clients
InvalidState | Subnet is in an invalid state

See Also

Unf.Dhcp.Smo Namespace


Unf.Dhcp.Smo.Interop Namespace

Unf.Dhcp.Smo.Interop Namespace
Send Feedback
Unf.Dhcp.Smo.Interop members interface with the DHCPSAPI via the System.Runtime.InteropServices classes, otherwise known as Platform Invoke. This namespace contains structures (ex. DHCP_CLIENT_INFO) and prototypes (NativeMethods) used to create managed code from the unmanaged DHCPSAPI library. This namespace also contains a memory management class to help manage heap memory allocations used by unmanaged function calls via Platform Invoke.

Classes

Class | Description
DhcpsapiError | Helper class for controlling DHCPSAPI error codes and their description strings
MemManager | Helper class to manage heap memory allocations used by unmanaged function calls via Platform Invoke
NativeMethods | Contains external unmanaged code functions from DHCPSAPI Windows C library. This class is part of the platform invoke (p/invoke) wrapper used in the Unf.Dhcp.Smo .NET Library.

Structures

Structure | Description
DATE_TIME | Defines a 64-bit integer value that contains a date/time, expressed in FILETIME format
DHCP_BINARY_DATA | Defines an opaque blob of binary data
DHCP_BOOTP_IP_RANGE | Defines a suite of IPs for lease to BOOTP-specific clients
DHCP_CLIENT_INFO | Defines a client information record used by the DHCP server
DHCP_CLIENT_INFO_ARRAY | An array of client info structures
DHCP_CLIENT_UID | Defines a Byte array representing a hardware/mac address
DHCP_HOST_INFO | Defines information on a DHCP server (host)
DHCP_IP_ARRAY | An array of IP addresses
DHCP_IP_RANGE | Defines a range of IP addresses
DHCP_IP_RESERVATION_V4 | Defines a client IP reservation
DHCP_OPTION | Defines a single DHCP option and any default data elements associated with it
DHCP_OPTION_ARRAY | An array of DHCP server option elements
DHCP_OPTION_DATA | An array of data elements associated with a DHCP option
DHCP_OPTION_DATA_ELEMENT | Defines a data element present (either singly or as a member of an array) within a DHCP_OPTION_DATA structure This structure mimics a C/C++ Union
DHCP_OPTION_SCOPE_INFO | Defines information about the options provided for a certain DHCP scope This structure mimics a C/C++ Union
DHCP_OPTION_VALUE | Defines a DHCP option value (just the option data with an associated ID tag)
DHCP_OPTION_VALUE_ARRAY | An array of DHCP option values
DHCP_RESERVED_SCOPE | Defines a reserved DHCP scope
DHCP_SEARCH_INFO | Defines the DHCP client record data used to search against for particular server operations This structure mimics a C/C++ Union
DHCP_SUBNET_ELEMENT_DATA_V5 | Defines an element that describes a feature or restriction of a subnet
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 | An array of subnet data elements
DHCP_SUBNET_INFO | Defines information describing a subnet
DWORD_DWORD | Defines a 64-bit integer value

Enumerations

Enumeration | Description
DHCP_FORCE_FLAG | Defines the set of flags describing the force level of a DHCP subnet element deletion operation
DHCP_OPTION_DATA_TYPE | Defines the set of formats that represent DHCP option data
DHCP_OPTION_SCOPE_TYPE | Defines the set of possible DHCP option scopes
DHCP_OPTION_TYPE | Defines if an option's data is in array form or single value
DHCP_SEARCH_INFO_TYPE | Defines the set of possible attributes used to search DHCP client information records
DHCP_SUBNET_ELEMENT_TYPE_V5 | Defines the set of possible subnet element types
DHCP_SUBNET_STATE | Defines the set of possible states for a subnet
DhcpsapiErrorType | DHCP Server Management API Error Codes


DATE_TIME Structure

DATE_TIME Structure
Members See Also Send Feedback
Defines a 64-bit integer value that contains a date/time, expressed in FILETIME format

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DATE_TIME

Remarks

Based on DATE_TIME [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DATE_TIME Members
Unf.Dhcp.Smo.Interop Namespace


DATE_TIME Members

[image]

DHCP Server Management Objects
DATE_TIME Members
DATE_TIME Structure Constructors Methods Fields See Also Send Feedback

The DATE_TIME type exposes the following members.

Constructors

Name | Description
DATE_TIME | Constructor takes a .Net DateTime and creates a DHCPSAPI DATE_TIME

Methods

Name | Description
Convert | Convert this object to a .Net DateTime
ToString | String value of .Net DateTime of this object (Overrides ValueType ..::. ToString()()().)

Fields

Name | Description
dwHighDateTime | Upper 32bits of FILETIME
dwLowDateTime | Lower 32bits of FILETIME

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


DATE_TIME Constructor

DATE_TIME Constructor
DATE_TIME Structure See Also Send Feedback
Constructor takes a .Net DateTime and creates a DHCPSAPI DATE_TIME

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DATE_TIME(
    DateTime date
)

Parameters

date
Type: System..::.DateTime
.Net DateTime type to convert

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


DATE_TIME Fields

[image]

DHCP Server Management Objects
DATE_TIME Fields
DATE_TIME Structure See Also Send Feedback

The DATE_TIME type exposes the following members.

Fields

Name | Description
dwHighDateTime | Upper 32bits of FILETIME
dwLowDateTime | Lower 32bits of FILETIME

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


dwHighDateTime Field

DATE_TIME..::.dwHighDateTime Field
DATE_TIME Structure See Also Send Feedback
Upper 32bits of FILETIME

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint dwHighDateTime

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


dwLowDateTime Field

DATE_TIME..::.dwLowDateTime Field
DATE_TIME Structure See Also Send Feedback
Lower 32bits of FILETIME

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint dwLowDateTime

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


DATE_TIME Methods

[image]

DHCP Server Management Objects
DATE_TIME Methods
DATE_TIME Structure See Also Send Feedback

The DATE_TIME type exposes the following members.

Methods

Name | Description
Convert | Convert this object to a .Net DateTime
ToString | String value of .Net DateTime of this object (Overrides ValueType ..::. ToString()()().)

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


Convert Method

DATE_TIME..::.Convert Method
DATE_TIME Structure See Also Send Feedback
Convert this object to a .Net DateTime

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime Convert()

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


ToString Method

DATE_TIME..::.ToString Method
DATE_TIME Structure See Also Send Feedback
String value of .Net DateTime of this object

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string ToString()

Return Value

String value of .Net DateTime

See Also

DATE_TIME Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_BINARY_DATA Structure

DHCP_BINARY_DATA Structure
Members See Also Send Feedback
Defines an opaque blob of binary data

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_BINARY_DATA

Remarks

Based on DHCP_BINARY_DATA [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_BINARY_DATA Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_BINARY_DATA Members

[image]

DHCP Server Management Objects
DHCP_BINARY_DATA Members
DHCP_BINARY_DATA Structure Fields See Also Send Feedback

The DHCP_BINARY_DATA type exposes the following members.

Fields

Name | Description
Data | Pointer to Byte array
DataLength | Size of Byte array

See Also

DHCP_BINARY_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_BINARY_DATA Fields

[image]

DHCP Server Management Objects
DHCP_BINARY_DATA Fields
DHCP_BINARY_DATA Structure See Also Send Feedback

The DHCP_BINARY_DATA type exposes the following members.

Fields

Name | Description
Data | Pointer to Byte array
DataLength | Size of Byte array

See Also

DHCP_BINARY_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


Data Field

DHCP_BINARY_DATA..::.Data Field
DHCP_BINARY_DATA Structure See Also Send Feedback
Pointer to Byte array

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Data

See Also

DHCP_BINARY_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


DataLength Field

DHCP_BINARY_DATA..::.DataLength Field
DHCP_BINARY_DATA Structure See Also Send Feedback
Size of Byte array

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint DataLength

See Also

DHCP_BINARY_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_BOOTP_IP_RANGE Structure

DHCP_BOOTP_IP_RANGE Structure
Members See Also Send Feedback
Defines a suite of IPs for lease to BOOTP-specific clients

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_BOOTP_IP_RANGE

Remarks

Based on DHCP_BOOTP_IP_RANGE [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_BOOTP_IP_RANGE Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_BOOTP_IP_RANGE Members

[image]

DHCP Server Management Objects
DHCP_BOOTP_IP_RANGE Members
DHCP_BOOTP_IP_RANGE Structure Fields See Also Send Feedback

The DHCP_BOOTP_IP_RANGE type exposes the following members.

Fields

Name | Description
BootpAllocated | Number of allocation BOOTP clients
EndAddress | End IP address
MaxBootpAllowed | Max allowed BOOTP clients
StartAddress | Start IP address

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_BOOTP_IP_RANGE Fields

[image]

DHCP Server Management Objects
DHCP_BOOTP_IP_RANGE Fields
DHCP_BOOTP_IP_RANGE Structure See Also Send Feedback

The DHCP_BOOTP_IP_RANGE type exposes the following members.

Fields

Name | Description
BootpAllocated | Number of allocation BOOTP clients
EndAddress | End IP address
MaxBootpAllowed | Max allowed BOOTP clients
StartAddress | Start IP address

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


BootpAllocated Field

DHCP_BOOTP_IP_RANGE..::.BootpAllocated Field
DHCP_BOOTP_IP_RANGE Structure See Also Send Feedback
Number of allocation BOOTP clients

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint BootpAllocated

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


EndAddress Field

DHCP_BOOTP_IP_RANGE..::.EndAddress Field
DHCP_BOOTP_IP_RANGE Structure See Also Send Feedback
End IP address

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint EndAddress

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


MaxBootpAllowed Field

DHCP_BOOTP_IP_RANGE..::.MaxBootpAllowed Field
DHCP_BOOTP_IP_RANGE Structure See Also Send Feedback
Max allowed BOOTP clients

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint MaxBootpAllowed

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


StartAddress Field

DHCP_BOOTP_IP_RANGE..::.StartAddress Field
DHCP_BOOTP_IP_RANGE Structure See Also Send Feedback
Start IP address

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint StartAddress

See Also

DHCP_BOOTP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO Structure

DHCP_CLIENT_INFO Structure
Members See Also Send Feedback
Defines a client information record used by the DHCP server

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_CLIENT_INFO

Remarks

Based on DHCP_CLIENT_INFO [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]

See Also

DHCP_CLIENT_INFO Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO Members

[image]

DHCP Server Management Objects
DHCP_CLIENT_INFO Members
DHCP_CLIENT_INFO Structure Fields See Also Send Feedback

The DHCP_CLIENT_INFO type exposes the following members.

Fields

Name | Description
ClientComment | Client description value
ClientHardwareAddress | MAC address of client lease
ClientIpAddress | IP address of client lease
ClientLeaseExpires | FILETIME when lease expires
ClientName | Client hostname
OwnerHost | Ignored
SubnetMask | Subnet mask of client lease

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO Fields

[image]

DHCP Server Management Objects
DHCP_CLIENT_INFO Fields
DHCP_CLIENT_INFO Structure See Also Send Feedback

The DHCP_CLIENT_INFO type exposes the following members.

Fields

Name | Description
ClientComment | Client description value
ClientHardwareAddress | MAC address of client lease
ClientIpAddress | IP address of client lease
ClientLeaseExpires | FILETIME when lease expires
ClientName | Client hostname
OwnerHost | Ignored
SubnetMask | Subnet mask of client lease

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientComment Field

DHCP_CLIENT_INFO..::.ClientComment Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
Client description value

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ClientComment

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientHardwareAddress Field

DHCP_CLIENT_INFO..::.ClientHardwareAddress Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
MAC address of client lease

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_CLIENT_UID ClientHardwareAddress

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientIpAddress Field

DHCP_CLIENT_INFO..::.ClientIpAddress Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
IP address of client lease

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint ClientIpAddress

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientLeaseExpires Field

DHCP_CLIENT_INFO..::.ClientLeaseExpires Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
FILETIME when lease expires

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DATE_TIME ClientLeaseExpires

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientName Field

DHCP_CLIENT_INFO..::.ClientName Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
Client hostname

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ClientName

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


OwnerHost Field

DHCP_CLIENT_INFO..::.OwnerHost Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
Ignored

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_HOST_INFO OwnerHost

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetMask Field

DHCP_CLIENT_INFO..::.SubnetMask Field
DHCP_CLIENT_INFO Structure See Also Send Feedback
Subnet mask of client lease

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint SubnetMask

See Also

DHCP_CLIENT_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO_ARRAY Structure

DHCP_CLIENT_INFO_ARRAY Structure
Members See Also Send Feedback
An array of client info structures

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_CLIENT_INFO_ARRAY

Remarks

Based on DHCP_CLIENT_INFO_ARRAY [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_CLIENT_INFO_ARRAY Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO_ARRAY Members

[image]

DHCP Server Management Objects
DHCP_CLIENT_INFO_ARRAY Members
DHCP_CLIENT_INFO_ARRAY Structure Fields See Also Send Feedback

The DHCP_CLIENT_INFO_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_CLIENT_INFO values
NumElements | Number of DHCP_CLIENT_INFO in Elements

See Also

DHCP_CLIENT_INFO_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_INFO_ARRAY Fields

[image]

DHCP Server Management Objects
DHCP_CLIENT_INFO_ARRAY Fields
DHCP_CLIENT_INFO_ARRAY Structure See Also Send Feedback

The DHCP_CLIENT_INFO_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_CLIENT_INFO values
NumElements | Number of DHCP_CLIENT_INFO in Elements

See Also

DHCP_CLIENT_INFO_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_CLIENT_INFO_ARRAY..::.Elements Field
DHCP_CLIENT_INFO_ARRAY Structure See Also Send Feedback
Pointer to an array of DHCP_CLIENT_INFO values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_CLIENT_INFO_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_CLIENT_INFO_ARRAY..::.NumElements Field
DHCP_CLIENT_INFO_ARRAY Structure See Also Send Feedback
Number of DHCP_CLIENT_INFO in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_CLIENT_INFO_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_UID Structure

DHCP_CLIENT_UID Structure
Members See Also Send Feedback
Defines a Byte array representing a hardware/mac address

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_CLIENT_UID

Remarks

Based on DHCP_BINARY_DATA [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_CLIENT_UID Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_UID Members

[image]

DHCP Server Management Objects
DHCP_CLIENT_UID Members
DHCP_CLIENT_UID Structure Fields See Also Send Feedback

The DHCP_CLIENT_UID type exposes the following members.

Fields

Name | Description
Data | Pointer to Byte array
DataLength | Size of Byte array

See Also

DHCP_CLIENT_UID Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_CLIENT_UID Fields

[image]

DHCP Server Management Objects
DHCP_CLIENT_UID Fields
DHCP_CLIENT_UID Structure See Also Send Feedback

The DHCP_CLIENT_UID type exposes the following members.

Fields

Name | Description
Data | Pointer to Byte array
DataLength | Size of Byte array

See Also

DHCP_CLIENT_UID Structure
Unf.Dhcp.Smo.Interop Namespace


Data Field

DHCP_CLIENT_UID..::.Data Field
DHCP_CLIENT_UID Structure See Also Send Feedback
Pointer to Byte array

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Data

See Also

DHCP_CLIENT_UID Structure
Unf.Dhcp.Smo.Interop Namespace


DataLength Field

DHCP_CLIENT_UID..::.DataLength Field
DHCP_CLIENT_UID Structure See Also Send Feedback
Size of Byte array

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint DataLength

See Also

DHCP_CLIENT_UID Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_FORCE_FLAG Enumeration

DHCP_FORCE_FLAG Enumeration
See Also Send Feedback
Defines the set of flags describing the force level of a DHCP subnet element deletion operation

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_FORCE_FLAG

Members

Member name | Description
DhcpFullForce | Delete subnet element and all affected records
DhcpNoForce | Delete only subnet element

Remarks

Based on DHCP_FORCE_FLAG [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_HOST_INFO Structure

DHCP_HOST_INFO Structure
Members See Also Send Feedback
Defines information on a DHCP server (host)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_HOST_INFO

Remarks

Based on DHCP_HOST_INFO [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]

See Also

DHCP_HOST_INFO Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_HOST_INFO Members

[image]

DHCP Server Management Objects
DHCP_HOST_INFO Members
DHCP_HOST_INFO Structure Fields See Also Send Feedback

The DHCP_HOST_INFO type exposes the following members.

Fields

Name | Description
HostName | Hostname
IpAddress | IP address of host
NetBiosName | Host's netbios name

See Also

DHCP_HOST_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_HOST_INFO Fields

[image]

DHCP Server Management Objects
DHCP_HOST_INFO Fields
DHCP_HOST_INFO Structure See Also Send Feedback

The DHCP_HOST_INFO type exposes the following members.

Fields

Name | Description
HostName | Hostname
IpAddress | IP address of host
NetBiosName | Host's netbios name

See Also

DHCP_HOST_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


HostName Field

DHCP_HOST_INFO..::.HostName Field
DHCP_HOST_INFO Structure See Also Send Feedback
Hostname

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string HostName

See Also

DHCP_HOST_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


IpAddress Field

DHCP_HOST_INFO..::.IpAddress Field
DHCP_HOST_INFO Structure See Also Send Feedback
IP address of host

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint IpAddress

See Also

DHCP_HOST_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


NetBiosName Field

DHCP_HOST_INFO..::.NetBiosName Field
DHCP_HOST_INFO Structure See Also Send Feedback
Host's netbios name

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string NetBiosName

See Also

DHCP_HOST_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_ARRAY Structure

DHCP_IP_ARRAY Structure
Members See Also Send Feedback
An array of IP addresses

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_IP_ARRAY

Remarks

Based on DHCP_IP_ARRAY [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_IP_ARRAY Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_ARRAY Members

[image]

DHCP Server Management Objects
DHCP_IP_ARRAY Members
DHCP_IP_ARRAY Structure Fields See Also Send Feedback

The DHCP_IP_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of UInt32 values
NumElements | Number of IP addresses in Elements

See Also

DHCP_IP_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_ARRAY Fields

[image]

DHCP Server Management Objects
DHCP_IP_ARRAY Fields
DHCP_IP_ARRAY Structure See Also Send Feedback

The DHCP_IP_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of UInt32 values
NumElements | Number of IP addresses in Elements

See Also

DHCP_IP_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_IP_ARRAY..::.Elements Field
DHCP_IP_ARRAY Structure See Also Send Feedback
Pointer to an array of UInt32 values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_IP_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_IP_ARRAY..::.NumElements Field
DHCP_IP_ARRAY Structure See Also Send Feedback
Number of IP addresses in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_IP_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RANGE Structure

DHCP_IP_RANGE Structure
Members See Also Send Feedback
Defines a range of IP addresses

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_IP_RANGE

Remarks

Based on DHCP_IP_RANGE [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_IP_RANGE Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RANGE Members

[image]

DHCP Server Management Objects
DHCP_IP_RANGE Members
DHCP_IP_RANGE Structure Fields See Also Send Feedback

The DHCP_IP_RANGE type exposes the following members.

Fields

Name | Description
EndAddress | End IP address
StartAddress | Start IP address

See Also

DHCP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RANGE Fields

[image]

DHCP Server Management Objects
DHCP_IP_RANGE Fields
DHCP_IP_RANGE Structure See Also Send Feedback

The DHCP_IP_RANGE type exposes the following members.

Fields

Name | Description
EndAddress | End IP address
StartAddress | Start IP address

See Also

DHCP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


EndAddress Field

DHCP_IP_RANGE..::.EndAddress Field
DHCP_IP_RANGE Structure See Also Send Feedback
End IP address

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint EndAddress

See Also

DHCP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


StartAddress Field

DHCP_IP_RANGE..::.StartAddress Field
DHCP_IP_RANGE Structure See Also Send Feedback
Start IP address

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint StartAddress

See Also

DHCP_IP_RANGE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RESERVATION_V4 Structure

DHCP_IP_RESERVATION_V4 Structure
Members See Also Send Feedback
Defines a client IP reservation

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_IP_RESERVATION_V4

Remarks

Based on DHCP_IP_RESERVATION_V4 [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_IP_RESERVATION_V4 Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RESERVATION_V4 Members

[image]

DHCP Server Management Objects
DHCP_IP_RESERVATION_V4 Members
DHCP_IP_RESERVATION_V4 Structure Fields See Also Send Feedback

The DHCP_IP_RESERVATION_V4 type exposes the following members.

Fields

Name | Description
bAllowedClientTypes | Allow client type (DHCP, BOOTP, or Both)
ReservedForClient | Pointer to DHCP_CLIENT_UID (MAC address)
ReservedIpAddress | IP address of reservation

See Also

DHCP_IP_RESERVATION_V4 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_IP_RESERVATION_V4 Fields

[image]

DHCP Server Management Objects
DHCP_IP_RESERVATION_V4 Fields
DHCP_IP_RESERVATION_V4 Structure See Also Send Feedback

The DHCP_IP_RESERVATION_V4 type exposes the following members.

Fields

Name | Description
bAllowedClientTypes | Allow client type (DHCP, BOOTP, or Both)
ReservedForClient | Pointer to DHCP_CLIENT_UID (MAC address)
ReservedIpAddress | IP address of reservation

See Also

DHCP_IP_RESERVATION_V4 Structure
Unf.Dhcp.Smo.Interop Namespace


bAllowedClientTypes Field

DHCP_IP_RESERVATION_V4..::.bAllowedClientTypes Field
DHCP_IP_RESERVATION_V4 Structure See Also Send Feedback
Allow client type (DHCP, BOOTP, or Both)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte bAllowedClientTypes

See Also

DHCP_IP_RESERVATION_V4 Structure
Unf.Dhcp.Smo.Interop Namespace


ReservedForClient Field

DHCP_IP_RESERVATION_V4..::.ReservedForClient Field
DHCP_IP_RESERVATION_V4 Structure See Also Send Feedback
Pointer to DHCP_CLIENT_UID (MAC address)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr ReservedForClient

See Also

DHCP_IP_RESERVATION_V4 Structure
Unf.Dhcp.Smo.Interop Namespace


ReservedIpAddress Field

DHCP_IP_RESERVATION_V4..::.ReservedIpAddress Field
DHCP_IP_RESERVATION_V4 Structure See Also Send Feedback
IP address of reservation

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint ReservedIpAddress

See Also

DHCP_IP_RESERVATION_V4 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION Structure

DHCP_OPTION Structure
Members See Also Send Feedback
Defines a single DHCP option and any default data elements associated with it

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION

Remarks

Based on DHCP_OPTION [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]

See Also

DHCP_OPTION Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION Members

[image]

DHCP Server Management Objects
DHCP_OPTION Members
DHCP_OPTION Structure Fields See Also Send Feedback

The DHCP_OPTION type exposes the following members.

Fields

Name | Description
DefaultValue | Default value of this option
OptionComment | Option desciption value
OptionID | DHCP Option ID (rfc2132)
OptionName | Option name value
OptionType | Data type of this option

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION Fields

[image]

DHCP Server Management Objects
DHCP_OPTION Fields
DHCP_OPTION Structure See Also Send Feedback

The DHCP_OPTION type exposes the following members.

Fields

Name | Description
DefaultValue | Default value of this option
OptionComment | Option desciption value
OptionID | DHCP Option ID (rfc2132)
OptionName | Option name value
OptionType | Data type of this option

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


DefaultValue Field

DHCP_OPTION..::.DefaultValue Field
DHCP_OPTION Structure See Also Send Feedback
Default value of this option

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_OPTION_DATA DefaultValue

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


OptionComment Field

DHCP_OPTION..::.OptionComment Field
DHCP_OPTION Structure See Also Send Feedback
Option desciption value

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OptionComment

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


OptionID Field

DHCP_OPTION..::.OptionID Field
DHCP_OPTION Structure See Also Send Feedback
DHCP Option ID (rfc2132)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint OptionID

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


OptionName Field

DHCP_OPTION..::.OptionName Field
DHCP_OPTION Structure See Also Send Feedback
Option name value

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string OptionName

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


OptionType Field

DHCP_OPTION..::.OptionType Field
DHCP_OPTION Structure See Also Send Feedback
Data type of this option

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_OPTION_TYPE OptionType

See Also

DHCP_OPTION Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_ARRAY Structure

DHCP_OPTION_ARRAY Structure
Members See Also Send Feedback
An array of DHCP server option elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_ARRAY

Remarks

Based on DHCP_OPTION_ARRAY [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_OPTION_ARRAY Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_ARRAY Members

[image]

DHCP Server Management Objects
DHCP_OPTION_ARRAY Members
DHCP_OPTION_ARRAY Structure Fields See Also Send Feedback

The DHCP_OPTION_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_OPTION values
NumElements | Number of DHCP_OPTION in Elements

See Also

DHCP_OPTION_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_ARRAY Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_ARRAY Fields
DHCP_OPTION_ARRAY Structure See Also Send Feedback

The DHCP_OPTION_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_OPTION values
NumElements | Number of DHCP_OPTION in Elements

See Also

DHCP_OPTION_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_OPTION_ARRAY..::.Elements Field
DHCP_OPTION_ARRAY Structure See Also Send Feedback
Pointer to an array of DHCP_OPTION values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_OPTION_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_OPTION_ARRAY..::.NumElements Field
DHCP_OPTION_ARRAY Structure See Also Send Feedback
Number of DHCP_OPTION in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_OPTION_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA Structure

DHCP_OPTION_DATA Structure
Members See Also Send Feedback
An array of data elements associated with a DHCP option

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_DATA

Remarks

Based on DHCP_OPTION_DATA [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_OPTION_DATA Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA Members

[image]

DHCP Server Management Objects
DHCP_OPTION_DATA Members
DHCP_OPTION_DATA Structure Fields See Also Send Feedback

The DHCP_OPTION_DATA type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_OPTION_DATA_ELEMENT values
NumElements | Number of DHCP_OPTION_DATA_ELEMENT in Elements

See Also

DHCP_OPTION_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_DATA Fields
DHCP_OPTION_DATA Structure See Also Send Feedback

The DHCP_OPTION_DATA type exposes the following members.

Fields

Name | Description
Elements | Pointer to an array of DHCP_OPTION_DATA_ELEMENT values
NumElements | Number of DHCP_OPTION_DATA_ELEMENT in Elements

See Also

DHCP_OPTION_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_OPTION_DATA..::.Elements Field
DHCP_OPTION_DATA Structure See Also Send Feedback
Pointer to an array of DHCP_OPTION_DATA_ELEMENT values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_OPTION_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_OPTION_DATA..::.NumElements Field
DHCP_OPTION_DATA Structure See Also Send Feedback
Number of DHCP_OPTION_DATA_ELEMENT in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_OPTION_DATA Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA_ELEMENT Structure

DHCP_OPTION_DATA_ELEMENT Structure
Members See Also Send Feedback
Defines a data element present (either singly or as a member of an array) within a DHCP_OPTION_DATA structure
This structure mimics a C/C++ Union

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_DATA_ELEMENT

Remarks

Based on DHCP_OPTION_DATA_ELEMENT [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Explicit, Size = 12)]
internal struct DHCP_OPTION_DATA_ELEMENT
{
    [FieldOffset(0)]
    public DHCP_OPTION_DATA_TYPE OptionType;
    [FieldOffset(4)]
    public byte ByteOption;
    [FieldOffset(4)]
    public UInt16 WordOption;
    [FieldOffset(4)]
    public UInt32 DWordOption;
    [FieldOffset(4)]
    public DWORD_DWORD DWordDWordOption;
    [FieldOffset(4)]
    public IntPtr StringOption;
    [FieldOffset(4)]
    public DHCP_BINARY_DATA BinDataOption;
}

See Also

DHCP_OPTION_DATA_ELEMENT Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA_ELEMENT Members

[image]

DHCP Server Management Objects
DHCP_OPTION_DATA_ELEMENT Members
DHCP_OPTION_DATA_ELEMENT Structure Fields See Also Send Feedback

The DHCP_OPTION_DATA_ELEMENT type exposes the following members.

Fields

Name | Description
BinDataOption | Union member Byte Array
ByteOption | Union member byte
DWordDWordOption | Union member DWORD_DWORD (64bit)
DWordOption | Union member UInt32
OptionType | Type of option data
StringOption | Union member String
WordOption | Union member UInt16

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA_ELEMENT Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_DATA_ELEMENT Fields
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback

The DHCP_OPTION_DATA_ELEMENT type exposes the following members.

Fields

Name | Description
BinDataOption | Union member Byte Array
ByteOption | Union member byte
DWordDWordOption | Union member DWORD_DWORD (64bit)
DWordOption | Union member UInt32
OptionType | Type of option data
StringOption | Union member String
WordOption | Union member UInt16

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


BinDataOption Field

DHCP_OPTION_DATA_ELEMENT..::.BinDataOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member Byte Array

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_BINARY_DATA BinDataOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


ByteOption Field

DHCP_OPTION_DATA_ELEMENT..::.ByteOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member byte

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public byte ByteOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


DWordDWordOption Field

DHCP_OPTION_DATA_ELEMENT..::.DWordDWordOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member DWORD_DWORD (64bit)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DWORD_DWORD DWordDWordOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


DWordOption Field

DHCP_OPTION_DATA_ELEMENT..::.DWordOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member UInt32

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint DWordOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


OptionType Field

DHCP_OPTION_DATA_ELEMENT..::.OptionType Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Type of option data

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_OPTION_DATA_TYPE OptionType

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


StringOption Field

DHCP_OPTION_DATA_ELEMENT..::.StringOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member String

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr StringOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


WordOption Field

DHCP_OPTION_DATA_ELEMENT..::.WordOption Field
DHCP_OPTION_DATA_ELEMENT Structure See Also Send Feedback
Union member UInt16

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ushort WordOption

See Also

DHCP_OPTION_DATA_ELEMENT Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_DATA_TYPE Enumeration

DHCP_OPTION_DATA_TYPE Enumeration
See Also Send Feedback
Defines the set of formats that represent DHCP option data

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_OPTION_DATA_TYPE

Members

Member name | Description
DhcpByteOption | Data type of byte
DhcpWordOption | Data type of WORD (uint16)
DhcpDWordOption | Data type of DWORD (uint32)
DhcpDWordDWordOption | Data type of DWORDDWORD (uint64)
DhcpIpAddressOption | Data type of IP address (uint)
DhcpStringDataOption | Data type of string
DhcpBinaryDataOption | Not Implemented
DhcpEncapsulatedDataOption | Not Implemented
DhcpIpv6AddressOption | Not Implemented

Remarks

Based on DHCP_OPTION_DATA_TYPE [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_SCOPE_INFO Structure

DHCP_OPTION_SCOPE_INFO Structure
Members See Also Send Feedback
Defines information about the options provided for a certain DHCP scope
This structure mimics a C/C++ Union

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_SCOPE_INFO

Remarks

Based on DHCP_OPTION_SCOPE_INFO [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Explicit, Size = 12)]
internal struct DHCP_OPTION_SCOPE_INFO
{
    [FieldOffset(0)]
    public DHCP_OPTION_SCOPE_TYPE ScopeType;
    [FieldOffset(4)]
    public UInt32 SubnetScopeInfo;
    [FieldOffset(4)]
    public DHCP_RESERVED_SCOPE ReservedScopeInfo;
    [FieldOffset(4)]
    public IntPtr GlobalScopeInfo;
}

See Also

DHCP_OPTION_SCOPE_INFO Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_SCOPE_INFO Members

[image]

DHCP Server Management Objects
DHCP_OPTION_SCOPE_INFO Members
DHCP_OPTION_SCOPE_INFO Structure Fields See Also Send Feedback

The DHCP_OPTION_SCOPE_INFO type exposes the following members.

Fields

Name | Description
GlobalScopeInfo | Union member Server (use IntPtr.Zero)
ReservedScopeInfo | Union member for reservation (subnet and reseration IP)
ScopeType | Scope Type (Server, Subnet, or Reservation)
SubnetScopeInfo | Union member Subnet network IP

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_SCOPE_INFO Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_SCOPE_INFO Fields
DHCP_OPTION_SCOPE_INFO Structure See Also Send Feedback

The DHCP_OPTION_SCOPE_INFO type exposes the following members.

Fields

Name | Description
GlobalScopeInfo | Union member Server (use IntPtr.Zero)
ReservedScopeInfo | Union member for reservation (subnet and reseration IP)
ScopeType | Scope Type (Server, Subnet, or Reservation)
SubnetScopeInfo | Union member Subnet network IP

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


GlobalScopeInfo Field

DHCP_OPTION_SCOPE_INFO..::.GlobalScopeInfo Field
DHCP_OPTION_SCOPE_INFO Structure See Also Send Feedback
Union member Server (use IntPtr.Zero)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr GlobalScopeInfo

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ReservedScopeInfo Field

DHCP_OPTION_SCOPE_INFO..::.ReservedScopeInfo Field
DHCP_OPTION_SCOPE_INFO Structure See Also Send Feedback
Union member for reservation (subnet and reseration IP)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_RESERVED_SCOPE ReservedScopeInfo

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ScopeType Field

DHCP_OPTION_SCOPE_INFO..::.ScopeType Field
DHCP_OPTION_SCOPE_INFO Structure See Also Send Feedback
Scope Type (Server, Subnet, or Reservation)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_OPTION_SCOPE_TYPE ScopeType

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetScopeInfo Field

DHCP_OPTION_SCOPE_INFO..::.SubnetScopeInfo Field
DHCP_OPTION_SCOPE_INFO Structure See Also Send Feedback
Union member Subnet network IP

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint SubnetScopeInfo

See Also

DHCP_OPTION_SCOPE_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_SCOPE_TYPE Enumeration

DHCP_OPTION_SCOPE_TYPE Enumeration
See Also Send Feedback
Defines the set of possible DHCP option scopes

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_OPTION_SCOPE_TYPE

Members

Member name | Description
DhcpDefaultOptions | Not Implemented
DhcpGlobalOptions | Server Options
DhcpSubnetOptions | Subnet Options
DhcpReservedOptions | Reservation Options
DhcpMScopeOptions | Not Implemented

Remarks

Based on DHCP_OPTION_SCOPE_TYPE [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_TYPE Enumeration

DHCP_OPTION_TYPE Enumeration
See Also Send Feedback
Defines if an option's data is in array form or single value

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_OPTION_TYPE

Members

Member name | Description
DhcpUnaryElementTypeOption | Single value type
DhcpArrayTypeOption | Array value type

Remarks

Based on DHCP_OPTION_TYPE [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE Structure

DHCP_OPTION_VALUE Structure
Members See Also Send Feedback
Defines a DHCP option value (just the option data with an associated ID tag)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_VALUE

Remarks

Based on DHCP_OPTION_VALUE [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_OPTION_VALUE Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE Members

[image]

DHCP Server Management Objects
DHCP_OPTION_VALUE Members
DHCP_OPTION_VALUE Structure Fields See Also Send Feedback

The DHCP_OPTION_VALUE type exposes the following members.

Fields

Name | Description
OptionID | DHCP Option ID (rfc2132)
Value | Option data value(s)

See Also

DHCP_OPTION_VALUE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_VALUE Fields
DHCP_OPTION_VALUE Structure See Also Send Feedback

The DHCP_OPTION_VALUE type exposes the following members.

Fields

Name | Description
OptionID | DHCP Option ID (rfc2132)
Value | Option data value(s)

See Also

DHCP_OPTION_VALUE Structure
Unf.Dhcp.Smo.Interop Namespace


OptionID Field

DHCP_OPTION_VALUE..::.OptionID Field
DHCP_OPTION_VALUE Structure See Also Send Feedback
DHCP Option ID (rfc2132)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint OptionID

See Also

DHCP_OPTION_VALUE Structure
Unf.Dhcp.Smo.Interop Namespace


Value Field

DHCP_OPTION_VALUE..::.Value Field
DHCP_OPTION_VALUE Structure See Also Send Feedback
Option data value(s)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_OPTION_DATA Value

See Also

DHCP_OPTION_VALUE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE_ARRAY Structure

DHCP_OPTION_VALUE_ARRAY Structure
Members See Also Send Feedback
An array of DHCP option values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_OPTION_VALUE_ARRAY

Remarks

Based on DHCP_OPTION_VALUE_ARRAY [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_OPTION_VALUE_ARRAY Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE_ARRAY Members

[image]

DHCP Server Management Objects
DHCP_OPTION_VALUE_ARRAY Members
DHCP_OPTION_VALUE_ARRAY Structure Fields See Also Send Feedback

The DHCP_OPTION_VALUE_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Point to an array of DHCP_OPTION_VALUE values
NumElements | Number of DHCP_OPTION_VALUE in Elements

See Also

DHCP_OPTION_VALUE_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_OPTION_VALUE_ARRAY Fields

[image]

DHCP Server Management Objects
DHCP_OPTION_VALUE_ARRAY Fields
DHCP_OPTION_VALUE_ARRAY Structure See Also Send Feedback

The DHCP_OPTION_VALUE_ARRAY type exposes the following members.

Fields

Name | Description
Elements | Point to an array of DHCP_OPTION_VALUE values
NumElements | Number of DHCP_OPTION_VALUE in Elements

See Also

DHCP_OPTION_VALUE_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_OPTION_VALUE_ARRAY..::.Elements Field
DHCP_OPTION_VALUE_ARRAY Structure See Also Send Feedback
Point to an array of DHCP_OPTION_VALUE values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_OPTION_VALUE_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_OPTION_VALUE_ARRAY..::.NumElements Field
DHCP_OPTION_VALUE_ARRAY Structure See Also Send Feedback
Number of DHCP_OPTION_VALUE in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_OPTION_VALUE_ARRAY Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_RESERVED_SCOPE Structure

DHCP_RESERVED_SCOPE Structure
Members See Also Send Feedback
Defines a reserved DHCP scope

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_RESERVED_SCOPE

Remarks

Based on DHCP_RESERVED_SCOPE [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_RESERVED_SCOPE Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_RESERVED_SCOPE Members

[image]

DHCP Server Management Objects
DHCP_RESERVED_SCOPE Members
DHCP_RESERVED_SCOPE Structure Fields See Also Send Feedback

The DHCP_RESERVED_SCOPE type exposes the following members.

Fields

Name | Description
ReservedIpAddress | IP address of reservation
ReservedIpSubnetAddress | IP address of subnet that owner reservation

See Also

DHCP_RESERVED_SCOPE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_RESERVED_SCOPE Fields

[image]

DHCP Server Management Objects
DHCP_RESERVED_SCOPE Fields
DHCP_RESERVED_SCOPE Structure See Also Send Feedback

The DHCP_RESERVED_SCOPE type exposes the following members.

Fields

Name | Description
ReservedIpAddress | IP address of reservation
ReservedIpSubnetAddress | IP address of subnet that owner reservation

See Also

DHCP_RESERVED_SCOPE Structure
Unf.Dhcp.Smo.Interop Namespace


ReservedIpAddress Field

DHCP_RESERVED_SCOPE..::.ReservedIpAddress Field
DHCP_RESERVED_SCOPE Structure See Also Send Feedback
IP address of reservation

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint ReservedIpAddress

See Also

DHCP_RESERVED_SCOPE Structure
Unf.Dhcp.Smo.Interop Namespace


ReservedIpSubnetAddress Field

DHCP_RESERVED_SCOPE..::.ReservedIpSubnetAddress Field
DHCP_RESERVED_SCOPE Structure See Also Send Feedback
IP address of subnet that owner reservation

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint ReservedIpSubnetAddress

See Also

DHCP_RESERVED_SCOPE Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SEARCH_INFO Structure

DHCP_SEARCH_INFO Structure
Members See Also Send Feedback
Defines the DHCP client record data used to search against for particular server operations
This structure mimics a C/C++ Union

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_SEARCH_INFO

Remarks

Based on DHCP_SEARCH_INFO [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Explicit, Size = 12)]
internal struct DHCP_SEARCH_INFO
{
    [FieldOffset(0)]
    public DHCP_SEARCH_INFO_TYPE SearchType;
    [FieldOffset(4)]
    public DHCP_CLIENT_UID ClientHardwareAddress;
    [FieldOffset(4)]
    public UInt32 ClientIpAddress;
    [FieldOffset(4)]
    public IntPtr ClientName;
}

See Also

DHCP_SEARCH_INFO Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_SEARCH_INFO Members

[image]

DHCP Server Management Objects
DHCP_SEARCH_INFO Members
DHCP_SEARCH_INFO Structure Fields See Also Send Feedback

The DHCP_SEARCH_INFO type exposes the following members.

Fields

Name | Description
ClientHardwareAddress | Union member for MAC type
ClientIpAddress | Union member for IP type
ClientName | Union member for Hostname type
SearchType | Search type (IP, MAC, or Hostname)

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SEARCH_INFO Fields

[image]

DHCP Server Management Objects
DHCP_SEARCH_INFO Fields
DHCP_SEARCH_INFO Structure See Also Send Feedback

The DHCP_SEARCH_INFO type exposes the following members.

Fields

Name | Description
ClientHardwareAddress | Union member for MAC type
ClientIpAddress | Union member for IP type
ClientName | Union member for Hostname type
SearchType | Search type (IP, MAC, or Hostname)

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientHardwareAddress Field

DHCP_SEARCH_INFO..::.ClientHardwareAddress Field
DHCP_SEARCH_INFO Structure See Also Send Feedback
Union member for MAC type

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_CLIENT_UID ClientHardwareAddress

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientIpAddress Field

DHCP_SEARCH_INFO..::.ClientIpAddress Field
DHCP_SEARCH_INFO Structure See Also Send Feedback
Union member for IP type

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint ClientIpAddress

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


ClientName Field

DHCP_SEARCH_INFO..::.ClientName Field
DHCP_SEARCH_INFO Structure See Also Send Feedback
Union member for Hostname type

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr ClientName

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SearchType Field

DHCP_SEARCH_INFO..::.SearchType Field
DHCP_SEARCH_INFO Structure See Also Send Feedback
Search type (IP, MAC, or Hostname)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_SEARCH_INFO_TYPE SearchType

See Also

DHCP_SEARCH_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SEARCH_INFO_TYPE Enumeration

DHCP_SEARCH_INFO_TYPE Enumeration
See Also Send Feedback
Defines the set of possible attributes used to search DHCP client information records

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_SEARCH_INFO_TYPE

Members

Member name | Description
DhcpClientIpAddress | Search by client IP
DhcpClientHardwareAddress | Search by Mac
DhcpClientName | Search by hostname

Remarks

Based on DHCP_SEARCH_INFO_TYPE [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_DATA_V5 Structure

DHCP_SUBNET_ELEMENT_DATA_V5 Structure
Members See Also Send Feedback
Defines an element that describes a feature or restriction of a subnet

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_SUBNET_ELEMENT_DATA_V5

Remarks

Based on DHCP_SUBNET_ELEMENT_DATA_V5 [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_SUBNET_ELEMENT_DATA_V5 Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_DATA_V5 Members

[image]

DHCP Server Management Objects
DHCP_SUBNET_ELEMENT_DATA_V5 Members
DHCP_SUBNET_ELEMENT_DATA_V5 Structure Fields See Also Send Feedback

The DHCP_SUBNET_ELEMENT_DATA_V5 type exposes the following members.

Fields

Name | Description
Data | Pointer to a DHCP structure based on ElementType. Possible type: DHCP_IP_RANGE, DHCP_BOOTP_IP_RANGE, DHCP_IP_RESERVATION_V4, and DHCP_HOST_INFO
ElementType | Type of subnet element data

See Also

DHCP_SUBNET_ELEMENT_DATA_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_DATA_V5 Fields

[image]

DHCP Server Management Objects
DHCP_SUBNET_ELEMENT_DATA_V5 Fields
DHCP_SUBNET_ELEMENT_DATA_V5 Structure See Also Send Feedback

The DHCP_SUBNET_ELEMENT_DATA_V5 type exposes the following members.

Fields

Name | Description
Data | Pointer to a DHCP structure based on ElementType. Possible type: DHCP_IP_RANGE, DHCP_BOOTP_IP_RANGE, DHCP_IP_RESERVATION_V4, and DHCP_HOST_INFO
ElementType | Type of subnet element data

See Also

DHCP_SUBNET_ELEMENT_DATA_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


Data Field

DHCP_SUBNET_ELEMENT_DATA_V5..::.Data Field
DHCP_SUBNET_ELEMENT_DATA_V5 Structure See Also Send Feedback
Pointer to a DHCP structure based on ElementType.
Possible type: DHCP_IP_RANGE, DHCP_BOOTP_IP_RANGE, DHCP_IP_RESERVATION_V4, and DHCP_HOST_INFO

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Data

See Also

DHCP_SUBNET_ELEMENT_DATA_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


ElementType Field

DHCP_SUBNET_ELEMENT_DATA_V5..::.ElementType Field
DHCP_SUBNET_ELEMENT_DATA_V5 Structure See Also Send Feedback
Type of subnet element data

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_SUBNET_ELEMENT_TYPE_V5 ElementType

See Also

DHCP_SUBNET_ELEMENT_DATA_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure
Members See Also Send Feedback
An array of subnet data elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5

Remarks

Based on DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Members

[image]

DHCP Server Management Objects
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Members
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure Fields See Also Send Feedback

The DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 type exposes the following members.

Fields

Name | Description
Elements | Pinter to an array of DHCP_SUBNET_ELEMENT_DATA_V5 values
NumElements | Number of DHCP_SUBNET_ELEMENT_DATA_V5 in Elements

See Also

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Fields

[image]

DHCP Server Management Objects
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Fields
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure See Also Send Feedback

The DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 type exposes the following members.

Fields

Name | Description
Elements | Pinter to an array of DHCP_SUBNET_ELEMENT_DATA_V5 values
NumElements | Number of DHCP_SUBNET_ELEMENT_DATA_V5 in Elements

See Also

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


Elements Field

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5..::.Elements Field
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure See Also Send Feedback
Pinter to an array of DHCP_SUBNET_ELEMENT_DATA_V5 values

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr Elements

See Also

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


NumElements Field

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5..::.NumElements Field
DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure See Also Send Feedback
Number of DHCP_SUBNET_ELEMENT_DATA_V5 in Elements

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint NumElements

See Also

DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5 Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_ELEMENT_TYPE_V5 Enumeration

DHCP_SUBNET_ELEMENT_TYPE_V5 Enumeration
See Also Send Feedback
Defines the set of possible subnet element types

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_SUBNET_ELEMENT_TYPE_V5

Members

Member name | Description
DhcpIpRanges | 0 - Use DhcpIpRangesDhcpOnly instead
DhcpSecondaryHosts | 1 - Not Implemented
DhcpReservedIps | 2 - IP reserverations
DhcpExcludedIpRanges | 3 - Excluded IP ranges or 'Pools'
DhcpIpRangesDhcpOnly | 5 - DHCP IP range only
DhcpIpRangesDhcpBootp | 6 - DHCP and/or Bootp ranges. Use this type to get the default range for a subnet
DhcpIpRangesBootpOnly | 7 - BOOTP IP range only

Remarks

Based on DHCP_SUBNET_ELEMENT_TYPE [MSDN]

Notice enum value 4 is missing. I came to this because EnumSubnetElements was returning invalid parameter when
the this enum was of normal numbering 0...6

See Also

Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_INFO Structure

DHCP_SUBNET_INFO Structure
Members See Also Send Feedback
Defines information describing a subnet

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DHCP_SUBNET_INFO

Remarks

Based on DHCP_SUBNET_INFO [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential, CharSet = CharSet.Unicode)]

See Also

DHCP_SUBNET_INFO Members
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_INFO Members

[image]

DHCP Server Management Objects
DHCP_SUBNET_INFO Members
DHCP_SUBNET_INFO Structure Fields See Also Send Feedback

The DHCP_SUBNET_INFO type exposes the following members.

Fields

Name | Description
PrimaryHost | Ignored
SubnetAddress | Subnet network IP
SubnetComment | Description value for subnet
SubnetMask | Subnet network mask
SubnetName | Name value for subnet
SubnetState | Subnet State (Enable, Disabled...)

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_INFO Fields

[image]

DHCP Server Management Objects
DHCP_SUBNET_INFO Fields
DHCP_SUBNET_INFO Structure See Also Send Feedback

The DHCP_SUBNET_INFO type exposes the following members.

Fields

Name | Description
PrimaryHost | Ignored
SubnetAddress | Subnet network IP
SubnetComment | Description value for subnet
SubnetMask | Subnet network mask
SubnetName | Name value for subnet
SubnetState | Subnet State (Enable, Disabled...)

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


PrimaryHost Field

DHCP_SUBNET_INFO..::.PrimaryHost Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Ignored

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_HOST_INFO PrimaryHost

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetAddress Field

DHCP_SUBNET_INFO..::.SubnetAddress Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Subnet network IP

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint SubnetAddress

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetComment Field

DHCP_SUBNET_INFO..::.SubnetComment Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Description value for subnet

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SubnetComment

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetMask Field

DHCP_SUBNET_INFO..::.SubnetMask Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Subnet network mask

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint SubnetMask

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetName Field

DHCP_SUBNET_INFO..::.SubnetName Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Name value for subnet

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SubnetName

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


SubnetState Field

DHCP_SUBNET_INFO..::.SubnetState Field
DHCP_SUBNET_INFO Structure See Also Send Feedback
Subnet State (Enable, Disabled...)

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DHCP_SUBNET_STATE SubnetState

See Also

DHCP_SUBNET_INFO Structure
Unf.Dhcp.Smo.Interop Namespace


DHCP_SUBNET_STATE Enumeration

DHCP_SUBNET_STATE Enumeration
See Also Send Feedback
Defines the set of possible states for a subnet

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DHCP_SUBNET_STATE

Members

Member name | Description
DhcpSubnetEnabled | Subnet Enabled
DhcpSubnetDisabled | Subnet Disabled
DhcpSubnetEnabledSwitched | Subnet Enabled and DHCP server is gateway
DhcpSubnetDisabledSwitched | SUbnet Disabled and DHCP server is gateway
DhcpSubnetInvalidState | Subnet in invalid state

Remarks

Based on DHCP_SUBNET_STATE [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DhcpsapiError Class

DhcpsapiError Class
Members See Also Send Feedback
Helper class for controlling DHCPSAPI error codes and their description strings

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static class DhcpsapiError

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.Interop..::.DhcpsapiError

See Also

DhcpsapiError Members
Unf.Dhcp.Smo.Interop Namespace


DhcpsapiError Members

[image]

DHCP Server Management Objects
DhcpsapiError Members
DhcpsapiError Class Methods See Also Send Feedback

The DhcpsapiError type exposes the following members.

Methods

Name | Description
GetDesc | Gets description string based on error code

See Also

DhcpsapiError Class
Unf.Dhcp.Smo.Interop Namespace


DhcpsapiError Methods

[image]

DHCP Server Management Objects
DhcpsapiError Methods
DhcpsapiError Class See Also Send Feedback

The DhcpsapiError type exposes the following members.

Methods

Name | Description
GetDesc | Gets description string based on error code

See Also

DhcpsapiError Class
Unf.Dhcp.Smo.Interop Namespace


GetDesc Method

DhcpsapiError..::.GetDesc Method
DhcpsapiError Class See Also Send Feedback
Gets description string based on error code

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static string GetDesc(
    DhcpsapiErrorType e
)

Parameters

e
Type: Unf.Dhcp.Smo.Interop..::.DhcpsapiErrorType
Error code in DHCPSAPIErrorType enumeration

Return Value

Error description string

See Also

DhcpsapiError Class
Unf.Dhcp.Smo.Interop Namespace


DhcpsapiErrorType Enumeration

DhcpsapiErrorType Enumeration
See Also Send Feedback
DHCP Server Management API Error Codes

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal enum DhcpsapiErrorType

Members

Member name | Description
ERROR_DHCP_REGISTRY_INIT_FAILED |
ERROR_DHCP_DATABASE_INIT_FAILED |
ERROR_DHCP_RPC_INIT_FAILED |
ERROR_DHCP_NETWORK_INIT_FAILED |
ERROR_DHCP_SUBNET_EXISTS |
ERROR_DHCP_SUBNET_NOT_PRESENT |
ERROR_DHCP_PRIMARY_NOT_FOUND |
ERROR_DHCP_ELEMENT_CANT_REMOVE |
ERROR_DHCP_OPTION_EXISTS |
ERROR_DHCP_OPTION_NOT_PRESENT |
ERROR_DHCP_ADDRESS_NOT_AVAILABLE |
ERROR_DHCP_RANGE_FULL |
ERROR_DHCP_JET_ERROR |
ERROR_DHCP_CLIENT_EXISTS |
ERROR_DHCP_INVALID_DHCP_MESSAGE |
ERROR_DHCP_INVALID_DHCP_CLIENT |
ERROR_DHCP_SERVICE_PAUSED |
ERROR_DHCP_NOT_RESERVED_CLIENT |
ERROR_DHCP_RESERVED_CLIENT |
ERROR_DHCP_RANGE_TOO_SMALL |
ERROR_DHCP_IPRANGE_EXISTS |
ERROR_DHCP_RESERVEDIP_EXISTS |
ERROR_DHCP_INVALID_RANGE |
ERROR_DHCP_RANGE_EXTENDED |
ERROR_DHCP_RANGE_EXTENSION_TOO_SMALL |
ERROR_DHCP_WARNING_RANGE_EXTENDED_LESS |
ERROR_DHCP_JET_CONV_REQUIRED |
ERROR_DHCP_SERVER_INVALID_BOOT_FILE_TABLE |
ERROR_DHCP_SERVER_UNKNOWN_BOOT_FILE_NAME |
ERROR_DHCP_SUPER_SCOPE_NAME_TOO_LONG |
ERROR_DHCP_IP_ADDRESS_IN_USE |
ERROR_DHCP_LOG_FILE_PATH_TOO_LONG |
ERROR_DHCP_UNSUPPORTED_CLIENT |
ERROR_DHCP_SERVER_INTERFACE_NOTIFICATION_EVENT |
ERROR_DHCP_JET97_CONV_REQUIRED |
ERROR_DHCP_ROGUE_INIT_FAILED |
ERROR_DHCP_ROGUE_SAMSHUTDOWN |
ERROR_DHCP_ROGUE_NOT_AUTHORIZED |
ERROR_DHCP_ROGUE_DS_UNREACHABLE |
ERROR_DHCP_ROGUE_DS_CONFLICT |
ERROR_DHCP_ROGUE_NOT_OUR_ENTERPRISE |
ERROR_DHCP_STANDALONE_IN_DS |
ERROR_DHCP_CLASS_NOT_FOUND |
ERROR_DHCP_CLASS_ALREADY_EXISTS |
ERROR_DHCP_SCOPE_NAME_TOO_LONG |
ERROR_DHCP_DEFAULT_SCOPE_EXISTS |
ERROR_DHCP_CANT_CHANGE_ATTRIBUTE |
ERROR_DHCP_IPRANGE_CONV_ILLEGAL |
ERROR_DHCP_NETWORK_CHANGED |
ERROR_DHCP_CANNOT_MODIFY_BINDINGS |
ERROR_DHCP_SUBNET_EXISTS_2 |
ERROR_DHCP_MSCOPE_EXISTS |
ERROR_DHCP_MSCOPE_RANGE_TOO_SMALL |
ERROR_DDS_NO_DS_AVAILABLE |
ERROR_DDS_NO_DHCP_ROOT |
ERROR_DDS_UNEXPECTED_ERROR |
ERROR_DDS_TOO_MANY_ERRORS |
ERROR_DDS_DHCP_SERVER_NOT_FOUND |
ERROR_DDS_OPTION_ALREADY_EXISTS |
ERROR_DDS_OPTION_DOES_NOT_EXIST |
ERROR_DDS_CLASS_EXISTS |
ERROR_DDS_CLASS_DOES_NOT_EXIST |
ERROR_DDS_SERVER_ALREADY_EXISTS |
ERROR_DDS_SERVER_DOES_NOT_EXIST |
ERROR_DDS_SERVER_ADDRESS_MISMATCH |
ERROR_DDS_SUBNET_EXISTS |
ERROR_DDS_SUBNET_HAS_DIFF_SUPER_SCOPE |
ERROR_DDS_SUBNET_NOT_PRESENT |
ERROR_DDS_RESERVATION_NOT_PRESENT |
ERROR_DDS_RESERVATION_CONFLICT |
ERROR_DDS_POSSIBLE_RANGE_CONFLICT |
ERROR_DDS_RANGE_DOES_NOT_EXIST |

Remarks

Based on DHCP Server Management API Error Codes [MSDN]

See Also

Unf.Dhcp.Smo.Interop Namespace


DWORD_DWORD Structure

DWORD_DWORD Structure
Members See Also Send Feedback
Defines a 64-bit integer value

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal struct DWORD_DWORD

Remarks

Based on DWORD_DWORD [MSDN]

Interop Attributes
CopyC#
[StructLayout(LayoutKind.Sequential)]

See Also

DWORD_DWORD Members
Unf.Dhcp.Smo.Interop Namespace


DWORD_DWORD Members

[image]

DHCP Server Management Objects
DWORD_DWORD Members
DWORD_DWORD Structure Fields See Also Send Feedback

The DWORD_DWORD type exposes the following members.

Fields

Name | Description
LowerWord2 | Lower 32bits
UpperWord1 | Upper 32bits

See Also

DWORD_DWORD Structure
Unf.Dhcp.Smo.Interop Namespace


DWORD_DWORD Fields

[image]

DHCP Server Management Objects
DWORD_DWORD Fields
DWORD_DWORD Structure See Also Send Feedback

The DWORD_DWORD type exposes the following members.

Fields

Name | Description
LowerWord2 | Lower 32bits
UpperWord1 | Upper 32bits

See Also

DWORD_DWORD Structure
Unf.Dhcp.Smo.Interop Namespace


LowerWord2 Field

DWORD_DWORD..::.LowerWord2 Field
DWORD_DWORD Structure See Also Send Feedback
Lower 32bits

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint LowerWord2

See Also

DWORD_DWORD Structure
Unf.Dhcp.Smo.Interop Namespace


UpperWord1 Field

DWORD_DWORD..::.UpperWord1 Field
DWORD_DWORD Structure See Also Send Feedback
Upper 32bits

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public uint UpperWord1

See Also

DWORD_DWORD Structure
Unf.Dhcp.Smo.Interop Namespace


MemManager Class

MemManager Class
Members See Also Send Feedback
Helper class to manage heap memory allocations used by unmanaged function calls via Platform Invoke

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal class MemManager : IDisposable

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.Interop..::.MemManager

See Also

MemManager Members
Unf.Dhcp.Smo.Interop Namespace


MemManager Members

[image]

DHCP Server Management Objects
MemManager Members
MemManager Class Constructors Methods Fields See Also Send Feedback

The MemManager type exposes the following members.

Constructors

Name | Description
MemManager |

Methods

Name | Description
AllocArray | Allocates and tracks memory needed to marshal a array of type and arraysize to the unmanaged memory heap
AllocByteArray | Allocates, copies and tracks memory needed to marshal a Byte array to the unmanaged memory heap
AllocString | Allocates, copies and tracks memory needed to marshal a string to the unmanaged memory heap
AllocStruct | Allocates, copies and tracks memory needed to marshal a structure to the unmanaged memory heap
Dispose | Overloaded.
Finalize | (Overrides Object ..::. Finalize()()().)

Fields

Name | Description
allocations | List of all unmanaged memory allocations made by an instance of this class. Allocations will be deleted on dispose.
isDisposed | Has this object been disposed already?

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


MemManager Constructor

MemManager Constructor
MemManager Class See Also Send Feedback
Initializes a new instance of the MemManager class.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MemManager()

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


MemManager Fields

[image]

DHCP Server Management Objects
MemManager Fields
MemManager Class See Also Send Feedback

The MemManager type exposes the following members.

Fields

Name | Description
allocations | List of all unmanaged memory allocations made by an instance of this class. Allocations will be deleted on dispose.
isDisposed | Has this object been disposed already?

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


allocations Field

MemManager..::.allocations Field
MemManager Class See Also Send Feedback
List of all unmanaged memory allocations made by an instance of this class. Allocations will be deleted on dispose.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected List<IntPtr> allocations

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


isDisposed Field

MemManager..::.isDisposed Field
MemManager Class See Also Send Feedback
Has this object been disposed already?

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected bool isDisposed

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


MemManager Methods

[image]

DHCP Server Management Objects
MemManager Methods
MemManager Class See Also Send Feedback

The MemManager type exposes the following members.

Methods

Name | Description
AllocArray | Allocates and tracks memory needed to marshal a array of type and arraysize to the unmanaged memory heap
AllocByteArray | Allocates, copies and tracks memory needed to marshal a Byte array to the unmanaged memory heap
AllocString | Allocates, copies and tracks memory needed to marshal a string to the unmanaged memory heap
AllocStruct | Allocates, copies and tracks memory needed to marshal a structure to the unmanaged memory heap
Dispose | Overloaded.
Finalize | (Overrides Object ..::. Finalize()()().)

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


AllocArray Method

MemManager..::.AllocArray Method
MemManager Class Example See Also Send Feedback
Allocates and tracks memory needed to marshal a array of type and arraysize to the unmanaged memory heap

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr AllocArray(
    Type type,
    uint arraysize
)

Parameters

type
Type: System..::.Type
Type of element used in allocated array
arraysize
Type: System..::.UInt32
Number of items in allocated array

Return Value

Pointer to an allocated array of type. Size of allocation = (sizeof(type)*arraysize)

Examples

CopyC#
using (MemManager mem = new MemManager())
{
    DHCP_OPTION_DATA_ELEMENT element;
    DHCP_OPTION_DATA data = new DHCP_OPTION_DATA();

    data.NumElements = (UInt32)/*Some Length*/;
    data.Elements = Mem.AllocArray(typeof(DHCP_OPTION_DATA_ELEMENT), data.NumElements);
    IntPtr iptr;
    for (int i = 0; i < data.NumElements; i++)
    {
        element = new DHCP_OPTION_DATA_ELEMENT();
        element.OptionType = DHCP_OPTION_DATA_TYPE.DhcpByteOption;
        element.ByteOption = /*Some Byte Data*/;

        iptr = (IntPtr)(data.Elements.ToInt32() + (i * Marshal.SizeOf(typeof(DHCP_OPTION_DATA_ELEMENT))));
        Marshal.StructureToPtr(element, iptr, false);
    }
}

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


AllocByteArray Method

MemManager..::.AllocByteArray Method
MemManager Class Example See Also Send Feedback
Allocates, copies and tracks memory needed to marshal a Byte array to the unmanaged memory heap

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr AllocByteArray(
    byte[] bytes
)

Parameters

bytes
Type: array< System..::.Byte >[]()[]
Byte array to allocate memory for and copy to that allocation

Return Value

Pointer to allocated memory based on Btye array

Examples

CopyC#
using (MemManager mem = new MemManager())
{
    DHCP_IP_RESERVATION_V4 rip = new DHCP_IP_RESERVATION_V4();
    ...
    Byte[] mac = /*MAC BYTES*/;
    DHCP_CLIENT_UID uid = new DHCP_CLIENT_UID();
    uid.DataLength = (uint)mac.Length;
    uid.Data = Mem.AllocByteArray(mac);
    rip.ReservedForClient = Mem.AllocStruct(uid);
    ...
}

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


AllocString Method

MemManager..::.AllocString Method
MemManager Class Example See Also Send Feedback
Allocates, copies and tracks memory needed to marshal a string to the unmanaged memory heap

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr AllocString(
    string str
)

Parameters

str
Type: System..::.String
String to allocate memory for and copy to that allocation

Return Value

Pointer to allocated memory based on string parameter

Examples

CopyC#
using (MemManager mem = new MemManager())
{
    ...
    info.ClientName = Mem.AllocString(/*String Hostname*/);
    ...
}

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


AllocStruct Method

MemManager..::.AllocStruct Method
MemManager Class Example See Also Send Feedback
Allocates, copies and tracks memory needed to marshal a structure to the unmanaged memory heap

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public IntPtr AllocStruct(
    Object structure
)

Parameters

structure
Type: System..::.Object
Structure to allocate memory for and copy to that allocation

Return Value

Pointer to allocated memory based on structure

Examples

CopyC#
using (MemManager mem = new MemManager())
{
    DHCP_IP_RESERVATION_V4 rip = new DHCP_IP_RESERVATION_V4();
    ...
    Byte[] mac = /*MAC BYTES*/;
    DHCP_CLIENT_UID uid = new DHCP_CLIENT_UID();
    uid.DataLength = (uint)mac.Length;
    uid.Data = Mem.AllocByteArray(mac);
    rip.ReservedForClient = Mem.AllocStruct(uid);
    ...
}

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


Dispose Method

[image]

DHCP Server Management Objects
MemManager..::.Dispose Method
MemManager Class See Also Send Feedback

Overload List

Name | Description
Dispose()()() | Dummy Dispose
Dispose(Boolean) | Cleaup up this object's umanaged memory allocations.

See Also

MemManager Class
MemManager Members
Unf.Dhcp.Smo.Interop Namespace


Dispose Method

MemManager..::.Dispose Method
MemManager Class See Also Send Feedback
Dummy Dispose

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public void Dispose()

Implements

IDisposable..::.Dispose()()()

See Also

MemManager Class
Dispose Overload
Unf.Dhcp.Smo.Interop Namespace


Dispose Method (Boolean)

MemManager..::.Dispose Method (Boolean)
MemManager Class See Also Send Feedback
Cleaup up this object's umanaged memory allocations.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: System..::.Boolean
Called by managed dispose?

See Also

MemManager Class
Dispose Overload
Unf.Dhcp.Smo.Interop Namespace


Finalize Method

MemManager..::.Finalize Method
MemManager Class See Also Send Feedback

[Missing <summary> documentation for M:Unf.Dhcp.Smo.Interop.MemManager.Finalize]

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected override void Finalize()

See Also

MemManager Class
Unf.Dhcp.Smo.Interop Namespace


NativeMethods Class

NativeMethods Class
Members See Also Send Feedback
Contains external unmanaged code functions from DHCPSAPI Windows C library. This class is part of the platform invoke (p/invoke) wrapper used in the Unf.Dhcp.Smo .NET Library.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static class NativeMethods

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.Interop..::.NativeMethods

See Also

NativeMethods Members
Unf.Dhcp.Smo.Interop Namespace
Consuming Unmanaged DLL Functions [MSDN]


NativeMethods Members

[image]

DHCP Server Management Objects
NativeMethods Members
NativeMethods Class Methods See Also Send Feedback

The NativeMethods type exposes the following members.

Methods

Name | Description
DhcpAddSubnetElementV5 | Adds an element describing a feature or aspect of the subnet to the subnet entry in the DHCP database.
DhcpCreateClientInfo | Creates a client information record on the DHCP server.
DhcpCreateSubnet | Creates a new subnet on the DHCP server.
DhcpDeleteClientInfo | Deletes a client information record from the DHCP server.
DhcpDeleteSubnet | Deletes a subnet from the DHCP server.
DhcpEnumOptionsV5 | Returns an enumerated list of DHCP options for a given class and/or vendor.
DhcpEnumOptionValuesV5 | Returns an enumerated list of option values (the option data and the associated ID number) for a specific scope within a given class.
DhcpEnumSubnetClients | Returns an enumerated list of clients with served IP addresses in the specified subnet.
DhcpEnumSubnetElementsV5 | Returns an enumerated list of elements for a specific DHCP subnet.
DhcpEnumSubnets | Returns an enumerated list of subnets defined on the DHCP server.
DhcpGetClientInfo | Returns information about a specific DHCP client.
DhcpGetOptionInfoV5 | Returns information on a specific DHCP option.
DhcpGetOptionValueV5 | Retrieves a DHCP option value (the option code and associated data) for a particular scope.
DhcpGetSubnetInfo | Returns information on a specific subnet.
DhcpRemoveOptionValueV5 | Removes an option value from a scope defined on the DHCP server.
DhcpRemoveSubnetElementV5 | Removes an element from a subnet defined on the DHCP server.
DhcpRpcFreeMemory | Frees a block of buffer space returned as a parameter by the Remote Procedure Call (RPC) service.
DhcpSetClientInfo | Sets information on a client whose IP address lease is administrated by the DHCP server.
DhcpSetOptionValueV5 | Sets information for a specific option value on the DHCP server.
DhcpSetSubnetInfo | Sets information about a subnet defined on the DHCP server.

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


NativeMethods Methods

[image]

DHCP Server Management Objects
NativeMethods Methods
NativeMethods Class See Also Send Feedback

The NativeMethods type exposes the following members.

Methods

Name | Description
DhcpAddSubnetElementV5 | Adds an element describing a feature or aspect of the subnet to the subnet entry in the DHCP database.
DhcpCreateClientInfo | Creates a client information record on the DHCP server.
DhcpCreateSubnet | Creates a new subnet on the DHCP server.
DhcpDeleteClientInfo | Deletes a client information record from the DHCP server.
DhcpDeleteSubnet | Deletes a subnet from the DHCP server.
DhcpEnumOptionsV5 | Returns an enumerated list of DHCP options for a given class and/or vendor.
DhcpEnumOptionValuesV5 | Returns an enumerated list of option values (the option data and the associated ID number) for a specific scope within a given class.
DhcpEnumSubnetClients | Returns an enumerated list of clients with served IP addresses in the specified subnet.
DhcpEnumSubnetElementsV5 | Returns an enumerated list of elements for a specific DHCP subnet.
DhcpEnumSubnets | Returns an enumerated list of subnets defined on the DHCP server.
DhcpGetClientInfo | Returns information about a specific DHCP client.
DhcpGetOptionInfoV5 | Returns information on a specific DHCP option.
DhcpGetOptionValueV5 | Retrieves a DHCP option value (the option code and associated data) for a particular scope.
DhcpGetSubnetInfo | Returns information on a specific subnet.
DhcpRemoveOptionValueV5 | Removes an option value from a scope defined on the DHCP server.
DhcpRemoveSubnetElementV5 | Removes an element from a subnet defined on the DHCP server.
DhcpRpcFreeMemory | Frees a block of buffer space returned as a parameter by the Remote Procedure Call (RPC) service.
DhcpSetClientInfo | Sets information on a client whose IP address lease is administrated by the DHCP server.
DhcpSetOptionValueV5 | Sets information for a specific option value on the DHCP server.
DhcpSetSubnetInfo | Sets information about a subnet defined on the DHCP server.

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpAddSubnetElementV5 Method

NativeMethods..::.DhcpAddSubnetElementV5 Method
NativeMethods Class See Also Send Feedback
Adds an element describing a feature or aspect of the subnet to the subnet entry in the DHCP database.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpAddSubnetElementV5(
    string ServerIpAddress,
    uint SubnetAddress,
    ref DHCP_SUBNET_ELEMENT_DATA_V5 AddElementInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
AddElementInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5 %
Subnet element to add

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpAddSubnetElementV5 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpCreateClientInfo Method

NativeMethods..::.DhcpCreateClientInfo Method
NativeMethods Class See Also Send Feedback
Creates a client information record on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpCreateClientInfo(
    string ServerIpAddress,
    ref DHCP_CLIENT_INFO ClientInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
ClientInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_CLIENT_INFO %
Client info to create

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpCreateClientInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpCreateSubnet Method

NativeMethods..::.DhcpCreateSubnet Method
NativeMethods Class See Also Send Feedback
Creates a new subnet on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpCreateSubnet(
    string ServerIpAddress,
    uint SubnetAddress,
    ref DHCP_SUBNET_INFO SubnetInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
SubnetInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_INFO %
Subnet info to create

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpCreateSubnet [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpDeleteClientInfo Method

NativeMethods..::.DhcpDeleteClientInfo Method
NativeMethods Class See Also Send Feedback
Deletes a client information record from the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpDeleteClientInfo(
    string ServerIpAddress,
    ref DHCP_SEARCH_INFO SearchInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SearchInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SEARCH_INFO %
Search parameters to delete by

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpDeleteClientInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpDeleteSubnet Method

NativeMethods..::.DhcpDeleteSubnet Method
NativeMethods Class See Also Send Feedback
Deletes a subnet from the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpDeleteSubnet(
    string ServerIpAddress,
    uint SubnetAddress,
    DHCP_FORCE_FLAG ForceFlag
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
ForceFlag
Type: Unf.Dhcp.Smo.Interop..::.DHCP_FORCE_FLAG
Full force or otherwise

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpDeleteSubnet [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpEnumOptionsV5 Method

NativeMethods..::.DhcpEnumOptionsV5 Method
NativeMethods Class See Also Send Feedback
Returns an enumerated list of DHCP options for a given class and/or vendor.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpEnumOptionsV5(
    string ServerIpAddress,
    uint Flags,
    string ClassName,
    string VendorName,
    ref uint ResumeHandle,
    uint PreferredMaximum,
    out IntPtr Options,
    out uint OptionsRead,
    out uint OptionsTotal
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
Use 0 when no vendor
ClassName
Type: System..::.String
Option class name, use null for Dhcp
VendorName
Type: System..::.String
Vendor name, use null when flag is 0
ResumeHandle
Type: System..::.UInt32 %
Pointer to start of next iteration
PreferredMaximum
Type: System..::.UInt32
Options
Type: System..::.IntPtr %
Pointer to DHCP_OPTION_VALUE_ARRAY
OptionsRead
Type: System..::.UInt32 %
Number of values read on one call
OptionsTotal
Type: System..::.UInt32 %
Total number of values left to be read on server

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpEnumOptionsV6 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpEnumOptionValuesV5 Method

NativeMethods..::.DhcpEnumOptionValuesV5 Method
NativeMethods Class See Also Send Feedback
Returns an enumerated list of option values (the option data and the associated ID number) for a specific scope within a given class.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpEnumOptionValuesV5(
    string ServerIpAddress,
    uint Flags,
    string ClassName,
    string VendorName,
    ref DHCP_OPTION_SCOPE_INFO ScopeInfo,
    ref uint ResumeHandle,
    uint PreferredMaximum,
    out IntPtr OptionValues,
    out uint OptionsRead,
    out uint OptionsTotal
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
Use 0 when no vendor
ClassName
Type: System..::.String
Option class name, use null for Dhcp
VendorName
Type: System..::.String
Vendor name, use null when flag is 0
ScopeInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_SCOPE_INFO %
Information identifying scope (server, subnet, or reservation) to be enumerated
ResumeHandle
Type: System..::.UInt32 %
Pointer to start of next iteration
PreferredMaximum
Type: System..::.UInt32
Max bytes returned from one call
OptionValues
Type: System..::.IntPtr %
Pointer to DHCP_OPTION_VALUE_ARRAY
OptionsRead
Type: System..::.UInt32 %
Number of values read on one call
OptionsTotal
Type: System..::.UInt32 %
Total number of values left to be read on server

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpEnumOptionValuesV6 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpEnumSubnetClients Method

NativeMethods..::.DhcpEnumSubnetClients Method
NativeMethods Class See Also Send Feedback
Returns an enumerated list of clients with served IP addresses in the specified subnet.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpEnumSubnetClients(
    string ServerIpAddress,
    uint SubnetAddress,
    ref uint ResumeHandle,
    uint PreferredMaximum,
    out IntPtr ClientInfo,
    out uint ElementsRead,
    out uint ElementsTotal
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
ResumeHandle
Type: System..::.UInt32 %
Pointer to start of next iteration
PreferredMaximum
Type: System..::.UInt32
Max number of bytes returned in one call
ClientInfo
Type: System..::.IntPtr %
Pointer to DHCP_CLIENT_INFO_ARRAY
ElementsRead
Type: System..::.UInt32 %
Number of items read on one call
ElementsTotal
Type: System..::.UInt32 %
Total items left to be read on server

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpEnumSubnetClients [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpEnumSubnetElementsV5 Method

NativeMethods..::.DhcpEnumSubnetElementsV5 Method
NativeMethods Class See Also Send Feedback
Returns an enumerated list of elements for a specific DHCP subnet.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpEnumSubnetElementsV5(
    string ServerIpAddress,
    uint SubnetAddress,
    DHCP_SUBNET_ELEMENT_TYPE_V5 EnumElementType,
    ref uint ResumeHandle,
    uint PreferredMaximum,
    out IntPtr EnumElementInfo,
    out uint ElementsRead,
    out uint ElementsTotal
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
EnumElementType
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_TYPE_V5
Type of elements to enumerate
ResumeHandle
Type: System..::.UInt32 %
Pointer to start of next iteration
PreferredMaximum
Type: System..::.UInt32
Max number of bytes returned in one call
EnumElementInfo
Type: System..::.IntPtr %
Pointer to DHCP_SUBNET_ELEMENT_INFO_ARRAY_V5
ElementsRead
Type: System..::.UInt32 %
Number of items read on one call
ElementsTotal
Type: System..::.UInt32 %
Total items left to be read on server

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpEnumSubnetElementsV5 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpEnumSubnets Method

NativeMethods..::.DhcpEnumSubnets Method
NativeMethods Class See Also Send Feedback
Returns an enumerated list of subnets defined on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpEnumSubnets(
    string ServerIpAddress,
    ref uint ResumeHandle,
    uint PreferredMaximum,
    out IntPtr EnumInfo,
    out uint ElementsRead,
    out uint ElementsTotal
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
ResumeHandle
Type: System..::.UInt32 %
Pointer to start of next iteration
PreferredMaximum
Type: System..::.UInt32
Max number of subnets returned in one call
EnumInfo
Type: System..::.IntPtr %
Pointer to DHCP_IP_ARRAY
ElementsRead
Type: System..::.UInt32 %
Number of items read on one call
ElementsTotal
Type: System..::.UInt32 %
Total items left to be read on server

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpEnumSubnets [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpGetClientInfo Method

NativeMethods..::.DhcpGetClientInfo Method
NativeMethods Class See Also Send Feedback
Returns information about a specific DHCP client.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpGetClientInfo(
    string ServerIpAddress,
    ref DHCP_SEARCH_INFO SearchInfo,
    out IntPtr ClientInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SearchInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SEARCH_INFO %
Search parameters
ClientInfo
Type: System..::.IntPtr %
Pointer to DHCP_CLIENT_INFO

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpGetClientInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpGetOptionInfoV5 Method

NativeMethods..::.DhcpGetOptionInfoV5 Method
NativeMethods Class See Also Send Feedback
Returns information on a specific DHCP option.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpGetOptionInfoV5(
    string ServerIpAddress,
    uint Flags,
    uint OptionID,
    string ClassName,
    string VendorName,
    out IntPtr OptionInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
Use 0 when no vendor
OptionID
Type: System..::.UInt32
Option ID, see rfc2132
ClassName
Type: System..::.String
Option class name, use null for Dhcp
VendorName
Type: System..::.String
Vendor name, use null when flag is 0
OptionInfo
Type: System..::.IntPtr %
Pointer to DHCP_OPTION

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpGetOptionInfoV6 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpGetOptionValueV5 Method

NativeMethods..::.DhcpGetOptionValueV5 Method
NativeMethods Class See Also Send Feedback
Retrieves a DHCP option value (the option code and associated data) for a particular scope.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpGetOptionValueV5(
    string ServerIpAddress,
    uint Flags,
    uint OptionID,
    string ClassName,
    string VendorName,
    ref DHCP_OPTION_SCOPE_INFO ScopeInfo,
    out IntPtr OptionValue
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
OptionID
Type: System..::.UInt32
ClassName
Type: System..::.String
VendorName
Type: System..::.String
ScopeInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_SCOPE_INFO %
OptionValue
Type: System..::.IntPtr %

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpGetOptionValue [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpGetSubnetInfo Method

NativeMethods..::.DhcpGetSubnetInfo Method
NativeMethods Class See Also Send Feedback
Returns information on a specific subnet.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpGetSubnetInfo(
    string ServerIpAddress,
    uint SubnetAddress,
    out IntPtr SubnetInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
SubnetInfo
Type: System..::.IntPtr %
Pointer to DHCP_SUBNET_INFO

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpGetSubnetInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpRemoveOptionValueV5 Method

NativeMethods..::.DhcpRemoveOptionValueV5 Method
NativeMethods Class See Also Send Feedback
Removes an option value from a scope defined on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpRemoveOptionValueV5(
    string ServerIpAddress,
    uint Flags,
    uint OptionID,
    string ClassName,
    string VendorName,
    ref DHCP_OPTION_SCOPE_INFO ScopeInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
Use 0 when no vendor
OptionID
Type: System..::.UInt32
Option ID, see rfc2132
ClassName
Type: System..::.String
Option class name, use null for Dhcp
VendorName
Type: System..::.String
Vendor name, use null when flag is 0
ScopeInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_SCOPE_INFO %
Information identifying scope (server, subnet, or reservation)

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpRemoveOptionValueV5 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpRemoveSubnetElementV5 Method

NativeMethods..::.DhcpRemoveSubnetElementV5 Method
NativeMethods Class See Also Send Feedback
Removes an element from a subnet defined on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpRemoveSubnetElementV5(
    string ServerIpAddress,
    uint SubnetAddress,
    ref DHCP_SUBNET_ELEMENT_DATA_V5 RemoveElementInfo,
    DHCP_FORCE_FLAG ForceFlag
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
RemoveElementInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_ELEMENT_DATA_V5 %
Subnet element to be removed
ForceFlag
Type: Unf.Dhcp.Smo.Interop..::.DHCP_FORCE_FLAG
Full force or otherwise

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpRemoveSubnetElementV5 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpRpcFreeMemory Method

NativeMethods..::.DhcpRpcFreeMemory Method
NativeMethods Class See Also Send Feedback
Frees a block of buffer space returned as a parameter by the Remote Procedure Call (RPC) service.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static void DhcpRpcFreeMemory(
    IntPtr BuffPtr
)

Parameters

BuffPtr
Type: System..::.IntPtr
Pointer to data returned by a DHCPSAPI function

Remarks

Based on DhcpRpcFreeMemory [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll")]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpSetClientInfo Method

NativeMethods..::.DhcpSetClientInfo Method
NativeMethods Class See Also Send Feedback
Sets information on a client whose IP address lease is administrated by the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpSetClientInfo(
    string ServerIpAddress,
    ref DHCP_CLIENT_INFO ClientInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
ClientInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_CLIENT_INFO %
Client info to set (update)

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpSetClientInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpSetOptionValueV5 Method

NativeMethods..::.DhcpSetOptionValueV5 Method
NativeMethods Class See Also Send Feedback
Sets information for a specific option value on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpSetOptionValueV5(
    string ServerIpAddress,
    uint Flags,
    uint OptionID,
    string ClassName,
    string VendorName,
    ref DHCP_OPTION_SCOPE_INFO ScopeInfo,
    ref DHCP_OPTION_DATA OptionValue
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
Flags
Type: System..::.UInt32
Use 0 when no vendor
OptionID
Type: System..::.UInt32
Option ID, see rfc2132
ClassName
Type: System..::.String
Option class name, use null for Dhcp
VendorName
Type: System..::.String
Vendor name, use null when flag is 0
ScopeInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_SCOPE_INFO %
Information identifying scope (server, subnet, or reservation)
OptionValue
Type: Unf.Dhcp.Smo.Interop..::.DHCP_OPTION_DATA %
Option data values to be assigned to OptionID

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpSetOptionValueV5 [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


DhcpSetSubnetInfo Method

NativeMethods..::.DhcpSetSubnetInfo Method
NativeMethods Class See Also Send Feedback
Sets information about a subnet defined on the DHCP server.

Namespace: Unf.Dhcp.Smo.Interop
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
internal static uint DhcpSetSubnetInfo(
    string ServerIpAddress,
    uint SubnetAddress,
    ref DHCP_SUBNET_INFO SubnetInfo
)

Parameters

ServerIpAddress
Type: System..::.String
Server IP address in string form
SubnetAddress
Type: System..::.UInt32
Subnet network IP in uint form
SubnetInfo
Type: Unf.Dhcp.Smo.Interop..::.DHCP_SUBNET_INFO %
Subnet info to update

Return Value

UInt which can be mapped to DhcpsapiErrorType

Remarks

Based on DhcpSetSubnetInfo [MSDN]

Interop Attributes
CopyC#
[DllImport("dhcpsapi.dll", CharSet = CharSet.Unicode)]

See Also

NativeMethods Class
Unf.Dhcp.Smo.Interop Namespace


Unf.Dhcp.Smo.Operations Namespace

Unf.Dhcp.Smo.Operations Namespace
Send Feedback
The Unf.Dhcp.Smo.Operations namespace provides a full set DHCP server management operations provided by the DHCP SMO class library. These server operations can be thought of as an abstraction of operations making it easier for the Unf.Dhcp.Smo.WebServices classes to use DHCP SMO. One server operation may involve one or more SMO method calls to complete the task. For example, ServerOperations.CreateSubnet calls methods to create the subnet, its address pool, and DHCP options.

Classes

Class | Description
ServerOperations | Provides a set of DHCP server operations. One server operation may involve one or more SMO method calls to complete the task.


ServerOperations Class

ServerOperations Class
Members See Also Send Feedback
Provides a set of DHCP server operations. One server operation may involve one or more SMO method calls to complete the task.

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static class ServerOperations

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.Operations..::.ServerOperations

See Also

ServerOperations Members
Unf.Dhcp.Smo.Operations Namespace


ServerOperations Members

[image]

DHCP Server Management Objects
ServerOperations Members
ServerOperations Class Methods See Also Send Feedback

The ServerOperations type exposes the following members.

Methods

Name | Description
CreateLease | Creates a client lease on server
CreateReservation | Creates a DHCP IP reservation on server
CreateSubnet | Creates a DHCP subnet on server
CreateSubnetExclusion | Creates a subnet exclusion address pool
DeleteLease | Deletes client lease from server
DeleteReservation | Deletes a DHCP IP reservation on server
DeleteSubnet | Deletes DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP Options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option's values set in scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on DHCP server
GetOptionValue | Retrieves a DHCP option's value(s)
RemoveOptionValue | Removes a DHCP option's value(s)
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Sets an DHCP option's value(s) based on a particluar scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Updates a client on server
UpdateReservation | Updates a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Updates default DHCP subnet address pool (range)

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


ServerOperations Methods

[image]

DHCP Server Management Objects
ServerOperations Methods
ServerOperations Class See Also Send Feedback

The ServerOperations type exposes the following members.

Methods

Name | Description
CreateLease | Creates a client lease on server
CreateReservation | Creates a DHCP IP reservation on server
CreateSubnet | Creates a DHCP subnet on server
CreateSubnetExclusion | Creates a subnet exclusion address pool
DeleteLease | Deletes client lease from server
DeleteReservation | Deletes a DHCP IP reservation on server
DeleteSubnet | Deletes DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP Options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option's values set in scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on DHCP server
GetOptionValue | Retrieves a DHCP option's value(s)
RemoveOptionValue | Removes a DHCP option's value(s)
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Sets an DHCP option's value(s) based on a particluar scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Updates a client on server
UpdateReservation | Updates a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Updates default DHCP subnet address pool (range)

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


CreateLease Method

ServerOperations..::.CreateLease Method
ServerOperations Class See Also Send Feedback
Creates a client lease on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease info to create

Remarks

Client lease will be assigned to a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


CreateReservation Method

ServerOperations..::.CreateReservation Method
ServerOperations Class See Also Send Feedback
Creates a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
IP reservation info

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


CreateSubnet Method

ServerOperations..::.CreateSubnet Method
ServerOperations Class See Also Send Feedback
Creates a DHCP subnet on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet network IP address
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
Default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


CreateSubnetExclusion Method

ServerOperations..::.CreateSubnetExclusion Method
ServerOperations Class See Also Send Feedback
Creates a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create pool in
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range use to created pool

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


DeleteLease Method

ServerOperations..::.DeleteLease Method
ServerOperations Class See Also Send Feedback
Deletes client lease from server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteLease(
    DhcpIpAddress server,
    DhcpIpAddress leaseIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
leaseIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Client lease IP address, used to identify and delete

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


DeleteReservation Method

ServerOperations..::.DeleteReservation Method
ServerOperations Class See Also Send Feedback
Deletes a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpAddress resIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete reservation from
resIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Reservation IP address to delete

Remarks

Lease associated with reservation will also be deleted

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


DeleteSubnet Method

ServerOperations..::.DeleteSubnet Method
ServerOperations Class See Also Send Feedback
Deletes DHCP subnet on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteSubnet(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address identifying subnet

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


DeleteSubnetExclusion Method

ServerOperations..::.DeleteSubnetExclusion Method
ServerOperations Class See Also Send Feedback
Deletes a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete pool from
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range to delete

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumLeases Method

ServerOperations..::.EnumLeases Method
ServerOperations Class See Also Send Feedback
Enumerate all client leases on subnet

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpClient> EnumLeases(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

A list of client leases belonging to subnet

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumOptions Method

ServerOperations..::.EnumOptions Method
ServerOperations Class See Also Send Feedback
Enumerate all DHCP Options available on server (global set of DHCP options)

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOption[] EnumOptions(
    DhcpIpAddress server,
    DhcpOptionClassType classType
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)

Return Value

An array of global DHCP options available on server

Remarks

Only Dhcp class types seems to return a set of possible DHCP options. The other classes share these same DHCP options

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumOptionValues Method

ServerOperations..::.EnumOptionValues Method
ServerOperations Class See Also Send Feedback
Enumerate all DHCP option's values set in scope

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOptionValue[] EnumOptionValues(
    DhcpIpAddress server,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Option scope (Server, Subnet, or Reservation) to enumerate

Return Value

An array of DHCP option's values current set in scope

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumPools Method

ServerOperations..::.EnumPools Method
ServerOperations Class See Also Send Feedback
Enumerate all address pools belonging to subnet

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpIpRange[] EnumPools(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address

Return Value

An array of address pools. The first pool will be the default address pool followed by zero or more exclusion pools

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumReservations Method

ServerOperations..::.EnumReservations Method
ServerOperations Class See Also Send Feedback
Enumerate IP Reservations owned by subnet on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpReservation> EnumReservations(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

A list of reservations on subnet

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


EnumSubnets Method

ServerOperations..::.EnumSubnets Method
ServerOperations Class See Also Send Feedback
Enumerate subnets on DHCP server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpSubnet> EnumSubnets(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to enumerate

Return Value

A list of DhcpSubnets

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


GetOptionValue Method

ServerOperations..::.GetOptionValue Method
ServerOperations Class See Also Send Feedback
Retrieves a DHCP option's value(s)

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOptionValue GetOptionValue(
    DhcpIpAddress server,
    uint optionId,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
optionId
Type: System..::.UInt32
DHCP option identifier (ex. 006 = DNS Servers)
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Get option value from scope (Server, Subnet, or Reservation)

Return Value

A DHCP option value

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


RemoveOptionValue Method

ServerOperations..::.RemoveOptionValue Method
ServerOperations Class See Also Send Feedback
Removes a DHCP option's value(s)

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void RemoveOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

Completes remove all values from option. Option becomes unset

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


ServerFindAllClients Method

ServerOperations..::.ServerFindAllClients Method
ServerOperations Class See Also Send Feedback
Search all subnets on server looking for client leases matching terms

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpClient> ServerFindAllClients(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

A list of client leases matching terms

Remarks

Client filter terms are .NET regex patterns

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


ServerFindOneClient Method

ServerOperations..::.ServerFindOneClient Method
ServerOperations Class See Also Send Feedback
Search all subnets on server looking for first client lease matching terms

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient ServerFindOneClient(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


SetOptionValue Method

ServerOperations..::.SetOptionValue Method
ServerOperations Class See Also Send Feedback
Sets an DHCP option's value(s) based on a particluar scope

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

This method overwrites any previous data set on value.OptionId

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


SubnetFindAllClients Method

ServerOperations..::.SubnetFindAllClients Method
ServerOperations Class See Also Send Feedback
Search subnet for client leases matching terms

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static List<DhcpClient> SubnetFindAllClients(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

A list of client leases matching terms

Remarks

Client filter terms are .NET regex patterns

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


SubnetFindOneClient Method

ServerOperations..::.SubnetFindOneClient Method
ServerOperations Class See Also Send Feedback
Search subnet for first client lease matching terms

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient SubnetFindOneClient(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


UpdateLease Method

ServerOperations..::.UpdateLease Method
ServerOperations Class See Also Send Feedback
Updates a client on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease to match and update

Remarks

Client lease will be updated on a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask
Operation will update lease.Mac, lease.Name, lease.Comment, and lease.LeaseExpires on existing lease matching lease.IpAddress and lease.SubnetMask

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


UpdateReservation Method

ServerOperations..::.UpdateReservation Method
ServerOperations Class See Also Send Feedback
Updates a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
Updated IP reservation info

Remarks

Updates res.ReservedMac, res.bAllowedClientTypes, res.Name, and res.Comment based on match of res.ReservedIp

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


UpdateSubnet Method

ServerOperations..::.UpdateSubnet Method
ServerOperations Class See Also Send Feedback
Update DHCP subnet on server

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet object to update

Remarks

Operation will update network.Name, network.Comment, and network.State on existing subnet matching network.Address

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


UpdateSubnetRange Method

ServerOperations..::.UpdateSubnetRange Method
ServerOperations Class See Also Send Feedback
Updates default DHCP subnet address pool (range)

Namespace: Unf.Dhcp.Smo.Operations
Assembly: Unf.Dhcp.Smo (in Unf.Dhcp.Smo.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateSubnetRange(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update pool on
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
New default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange
Removes current address pool and replaces with ipRange. This can be used to change address pool client type (Dhcp, Bootp, or Both)

See Also

ServerOperations Class
Unf.Dhcp.Smo.Operations Namespace


Unf.Dhcp.Smo.WebServices Namespace

Unf.Dhcp.Smo.WebServices Namespace
Send Feedback
The Unf.Dhcp.Smo.WebServices classes interface with Unf.Dhcp.Smo and Unf.Dhcp.Smo.Operations classes to create DHCP Web Services. The web services expose DHCP server management operations found in the Unf.Dhcp.Smo.Operations namespace and in addition use data types defined in the Unf.Dhcp.Smo namespace. Also, an authorization layer has been created via Microsoft’s Authorization Manager (AzMan) framework. This authorization layer implements a trusted subsystem model, authorizing users to manipulate DHCP objects based on roles while a trusted service account performs the actual task on their behalf.

Classes

Class | Description
AzServerOperations | Authorization wrapper for DHCP operations found in ServerOperations. This wrapper uses Microsoft's Authorization Manager framework (AzMan) to provide an authorization layer on DHCP server operation classes.
DhcpAzAccount | Defines an authorizated account in AzMan
DhcpAzGlobalAccount | Defines a global authorizated account in AzMan
DhcpAzIpRangeScope | DHCP IP range authorization scope (IP range level roles/permissions)
DhcpAzScope | Base class for DHCP authorization scopes
DhcpAzServerScope | DHCP server authorization scope (server level roles/permissions)
DhcpAzSubnetScope | DHCP subnet authorization scope (subnet level roles/permissions)
DhcpOperations | DHCP Web Services
DhcpSecurity | DHCP Web Services Authorization Services
DhcpSecurityOps | Provides a set of security operations associated with Unf.Dhcp.Smo.WebServices. These operations provide authorization to DHCP Web Services using Microsoft's Authorization Manager (AzMan) framework. Authentication is performed at the web server level and this application uses the provided user identity (HttpContext.Current.User.Identity) to check authorizations.
Global | Consume global web application events

Enumerations

Enumeration | Description
DhcpAzGlobalRole | DHCP global authorization roles
DhcpAzOps | AzMan authorization operations
DhcpAzRole | Scope specific DHCP authorization roles
DhcpAzScopeType | DHCP authorization scope types


AzServerOperations Class

AzServerOperations Class
Members See Also Send Feedback
Authorization wrapper for DHCP operations found in ServerOperations. This wrapper uses Microsoft's Authorization Manager framework (AzMan) to provide an authorization layer on DHCP server operation classes.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AzServerOperations

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.AzServerOperations

See Also

AzServerOperations Members
Unf.Dhcp.Smo.WebServices Namespace
Developing Applications Using Windows Authorization Manager
Role-Based Access Control for Multi-tier Applications Using Authorization Manager
Authorization Manager Interfaces


AzServerOperations Members

[image]

DHCP Server Management Objects
AzServerOperations Members
AzServerOperations Class Constructors Methods See Also Send Feedback

The AzServerOperations type exposes the following members.

Constructors

Name | Description
AzServerOperations |

Methods

Name | Description
CreateLease | Create a client lease on server
CreateReservation | Create a DHCP IP reservation on server
CreateSubnet | Create a DHCP subnet on server
CreateSubnetExclusion | Create a subnet exclusion address pool
DeleteLease | Delete client lease from server
DeleteReservation | Delete a DHCP IP reservation on server
DeleteSubnet | Delete DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option values set in scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on server
GetOptionValue | Retrieves a DHCP option's value
RemoveOptionValue | Removes a DHCP option's value
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Sets an DHCP option's value based on a particular scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Update a client lease on server
UpdateReservation | Update a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Update default DHCP subnet address pool (range)

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


AzServerOperations Constructor

AzServerOperations Constructor
AzServerOperations Class See Also Send Feedback
Initializes a new instance of the AzServerOperations class.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AzServerOperations()

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


AzServerOperations Methods

[image]

DHCP Server Management Objects
AzServerOperations Methods
AzServerOperations Class See Also Send Feedback

The AzServerOperations type exposes the following members.

Methods

Name | Description
CreateLease | Create a client lease on server
CreateReservation | Create a DHCP IP reservation on server
CreateSubnet | Create a DHCP subnet on server
CreateSubnetExclusion | Create a subnet exclusion address pool
DeleteLease | Delete client lease from server
DeleteReservation | Delete a DHCP IP reservation on server
DeleteSubnet | Delete DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option values set in scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on server
GetOptionValue | Retrieves a DHCP option's value
RemoveOptionValue | Removes a DHCP option's value
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Sets an DHCP option's value based on a particular scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Update a client lease on server
UpdateReservation | Update a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Update default DHCP subnet address pool (range)

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateLease Method

AzServerOperations..::.CreateLease Method
AzServerOperations Class See Also Send Feedback
Create a client lease on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease info to create

Remarks

Client lease will be assigned to a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateReservation Method

AzServerOperations..::.CreateReservation Method
AzServerOperations Class See Also Send Feedback
Create a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
IP reservation info

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning reservation's IP address

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateSubnet Method

AzServerOperations..::.CreateSubnet Method
AzServerOperations Class See Also Send Feedback
Create a DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet network IP address
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
Default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role at server scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateSubnetExclusion Method

AzServerOperations..::.CreateSubnetExclusion Method
AzServerOperations Class See Also Send Feedback
Create a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void CreateSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create pool in
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range use to created pool

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteLease Method

AzServerOperations..::.DeleteLease Method
AzServerOperations Class See Also Send Feedback
Delete client lease from server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteLease(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpAddress leaseIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete lease from
leaseIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Client lease IP address, used to identify and delete

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteReservation Method

AzServerOperations..::.DeleteReservation Method
AzServerOperations Class See Also Send Feedback
Delete a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpAddress resIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete reservation from
resIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Reservation IP address to delete

Remarks

Lease associated with reservation will also be deleted

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning reservation's IP address

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteSubnet Method

AzServerOperations..::.DeleteSubnet Method
AzServerOperations Class See Also Send Feedback
Delete DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteSubnet(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address identifying subnet

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role at server scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteSubnetExclusion Method

AzServerOperations..::.DeleteSubnetExclusion Method
AzServerOperations Class See Also Send Feedback
Deletes a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void DeleteSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete pool from
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range to delete

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumLeases Method

AzServerOperations..::.EnumLeases Method
AzServerOperations Class See Also Send Feedback
Enumerate all client leases on subnet

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient[] EnumLeases(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

A list of client leases belonging to subnet

Remarks

This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumOptions Method

AzServerOperations..::.EnumOptions Method
AzServerOperations Class See Also Send Feedback
Enumerate all DHCP options available on server (global set of DHCP options)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOption[] EnumOptions(
    DhcpIpAddress server,
    DhcpOptionClassType classType
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)

Return Value

An array of global DHCP options available on server

Remarks

Only Dhcp class types seems to return a set of possible DHCP options. The other classes share these same DHCP options

Permissions

Permission | Description
 | Does not require authorization, only authentication

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumOptionValues Method

AzServerOperations..::.EnumOptionValues Method
AzServerOperations Class See Also Send Feedback
Enumerate all DHCP option values set in scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOptionValue[] EnumOptionValues(
    DhcpIpAddress server,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Option scope (Server, Subnet, or Reservation) to enumerate

Return Value

An array of DHCP option's values current set in scope

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least Auditor role on scope owning option values

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumPools Method

AzServerOperations..::.EnumPools Method
AzServerOperations Class See Also Send Feedback
Enumerate all address pools belonging to subnet

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpIpRange[] EnumPools(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address

Return Value

An array of address pools. The first pool will be the default address pool followed by zero or more exclusion pools

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at subnet scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumReservations Method

AzServerOperations..::.EnumReservations Method
AzServerOperations Class See Also Send Feedback
Enumerate IP Reservations owned by subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpReservation[] EnumReservations(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

A list of reservations on subnet

Remarks

This method implements security trimming. User will only 'see' reservations their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning reservation's IP address

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumSubnets Method

AzServerOperations..::.EnumSubnets Method
AzServerOperations Class See Also Send Feedback
Enumerate subnets on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpSubnet[] EnumSubnets(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to enumerate

Return Value

A list of DhcpSubnets

Remarks

This method implements security trimming. User will only 'see' subnets they can access

Permissions

Permission | Description
 | Requires internal limited role. This role will be automatically assigned based on other roles within the subnet and/or IP range

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


GetOptionValue Method

AzServerOperations..::.GetOptionValue Method
AzServerOperations Class See Also Send Feedback
Retrieves a DHCP option's value

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpOptionValue GetOptionValue(
    DhcpIpAddress server,
    uint optionId,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
optionId
Type: System..::.UInt32
DHCP option identifier (ex. 006 = DNS Servers)
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Get option value from scope (Server, Subnet, or Reservation)

Return Value

A DHCP option value

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least Auditor role on scope owning option value

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


RemoveOptionValue Method

AzServerOperations..::.RemoveOptionValue Method
AzServerOperations Class See Also Send Feedback
Removes a DHCP option's value

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void RemoveOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

Completes remove all values from option. Option becomes unset

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least Manager role on scope owning option value

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


ServerFindAllClients Method

AzServerOperations..::.ServerFindAllClients Method
AzServerOperations Class See Also Send Feedback
Search all subnets on server looking for client leases matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient[] ServerFindAllClients(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

A list of client leases matching terms

Remarks

Client filter terms are .NET regex patterns

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at server scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


ServerFindOneClient Method

AzServerOperations..::.ServerFindOneClient Method
AzServerOperations Class See Also Send Feedback
Search all subnets on server looking for first client lease matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient ServerFindOneClient(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at server scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SetOptionValue Method

AzServerOperations..::.SetOptionValue Method
AzServerOperations Class See Also Send Feedback
Sets an DHCP option's value based on a particular scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void SetOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

This method overwrites any previous data set on value.OptionId

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least Manager role on scope owning option value

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SubnetFindAllClients Method

AzServerOperations..::.SubnetFindAllClients Method
AzServerOperations Class See Also Send Feedback
Search subnet for client leases matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient[] SubnetFindAllClients(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

A list of client leases matching terms

Remarks

Client filter terms are .NET regex patterns
This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SubnetFindOneClient Method

AzServerOperations..::.SubnetFindOneClient Method
AzServerOperations Class See Also Send Feedback
Search subnet for first client lease matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpClient SubnetFindOneClient(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns
This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateLease Method

AzServerOperations..::.UpdateLease Method
AzServerOperations Class See Also Send Feedback
Update a client lease on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease to match and update

Remarks

Client lease will be updated on a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask
Operation will update lease.Mac, lease.Name, lease.Comment, and lease.LeaseExpires on existing lease matching lease.IpAddress and lease.SubnetMask

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role on scope owning IP address of client lease

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateReservation Method

AzServerOperations..::.UpdateReservation Method
AzServerOperations Class See Also Send Feedback
Update a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
Updated IP reservation info

Remarks

Updates res.ReservedMac, res.bAllowedClientTypes, res.Name, and res.Comment based on match of res.ReservedIp

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role on scope owning reservation's IP address

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateSubnet Method

AzServerOperations..::.UpdateSubnet Method
AzServerOperations Class See Also Send Feedback
Update DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet object to update

Remarks

Operation will update network.Name, network.Comment, and network.State on existing subnet matching network.Address

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateSubnetRange Method

AzServerOperations..::.UpdateSubnetRange Method
AzServerOperations Class See Also Send Feedback
Update default DHCP subnet address pool (range)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void UpdateSubnetRange(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update pool on
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
New default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange
Removes current address pool and replaces with ipRange. This can be used to change address pool client type (Dhcp, Bootp, or Both)

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

AzServerOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Class

DhcpAzAccount Class
Members See Also Send Feedback
Defines an authorizated account in AzMan

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpAzAccount

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzAccount

See Also

DhcpAzAccount Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Members

[image]

DHCP Server Management Objects
DhcpAzAccount Members
DhcpAzAccount Class Constructors Fields See Also Send Feedback

The DhcpAzAccount type exposes the following members.

Constructors

Name | Description
DhcpAzAccount | Overloaded.

Fields

Name | Description
AccountName | Account name: user@domain, group@domain, domain\user, domain\group
Role | Dhcp authorization role account belongs to

See Also

DhcpAzAccount Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Constructor

[image]

DHCP Server Management Objects
DhcpAzAccount Constructor
DhcpAzAccount Class See Also Send Feedback

Overload List

Name | Description
DhcpAzAccount()()() | Dummy constructor
DhcpAzAccount(String, DhcpAzRole) | Creates new object based on account name and role type

See Also

DhcpAzAccount Class
DhcpAzAccount Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Constructor

DhcpAzAccount Constructor
DhcpAzAccount Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzAccount()

See Also

DhcpAzAccount Class
DhcpAzAccount Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Constructor (String, DhcpAzRole)

DhcpAzAccount Constructor (String, DhcpAzRole)
DhcpAzAccount Class See Also Send Feedback
Creates new object based on account name and role type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzAccount(
    string accountName,
    DhcpAzRole role
)

Parameters

accountName
Type: System..::.String
New account name
role
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzRole
New account role

See Also

DhcpAzAccount Class
DhcpAzAccount Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzAccount Fields

[image]

DHCP Server Management Objects
DhcpAzAccount Fields
DhcpAzAccount Class See Also Send Feedback

The DhcpAzAccount type exposes the following members.

Fields

Name | Description
AccountName | Account name: user@domain, group@domain, domain\user, domain\group
Role | Dhcp authorization role account belongs to

See Also

DhcpAzAccount Class
Unf.Dhcp.Smo.WebServices Namespace


AccountName Field

DhcpAzAccount..::.AccountName Field
DhcpAzAccount Class See Also Send Feedback
Account name: user@domain, group@domain, domain\user, domain\group

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AccountName

See Also

DhcpAzAccount Class
Unf.Dhcp.Smo.WebServices Namespace


Role Field

DhcpAzAccount..::.Role Field
DhcpAzAccount Class See Also Send Feedback
Dhcp authorization role account belongs to

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzRole Role

See Also

DhcpAzAccount Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Class

DhcpAzGlobalAccount Class
Members See Also Send Feedback
Defines a global authorizated account in AzMan

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpAzGlobalAccount

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalAccount

See Also

DhcpAzGlobalAccount Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Members

[image]

DHCP Server Management Objects
DhcpAzGlobalAccount Members
DhcpAzGlobalAccount Class Constructors Fields See Also Send Feedback

The DhcpAzGlobalAccount type exposes the following members.

Constructors

Name | Description
DhcpAzGlobalAccount | Overloaded.

Fields

Name | Description
AccountName | Account name: user@domain, group@domain, domain\user, domain\group
GlobalRole | Dhcp global authorization role account belongs to

See Also

DhcpAzGlobalAccount Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Constructor

[image]

DHCP Server Management Objects
DhcpAzGlobalAccount Constructor
DhcpAzGlobalAccount Class See Also Send Feedback

Overload List

Name | Description
DhcpAzGlobalAccount()()() | Dummy constructor
DhcpAzGlobalAccount(String, DhcpAzGlobalRole) | Creates new object based on account name and role type

See Also

DhcpAzGlobalAccount Class
DhcpAzGlobalAccount Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Constructor

DhcpAzGlobalAccount Constructor
DhcpAzGlobalAccount Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzGlobalAccount()

See Also

DhcpAzGlobalAccount Class
DhcpAzGlobalAccount Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Constructor (String, DhcpAzGlobalRole)

DhcpAzGlobalAccount Constructor (String, DhcpAzGlobalRole)
DhcpAzGlobalAccount Class See Also Send Feedback
Creates new object based on account name and role type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzGlobalAccount(
    string accountName,
    DhcpAzGlobalRole role
)

Parameters

accountName
Type: System..::.String
New account name
role
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalRole
New account role

See Also

DhcpAzGlobalAccount Class
DhcpAzGlobalAccount Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalAccount Fields

[image]

DHCP Server Management Objects
DhcpAzGlobalAccount Fields
DhcpAzGlobalAccount Class See Also Send Feedback

The DhcpAzGlobalAccount type exposes the following members.

Fields

Name | Description
AccountName | Account name: user@domain, group@domain, domain\user, domain\group
GlobalRole | Dhcp global authorization role account belongs to

See Also

DhcpAzGlobalAccount Class
Unf.Dhcp.Smo.WebServices Namespace


AccountName Field

DhcpAzGlobalAccount..::.AccountName Field
DhcpAzGlobalAccount Class See Also Send Feedback
Account name: user@domain, group@domain, domain\user, domain\group

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AccountName

See Also

DhcpAzGlobalAccount Class
Unf.Dhcp.Smo.WebServices Namespace


GlobalRole Field

DhcpAzGlobalAccount..::.GlobalRole Field
DhcpAzGlobalAccount Class See Also Send Feedback
Dhcp global authorization role account belongs to

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzGlobalRole GlobalRole

See Also

DhcpAzGlobalAccount Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzGlobalRole Enumeration

DhcpAzGlobalRole Enumeration
See Also Send Feedback
DHCP global authorization roles

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpAzGlobalRole

Members

Member name | Description
GlobalAuditor | Global read only access
GlobalAdministrator | Global administrator access

See Also

Unf.Dhcp.Smo.WebServices Namespace


DhcpAzIpRangeScope Class

DhcpAzIpRangeScope Class
Members See Also Send Feedback
DHCP IP range authorization scope (IP range level roles/permissions)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpAzIpRangeScope : DhcpAzSubnetScope

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzServerScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzIpRangeScope

See Also

DhcpAzIpRangeScope Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzIpRangeScope Members

[image]

DHCP Server Management Objects
DhcpAzIpRangeScope Members
DhcpAzIpRangeScope Class Constructors Methods Fields See Also Send Feedback

The DhcpAzIpRangeScope type exposes the following members.

Constructors

Name | Description
DhcpAzIpRangeScope | Dummy constructor, sets type

Methods

Name | Description
AccessCheck | A IP range scope check access authorization (Overrides DhcpAzSubnetScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Generates the scope string ID based on IP range in inherited server and subnet IPs (Overrides DhcpAzSubnetScope ..::. GenerateAzScopeName()()().)

Fields

Name | Description
EndIp | End IP address
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address (Inherited from DhcpAzServerScope.)
StartIp | Start IP address
Subnet | DHCP subnet network IP address (Inherited from DhcpAzSubnetScope.)

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzIpRangeScope Constructor

DhcpAzIpRangeScope Constructor
DhcpAzIpRangeScope Class See Also Send Feedback
Dummy constructor, sets type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzIpRangeScope()

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzIpRangeScope Fields

[image]

DHCP Server Management Objects
DhcpAzIpRangeScope Fields
DhcpAzIpRangeScope Class See Also Send Feedback

The DhcpAzIpRangeScope type exposes the following members.

Fields

Name | Description
EndIp | End IP address
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address (Inherited from DhcpAzServerScope.)
StartIp | Start IP address
Subnet | DHCP subnet network IP address (Inherited from DhcpAzSubnetScope.)

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


EndIp Field

DhcpAzIpRangeScope..::.EndIp Field
DhcpAzIpRangeScope Class See Also Send Feedback
End IP address

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress EndIp

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


StartIp Field

DhcpAzIpRangeScope..::.StartIp Field
DhcpAzIpRangeScope Class See Also Send Feedback
Start IP address

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress StartIp

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzIpRangeScope Methods

[image]

DHCP Server Management Objects
DhcpAzIpRangeScope Methods
DhcpAzIpRangeScope Class See Also Send Feedback

The DhcpAzIpRangeScope type exposes the following members.

Methods

Name | Description
AccessCheck | A IP range scope check access authorization (Overrides DhcpAzSubnetScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Generates the scope string ID based on IP range in inherited server and subnet IPs (Overrides DhcpAzSubnetScope ..::. GenerateAzScopeName()()().)

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


AccessCheck Method

DhcpAzIpRangeScope..::.AccessCheck Method
DhcpAzIpRangeScope Class See Also Send Feedback
A IP range scope check access authorization

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool AccessCheck(
    string opDesc,
    IAzClientContext2 azClient,
    DhcpAzOps operation
)

Parameters

opDesc
Type: System..::.String
Audit description
azClient
Type: IAzClientContext2
Client context (current httpcontext user)
operation
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzOps
Authorized operation

Return Value

True, if client is allowed to perform operation at IP range level

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

DhcpAzIpRangeScope..::.GenerateAzScopeName Method
DhcpAzIpRangeScope Class See Also Send Feedback
Generates the scope string ID based on IP range in inherited server and subnet IPs

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string GenerateAzScopeName()

Return Value

A string representing the scope's ID in the AzMan database

Remarks

String ID format: 'SRV w.x.y.z - SN a.b.c.d - IPR e.f.g.h:i.j.k.l'
StartIP can equal EndIP, creating a one address authorization

See Also

DhcpAzIpRangeScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzOps Enumeration

DhcpAzOps Enumeration
See Also Send Feedback
AzMan authorization operations

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpAzOps

Members

Member name | Description
Traverse | Traverse item
Read | Read item
Create | Create item
Update | Update item
Delete | Delete item

See Also

Unf.Dhcp.Smo.WebServices Namespace


DhcpAzRole Enumeration

DhcpAzRole Enumeration
See Also Send Feedback
Scope specific DHCP authorization roles

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpAzRole

Members

Member name | Description
Auditor | Scope specific read only role
Manager | Scope specific read/update only role
Owner | Scope specific read/update/create/delete role

See Also

Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScope Class

DhcpAzScope Class
Members See Also Send Feedback
Base class for DHCP authorization scopes

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract class DhcpAzScope

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzServerScope

See Also

DhcpAzScope Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScope Members

[image]

DHCP Server Management Objects
DhcpAzScope Members
DhcpAzScope Class Constructors Methods Fields See Also Send Feedback

The DhcpAzScope type exposes the following members.

Constructors

Name | Description
DhcpAzScope | Dummy constructor

Methods

Name | Description
AccessCheck | A scope specific check access authorization
GenerateAzScopeName | Generates the scope string ID based on the scopes type and members

Fields

Name | Description
ScopeType | Scope type

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScope Constructor

DhcpAzScope Constructor
DhcpAzScope Class See Also Send Feedback
Dummy constructor

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzScope()

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScope Fields

[image]

DHCP Server Management Objects
DhcpAzScope Fields
DhcpAzScope Class See Also Send Feedback

The DhcpAzScope type exposes the following members.

Fields

Name | Description
ScopeType | Scope type

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


ScopeType Field

DhcpAzScope..::.ScopeType Field
DhcpAzScope Class See Also Send Feedback
Scope type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzScopeType ScopeType

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScope Methods

[image]

DHCP Server Management Objects
DhcpAzScope Methods
DhcpAzScope Class See Also Send Feedback

The DhcpAzScope type exposes the following members.

Methods

Name | Description
AccessCheck | A scope specific check access authorization
GenerateAzScopeName | Generates the scope string ID based on the scopes type and members

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


AccessCheck Method

DhcpAzScope..::.AccessCheck Method
DhcpAzScope Class See Also Send Feedback
A scope specific check access authorization

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract bool AccessCheck(
    string opDesc,
    IAzClientContext2 azClient,
    DhcpAzOps operation
)

Parameters

opDesc
Type: System..::.String
Audit description
azClient
Type: IAzClientContext2
Client context (current httpcontext user)
operation
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzOps
Authorized operation

Return Value

True, if client is allowed to perform operation in scope

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

DhcpAzScope..::.GenerateAzScopeName Method
DhcpAzScope Class See Also Send Feedback
Generates the scope string ID based on the scopes type and members

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public abstract string GenerateAzScopeName()

Return Value

A string representing the scope's ID in the AzMan database

See Also

DhcpAzScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzScopeType Enumeration

DhcpAzScopeType Enumeration
See Also Send Feedback
DHCP authorization scope types

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DhcpAzScopeType

Members

Member name | Description
IpRange | IP range level authorizations
Subnet | Subnet level authorizations
Server | Server level authorizations

See Also

Unf.Dhcp.Smo.WebServices Namespace


DhcpAzServerScope Class

DhcpAzServerScope Class
Members See Also Send Feedback
DHCP server authorization scope (server level roles/permissions)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpAzServerScope : DhcpAzScope

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzServerScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope

See Also

DhcpAzServerScope Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzServerScope Members

[image]

DHCP Server Management Objects
DhcpAzServerScope Members
DhcpAzServerScope Class Constructors Methods Fields See Also Send Feedback

The DhcpAzServerScope type exposes the following members.

Constructors

Name | Description
DhcpAzServerScope | Dummy constructor, sets type

Methods

Name | Description
AccessCheck | A server scope check access authorization (Overrides DhcpAzScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Overloaded.

Fields

Name | Description
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzServerScope Constructor

DhcpAzServerScope Constructor
DhcpAzServerScope Class See Also Send Feedback
Dummy constructor, sets type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzServerScope()

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzServerScope Fields

[image]

DHCP Server Management Objects
DhcpAzServerScope Fields
DhcpAzServerScope Class See Also Send Feedback

The DhcpAzServerScope type exposes the following members.

Fields

Name | Description
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


Server Field

DhcpAzServerScope..::.Server Field
DhcpAzServerScope Class See Also Send Feedback
DHCP server IP address

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress Server

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzServerScope Methods

[image]

DHCP Server Management Objects
DhcpAzServerScope Methods
DhcpAzServerScope Class See Also Send Feedback

The DhcpAzServerScope type exposes the following members.

Methods

Name | Description
AccessCheck | A server scope check access authorization (Overrides DhcpAzScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Overloaded.

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


AccessCheck Method

DhcpAzServerScope..::.AccessCheck Method
DhcpAzServerScope Class See Also Send Feedback
A server scope check access authorization

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool AccessCheck(
    string opDesc,
    IAzClientContext2 azClient,
    DhcpAzOps operation
)

Parameters

opDesc
Type: System..::.String
Audit description
azClient
Type: IAzClientContext2
Client context (current httpcontext user)
operation
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzOps
Authorized operation

Return Value

True, if client is allowed to perform operation at server level

See Also

DhcpAzServerScope Class
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

[image]

DHCP Server Management Objects
DhcpAzServerScope..::.GenerateAzScopeName Method
DhcpAzServerScope Class See Also Send Feedback

Overload List

Name | Description
GenerateAzScopeName()()() | Generates the scope string ID based on DHCP server's IP (Overrides DhcpAzScope ..::. GenerateAzScopeName()()().)
GenerateAzScopeName(DhcpIpAddress) | Generates the scope string ID based on server parameter

See Also

DhcpAzServerScope Class
DhcpAzServerScope Members
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

DhcpAzServerScope..::.GenerateAzScopeName Method
DhcpAzServerScope Class See Also Send Feedback
Generates the scope string ID based on DHCP server's IP

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string GenerateAzScopeName()

Return Value

A string representing the scope's ID in the AzMan database

Remarks

String ID format: 'SRV w.x.y.z'

See Also

DhcpAzServerScope Class
GenerateAzScopeName Overload
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method (DhcpIpAddress)

DhcpAzServerScope..::.GenerateAzScopeName Method (DhcpIpAddress)
DhcpAzServerScope Class See Also Send Feedback
Generates the scope string ID based on server parameter

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected static string GenerateAzScopeName(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress

Return Value

A string representing the scope's ID in the AzMan database

Remarks

String ID format: 'SRV w.x.y.z'

See Also

DhcpAzServerScope Class
GenerateAzScopeName Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzSubnetScope Class

DhcpAzSubnetScope Class
Members See Also Send Feedback
DHCP subnet authorization scope (subnet level roles/permissions)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpAzSubnetScope : DhcpAzServerScope

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzServerScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope
Unf.Dhcp.Smo.WebServices..::.DhcpAzIpRangeScope

See Also

DhcpAzSubnetScope Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzSubnetScope Members

[image]

DHCP Server Management Objects
DhcpAzSubnetScope Members
DhcpAzSubnetScope Class Constructors Methods Fields See Also Send Feedback

The DhcpAzSubnetScope type exposes the following members.

Constructors

Name | Description
DhcpAzSubnetScope | Dummy construtor, sets type

Methods

Name | Description
AccessCheck | A subnet scope check access authorization (Overrides DhcpAzServerScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Overloaded.

Fields

Name | Description
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address (Inherited from DhcpAzServerScope.)
Subnet | DHCP subnet network IP address

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzSubnetScope Constructor

DhcpAzSubnetScope Constructor
DhcpAzSubnetScope Class See Also Send Feedback
Dummy construtor, sets type

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpAzSubnetScope()

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzSubnetScope Fields

[image]

DHCP Server Management Objects
DhcpAzSubnetScope Fields
DhcpAzSubnetScope Class See Also Send Feedback

The DhcpAzSubnetScope type exposes the following members.

Fields

Name | Description
ScopeType | Scope type (Inherited from DhcpAzScope.)
Server | DHCP server IP address (Inherited from DhcpAzServerScope.)
Subnet | DHCP subnet network IP address

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


Subnet Field

DhcpAzSubnetScope..::.Subnet Field
DhcpAzSubnetScope Class See Also Send Feedback
DHCP subnet network IP address

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpIpAddress Subnet

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpAzSubnetScope Methods

[image]

DHCP Server Management Objects
DhcpAzSubnetScope Methods
DhcpAzSubnetScope Class See Also Send Feedback

The DhcpAzSubnetScope type exposes the following members.

Methods

Name | Description
AccessCheck | A subnet scope check access authorization (Overrides DhcpAzServerScope ..::. AccessCheck(String, IAzClientContext2, DhcpAzOps).)
GenerateAzScopeName | Overloaded.

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


AccessCheck Method

DhcpAzSubnetScope..::.AccessCheck Method
DhcpAzSubnetScope Class See Also Send Feedback
A subnet scope check access authorization

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override bool AccessCheck(
    string opDesc,
    IAzClientContext2 azClient,
    DhcpAzOps operation
)

Parameters

opDesc
Type: System..::.String
Audit description
azClient
Type: IAzClientContext2
Client context (current httpcontext user)
operation
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzOps
Authorized operation

Return Value

True, if client is allowed to perform operation at subnet level

See Also

DhcpAzSubnetScope Class
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

[image]

DHCP Server Management Objects
DhcpAzSubnetScope..::.GenerateAzScopeName Method
DhcpAzSubnetScope Class See Also Send Feedback

Overload List

Name | Description
GenerateAzScopeName()()() | Generates the scope string ID based on inherited server IP and this subnet IP (Overrides DhcpAzServerScope ..::. GenerateAzScopeName()()().)
GenerateAzScopeName(DhcpIpAddress, DhcpIpAddress) | Generates the scope string ID based on server IP and subnet IP parameters

See Also

DhcpAzSubnetScope Class
DhcpAzSubnetScope Members
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method

DhcpAzSubnetScope..::.GenerateAzScopeName Method
DhcpAzSubnetScope Class See Also Send Feedback
Generates the scope string ID based on inherited server IP and this subnet IP

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public override string GenerateAzScopeName()

Return Value

A string representing the scope's ID in the AzMan database

Remarks

String ID format: 'SRV w.x.y.z - SN a.b.c.d'

See Also

DhcpAzSubnetScope Class
GenerateAzScopeName Overload
Unf.Dhcp.Smo.WebServices Namespace


GenerateAzScopeName Method (DhcpIpAddress, DhcpIpAddress)

DhcpAzSubnetScope..::.GenerateAzScopeName Method (DhcpIpAddress, DhcpIpAddress)
DhcpAzSubnetScope Class See Also Send Feedback
Generates the scope string ID based on server IP and subnet IP parameters

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected static string GenerateAzScopeName(
    DhcpIpAddress server,
    DhcpIpAddress subnet
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
subnet
Type: Unf.Dhcp.Smo..::.DhcpIpAddress

Return Value

A string representing the scope's ID in the AzMan database

Remarks

String ID format: 'SRV w.x.y.z - SN a.b.c.d'

See Also

DhcpAzSubnetScope Class
GenerateAzScopeName Overload
Unf.Dhcp.Smo.WebServices Namespace


DhcpOperations Class

DhcpOperations Class
Members See Also Send Feedback
DHCP Web Services

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebServiceBindingAttribute(ConformsTo = WsiProfiles.BasicProfile1_1)]
[WebServiceAttribute(Namespace = "http://www.unf.edu/~jrupard/dws/")]
public class DhcpOperations : WebService

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.MarshalByValueComponent
System.Web.Services..::.WebService
Unf.Dhcp.Smo.WebServices..::.DhcpOperations

See Also

DhcpOperations Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpOperations Members

[image]

DHCP Server Management Objects
DhcpOperations Members
DhcpOperations Class Constructors Methods See Also Send Feedback

The DhcpOperations type exposes the following members.

Constructors

Name | Description
DhcpOperations |

Methods

Name | Description
CreateLease | Create a client lease on server
CreateReservation | Create a DHCP IP reservation on server
CreateSubnet | Create a DHCP subnet on server
CreateSubnetExclusion | Create a subnet exclusion address pool
DeleteLease | Delete client lease from server
DeleteReservation | Delete a DHCP IP reservation on server
DeleteSubnet | Delete DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option values set in particular scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on server
GetOptionValue | Retrieve a DHCP option's value from a particular scope
RemoveOptionValue | Remove a DHCP option's value from a particular scope
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Set a DHCP option's value on a particular scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Update a client lease on server
UpdateReservation | Update a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Update default DHCP subnet address pool (range)

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpOperations Constructor

DhcpOperations Constructor
DhcpOperations Class See Also Send Feedback
Initializes a new instance of the DhcpOperations class.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpOperations()

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpOperations Methods

[image]

DHCP Server Management Objects
DhcpOperations Methods
DhcpOperations Class See Also Send Feedback

The DhcpOperations type exposes the following members.

Methods

Name | Description
CreateLease | Create a client lease on server
CreateReservation | Create a DHCP IP reservation on server
CreateSubnet | Create a DHCP subnet on server
CreateSubnetExclusion | Create a subnet exclusion address pool
DeleteLease | Delete client lease from server
DeleteReservation | Delete a DHCP IP reservation on server
DeleteSubnet | Delete DHCP subnet on server
DeleteSubnetExclusion | Deletes a subnet exclusion address pool
EnumLeases | Enumerate all client leases on subnet
EnumOptions | Enumerate all DHCP options available on server (global set of DHCP options)
EnumOptionValues | Enumerate all DHCP option values set in particular scope
EnumPools | Enumerate all address pools belonging to subnet
EnumReservations | Enumerate IP Reservations owned by subnet on server
EnumSubnets | Enumerate subnets on server
GetOptionValue | Retrieve a DHCP option's value from a particular scope
RemoveOptionValue | Remove a DHCP option's value from a particular scope
ServerFindAllClients | Search all subnets on server looking for client leases matching terms
ServerFindOneClient | Search all subnets on server looking for first client lease matching terms
SetOptionValue | Set a DHCP option's value on a particular scope
SubnetFindAllClients | Search subnet for client leases matching terms
SubnetFindOneClient | Search subnet for first client lease matching terms
UpdateLease | Update a client lease on server
UpdateReservation | Update a DHCP IP reservation on server
UpdateSubnet | Update DHCP subnet on server
UpdateSubnetRange | Update default DHCP subnet address pool (range)

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateLease Method

DhcpOperations..::.CreateLease Method
DhcpOperations Class See Also Send Feedback
Create a client lease on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Create a client lease on server")]
public void CreateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease info to create

Remarks

Client lease will be assigned to a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateReservation Method

DhcpOperations..::.CreateReservation Method
DhcpOperations Class See Also Send Feedback
Create a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Create a DHCP IP reservation on server")]
public void CreateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
IP reservation info

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning reservation's IP address

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateSubnet Method

DhcpOperations..::.CreateSubnet Method
DhcpOperations Class See Also Send Feedback
Create a DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[XmlIncludeAttribute(typeof(BootpIpRange))]
[WebMethodAttribute(Description = "Create a DHCP subnet on server")]
[XmlIncludeAttribute(typeof(DhcpIpRange))]
public void CreateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet network IP address
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
Default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role at server scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


CreateSubnetExclusion Method

DhcpOperations..::.CreateSubnetExclusion Method
DhcpOperations Class See Also Send Feedback
Create a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Create a subnet exclusion address pool")]
public void CreateSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to create pool in
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range use to created pool

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteLease Method

DhcpOperations..::.DeleteLease Method
DhcpOperations Class See Also Send Feedback
Delete client lease from server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Delete client lease from server")]
public void DeleteLease(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpAddress leaseIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete lease from
leaseIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Client lease IP address, used to identify and delete

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteReservation Method

DhcpOperations..::.DeleteReservation Method
DhcpOperations Class See Also Send Feedback
Delete a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Delete a DHCP IP reservation on server")]
public void DeleteReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpAddress resIp
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete reservation from
resIp
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Reservation IP address to delete

Remarks

Lease associated with reservation will also be deleted

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role on scope owning reservation's IP address

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteSubnet Method

DhcpOperations..::.DeleteSubnet Method
DhcpOperations Class See Also Send Feedback
Delete DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Delete DHCP subnet on server")]
public void DeleteSubnet(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address identifying subnet

Permissions

Permission | Description
DhcpAzRole..::.Owner | Requires owner role at server scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DeleteSubnetExclusion Method

DhcpOperations..::.DeleteSubnetExclusion Method
DhcpOperations Class See Also Send Feedback
Deletes a subnet exclusion address pool

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Delete a subnet exclusion address pool")]
public void DeleteSubnetExclusion(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipExRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to delete pool from
ipExRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
IP range to delete

Remarks

ipExRange.Type must equal DhcpExcludedIpRanges

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumLeases Method

DhcpOperations..::.EnumLeases Method
DhcpOperations Class See Also Send Feedback
Enumerate all client leases on subnet

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate all client leases on subnet")]
public DhcpClient[] EnumLeases(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

A list of client leases belonging to subnet

Remarks

This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumOptions Method

DhcpOperations..::.EnumOptions Method
DhcpOperations Class See Also Send Feedback
Enumerate all DHCP options available on server (global set of DHCP options)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate all DHCP options available on server (global set of DHCP options)")]
public DhcpOption[] EnumOptions(
    DhcpIpAddress server,
    DhcpOptionClassType classType
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)

Return Value

An array of global DHCP options available on server

Remarks

Only Dhcp class types seems to return a set of possible DHCP options. The other classes share these same DHCP options

Permissions

Permission | Description
 | Does not require authorization, only authentication

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumOptionValues Method

DhcpOperations..::.EnumOptionValues Method
DhcpOperations Class See Also Send Feedback
Enumerate all DHCP option values set in particular scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate all DHCP option values set in particular scope")]
public DhcpOptionValue[] EnumOptionValues(
    DhcpIpAddress server,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Option scope (Server, Subnet, or Reservation) to enumerate

Return Value

An array of DHCP option's values current set in scope

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least Auditor role on scope owning option values

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumPools Method

DhcpOperations..::.EnumPools Method
DhcpOperations Class See Also Send Feedback
Enumerate all address pools belonging to subnet

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate all address pools belonging to subnet")]
public DhcpIpRange[] EnumPools(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address

Return Value

An array of address pools. The first pool will be the default address pool followed by zero or more exclusion pools

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at subnet scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumReservations Method

DhcpOperations..::.EnumReservations Method
DhcpOperations Class See Also Send Feedback
Enumerate IP Reservations owned by subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate IP Reservations owned by subnet on server")]
public DhcpReservation[] EnumReservations(
    DhcpIpAddress server,
    DhcpIpAddress network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to enumerate

Return Value

An array of reservations on subnet

Remarks

This method implements security trimming. User will only 'see' reservations their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning reservation's IP address

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


EnumSubnets Method

DhcpOperations..::.EnumSubnets Method
DhcpOperations Class See Also Send Feedback
Enumerate subnets on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate subnets on DHCP server")]
public DhcpSubnet[] EnumSubnets(
    DhcpIpAddress server
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to enumerate

Return Value

An array of DHCP subnets

Remarks

This method implements security trimming. User will only 'see' subnets they can access

Permissions

Permission | Description
 | Requires internal limited role. This role will be automatically assigned based on other roles within the subnet and/or IP range

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


GetOptionValue Method

DhcpOperations..::.GetOptionValue Method
DhcpOperations Class See Also Send Feedback
Retrieve a DHCP option's value from a particular scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Retrieve a DHCP option's value from a particular scope")]
public DhcpOptionValue GetOptionValue(
    DhcpIpAddress server,
    uint optionId,
    DhcpOptionClassType classType,
    DhcpOptionScope scope
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
optionId
Type: System..::.UInt32
DHCP option identifier (ex. 006 = DNS Servers)
classType
Type: Unf.Dhcp.Smo..::.DhcpOptionClassType
DHCP option class type (Dhcp, Bootp, or Routing)
scope
Type: Unf.Dhcp.Smo..::.DhcpOptionScope
Get option value from scope (Server, Subnet, or Reservation)

Return Value

A DHCP option value

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least Auditor role on scope owning option value

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


RemoveOptionValue Method

DhcpOperations..::.RemoveOptionValue Method
DhcpOperations Class See Also Send Feedback
Remove a DHCP option's value from a particular scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Remove a DHCP option's value from a particular scope")]
public void RemoveOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

Completes remove all values from option. Option becomes unset

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least Manager role on scope owning option value

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


ServerFindAllClients Method

DhcpOperations..::.ServerFindAllClients Method
DhcpOperations Class See Also Send Feedback
Search all subnets on server looking for client leases matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Search <b>all</b> subnets on server looking for client leases matching terms")]
public DhcpClient[] ServerFindAllClients(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

An array of client leases matching terms

Remarks

Client filter terms are .NET regex patterns

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at server scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


ServerFindOneClient Method

DhcpOperations..::.ServerFindOneClient Method
DhcpOperations Class See Also Send Feedback
Search all subnets on server looking for first client lease matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Search <b>all</b> subnets on server looking for first client lease matching terms")]
public DhcpClient ServerFindOneClient(
    DhcpIpAddress server,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role at server scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SetOptionValue Method

DhcpOperations..::.SetOptionValue Method
DhcpOperations Class See Also Send Feedback
Set a DHCP option's value on a particular scope

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[XmlIncludeAttribute(typeof(DhcpOptionDataString))]
[XmlIncludeAttribute(typeof(DhcpOptionDataIp))]
[XmlIncludeAttribute(typeof(DhcpOptionDataByte))]
[XmlIncludeAttribute(typeof(DhcpOptionDataDword))]
[XmlIncludeAttribute(typeof(DhcpOptionDataDwordDword))]
[WebMethodAttribute(Description = "Set a DHCP option's value based on a particular scope")]
[XmlIncludeAttribute(typeof(DhcpOptionDataWord))]
public void SetOptionValue(
    DhcpIpAddress server,
    DhcpOptionValue value
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
value
Type: Unf.Dhcp.Smo..::.DhcpOptionValue
DHCP option value

Remarks

This method overwrites any previous data set on value.OptionId

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least Manager role on scope owning option value

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SubnetFindAllClients Method

DhcpOperations..::.SubnetFindAllClients Method
DhcpOperations Class See Also Send Feedback
Search subnet for client leases matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Search subnet for client leases matching terms")]
public DhcpClient[] SubnetFindAllClients(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

An array of client leases matching terms

Remarks

Client filter terms are .NET regex patterns
This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


SubnetFindOneClient Method

DhcpOperations..::.SubnetFindOneClient Method
DhcpOperations Class See Also Send Feedback
Search subnet for first client lease matching terms

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Search subnet for first client lease matching terms")]
public DhcpClient SubnetFindOneClient(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpClientFilter terms
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to search
terms
Type: Unf.Dhcp.Smo..::.DhcpClientFilter
Client filter terms

Return Value

First matching client lease or null if no match

Remarks

Client filter terms are .NET regex patterns
This method implements security trimming. User will only 'see' client leases their authorized to access

Permissions

Permission | Description
DhcpAzRole..::.Auditor | Requires at least auditor role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateLease Method

DhcpOperations..::.UpdateLease Method
DhcpOperations Class See Also Send Feedback
Update a client lease on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Update a client lease on server")]
public void UpdateLease(
    DhcpIpAddress server,
    DhcpClient lease
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
lease
Type: Unf.Dhcp.Smo..::.DhcpClient
Client lease to match and update

Remarks

Client lease will be updated on a existing subnet based on the binary AND operation of lease.IpAddress & lease.SubnetMask
Operation will update lease.Mac, lease.Name, lease.Comment, and lease.LeaseExpires on existing lease matching lease.IpAddress and lease.SubnetMask

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role on scope owning IP address of client lease

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateReservation Method

DhcpOperations..::.UpdateReservation Method
DhcpOperations Class See Also Send Feedback
Update a DHCP IP reservation on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Update a DHCP IP reservation on server")]
public void UpdateReservation(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpReservation res
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update reservation on
res
Type: Unf.Dhcp.Smo..::.DhcpReservation
Updated IP reservation info

Remarks

Updates res.ReservedMac, res.bAllowedClientTypes, res.Name, and res.Comment based on match of res.ReservedIp

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role on scope owning reservation's IP address

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateSubnet Method

DhcpOperations..::.UpdateSubnet Method
DhcpOperations Class See Also Send Feedback
Update DHCP subnet on server

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Update DHCP subnet on server")]
public void UpdateSubnet(
    DhcpIpAddress server,
    DhcpSubnet network
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpSubnet
Subnet object to update

Remarks

Operation will update network.Name, network.Comment, and network.State on existing subnet matching network.Address

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


UpdateSubnetRange Method

DhcpOperations..::.UpdateSubnetRange Method
DhcpOperations Class See Also Send Feedback
Update default DHCP subnet address pool (range)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Update default DHCP subnet address pool (range)")]
public void UpdateSubnetRange(
    DhcpIpAddress server,
    DhcpIpAddress network,
    DhcpIpRange ipRange
)

Parameters

server
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Server IP address
network
Type: Unf.Dhcp.Smo..::.DhcpIpAddress
Subnet network IP address to update pool on
ipRange
Type: Unf.Dhcp.Smo..::.DhcpIpRange
New default address pool associated with subnet

Remarks

ipRange parameter can be of type DhcpIpRange or BootpIpRange
Removes current address pool and replaces with ipRange. This can be used to change address pool client type (Dhcp, Bootp, or Both)

Permissions

Permission | Description
DhcpAzRole..::.Manager | Requires at least manager role at subnet scope

See Also

DhcpOperations Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurity Class

DhcpSecurity Class
Members See Also Send Feedback
DHCP Web Services Authorization Services

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebServiceAttribute(Namespace = "http://www.unf.edu/~jrupard/dws/")]
[WebServiceBindingAttribute(ConformsTo = WsiProfiles.BasicProfile1_1)]
public class DhcpSecurity : WebService

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.MarshalByValueComponent
System.Web.Services..::.WebService
Unf.Dhcp.Smo.WebServices..::.DhcpSecurity

See Also

DhcpSecurity Members
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurity Members

[image]

DHCP Server Management Objects
DhcpSecurity Members
DhcpSecurity Class Constructors Methods See Also Send Feedback

The DhcpSecurity type exposes the following members.

Constructors

Name | Description
DhcpSecurity |

Methods

Name | Description
AddGlobalPermission | Add account with global role to DHCP authorization database
AddPermission | Add account with role to DHCP authorization database
EnumAzIpRanges | Enumerate authorization IP ranges in DHCP authorization database
GetGlobalPermissions | Enumerate global accounts and their roles in DHCP authorization database
GetPermissions | Enumerate accounts and their roles in DHCP authorization database
isAdmin | Check if current user belongs to global administrator role in DHCP authorization database
RemoveGlobalPermission | Remove account with global role from DHCP authorization database
RemovePermission | Remove account with role from DHCP authorization database

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurity Constructor

DhcpSecurity Constructor
DhcpSecurity Class See Also Send Feedback
Initializes a new instance of the DhcpSecurity class.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSecurity()

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurity Methods

[image]

DHCP Server Management Objects
DhcpSecurity Methods
DhcpSecurity Class See Also Send Feedback

The DhcpSecurity type exposes the following members.

Methods

Name | Description
AddGlobalPermission | Add account with global role to DHCP authorization database
AddPermission | Add account with role to DHCP authorization database
EnumAzIpRanges | Enumerate authorization IP ranges in DHCP authorization database
GetGlobalPermissions | Enumerate global accounts and their roles in DHCP authorization database
GetPermissions | Enumerate accounts and their roles in DHCP authorization database
isAdmin | Check if current user belongs to global administrator role in DHCP authorization database
RemoveGlobalPermission | Remove account with global role from DHCP authorization database
RemovePermission | Remove account with role from DHCP authorization database

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


AddGlobalPermission Method

DhcpSecurity..::.AddGlobalPermission Method
DhcpSecurity Class See Also Send Feedback
Add account with global role to DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Add account with global role to DHCP authorization database")]
public void AddGlobalPermission(
    DhcpAzGlobalAccount account
)

Parameters

account
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalAccount

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


AddPermission Method

DhcpSecurity..::.AddPermission Method
DhcpSecurity Class See Also Send Feedback
Add account with role to DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[XmlIncludeAttribute(typeof(DhcpAzIpRangeScope))]
[XmlIncludeAttribute(typeof(DhcpAzServerScope))]
[XmlIncludeAttribute(typeof(DhcpAzSubnetScope))]
[WebMethodAttribute(Description = "Add account with role to DHCP authorization database")]
public void AddPermission(
    DhcpAzScope scope,
    DhcpAzAccount account
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
account
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzAccount

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


EnumAzIpRanges Method

DhcpSecurity..::.EnumAzIpRanges Method
DhcpSecurity Class See Also Send Feedback
Enumerate authorization IP ranges in DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate authorization IP ranges in DHCP authorization database")]
public DhcpAzIpRangeScope[] EnumAzIpRanges(
    DhcpAzSubnetScope scope
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope

Return Value

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


GetGlobalPermissions Method

DhcpSecurity..::.GetGlobalPermissions Method
DhcpSecurity Class See Also Send Feedback
Enumerate global accounts and their roles in DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate global accounts and their roles in DHCP authorization database")]
public DhcpAzGlobalAccount[] GetGlobalPermissions()

Return Value

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


GetPermissions Method

DhcpSecurity..::.GetPermissions Method
DhcpSecurity Class See Also Send Feedback
Enumerate accounts and their roles in DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Enumerate accounts and their roles in DHCP authorization database")]
public DhcpAzAccount[] GetPermissions(
    DhcpAzScope scope
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope

Return Value

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


isAdmin Method

DhcpSecurity..::.isAdmin Method
DhcpSecurity Class See Also Send Feedback
Check if current user belongs to global administrator role in DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Check if current user belongs to global administrator role in DHCP authorization database")]
public bool isAdmin()

Return Value

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


RemoveGlobalPermission Method

DhcpSecurity..::.RemoveGlobalPermission Method
DhcpSecurity Class See Also Send Feedback
Remove account with global role from DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Remove account with global role from DHCP authorization database")]
public void RemoveGlobalPermission(
    DhcpAzGlobalAccount account
)

Parameters

account
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalAccount

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


RemovePermission Method

DhcpSecurity..::.RemovePermission Method
DhcpSecurity Class See Also Send Feedback
Remove account with role from DHCP authorization database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
[WebMethodAttribute(Description = "Remove account with role from DHCP authorization database")]
public void RemovePermission(
    DhcpAzScope scope,
    DhcpAzAccount account
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
account
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzAccount

See Also

DhcpSecurity Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurityOps Class

DhcpSecurityOps Class
Members See Also Send Feedback
Provides a set of security operations associated with Unf.Dhcp.Smo.WebServices. These operations provide authorization to DHCP Web Services using Microsoft's Authorization Manager (AzMan) framework. Authentication is performed at the web server level and this application uses the provided user identity (HttpContext.Current.User.Identity) to check authorizations.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DhcpSecurityOps

Inheritance Hierarchy

System..::.Object
Unf.Dhcp.Smo.WebServices..::.DhcpSecurityOps

See Also

DhcpSecurityOps Members
Unf.Dhcp.Smo.WebServices Namespace
Developing Applications Using Windows Authorization Manager
Role-Based Access Control for Multi-tier Applications Using Authorization Manager
Authorization Manager Interfaces


DhcpSecurityOps Members

[image]

DHCP Server Management Objects
DhcpSecurityOps Members
DhcpSecurityOps Class Constructors Methods See Also Send Feedback

The DhcpSecurityOps type exposes the following members.

Constructors

Name | Description
DhcpSecurityOps |

Methods

Name | Description
AddGlobalPermission | Add global scope authorization to AzMan database
AddPermission | Add authorization to AzMan database
EnumAzIpRanges | Enumerate all authorization IP ranges in AzMan database within a subnet
GetClientContext | Gets a AzMan client context based on current user (HttpContext.Current.User.Identity)
GetGlobalPermissions | Gets accounts authorized in the global scope. These account belong to at least one role within the global scope.
GetPermissions | Gets accounts authorized in scope. These account belong to at least one role within that scope.
Init | Initializes the AzMan database and application store during application start-up. It uses AZ_STORE_PATH and AZ_APP_NAME from the web.config as parameters for initialization.
isAdmin | Check if current user is a part of builtin\administrators or belongs to the GlobalAdmin role in the AzMan database
RemoveAzSubnetAzIpRanges | Remove subnet authorization scope and it child scopes in AzMan database
RemoveGlobalPermission | Removes global scope authorization from AzMan database
RemovePermission | Remove authorization from AzMan database

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurityOps Constructor

DhcpSecurityOps Constructor
DhcpSecurityOps Class See Also Send Feedback
Initializes a new instance of the DhcpSecurityOps class.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DhcpSecurityOps()

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


DhcpSecurityOps Methods

[image]

DHCP Server Management Objects
DhcpSecurityOps Methods
DhcpSecurityOps Class See Also Send Feedback

The DhcpSecurityOps type exposes the following members.

Methods

Name | Description
AddGlobalPermission | Add global scope authorization to AzMan database
AddPermission | Add authorization to AzMan database
EnumAzIpRanges | Enumerate all authorization IP ranges in AzMan database within a subnet
GetClientContext | Gets a AzMan client context based on current user (HttpContext.Current.User.Identity)
GetGlobalPermissions | Gets accounts authorized in the global scope. These account belong to at least one role within the global scope.
GetPermissions | Gets accounts authorized in scope. These account belong to at least one role within that scope.
Init | Initializes the AzMan database and application store during application start-up. It uses AZ_STORE_PATH and AZ_APP_NAME from the web.config as parameters for initialization.
isAdmin | Check if current user is a part of builtin\administrators or belongs to the GlobalAdmin role in the AzMan database
RemoveAzSubnetAzIpRanges | Remove subnet authorization scope and it child scopes in AzMan database
RemoveGlobalPermission | Removes global scope authorization from AzMan database
RemovePermission | Remove authorization from AzMan database

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


AddGlobalPermission Method

DhcpSecurityOps..::.AddGlobalPermission Method
DhcpSecurityOps Class See Also Send Feedback
Add global scope authorization to AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void AddGlobalPermission(
    DhcpAzGlobalRole globalRole,
    string account
)

Parameters

globalRole
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalRole
Global Role within global scope to assign account
account
Type: System..::.String
User or group account to authorize

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


AddPermission Method

DhcpSecurityOps..::.AddPermission Method
DhcpSecurityOps Class See Also Send Feedback
Add authorization to AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void AddPermission(
    DhcpAzScope scope,
    DhcpAzRole role,
    string account
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Authorization scope to assign account in (server, subnet, ipRange)
role
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzRole
Role within scope to assign account
account
Type: System..::.String
User or group account to authorize

Remarks

Assigns account to limited role at subnet level if scope is at ipRange

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


EnumAzIpRanges Method

DhcpSecurityOps..::.EnumAzIpRanges Method
DhcpSecurityOps Class See Also Send Feedback
Enumerate all authorization IP ranges in AzMan database within a subnet

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpAzIpRangeScope[] EnumAzIpRanges(
    DhcpAzSubnetScope azSubnetScope
)

Parameters

azSubnetScope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope
Authorization subnet scope to enumerate

Return Value

All IP range authorization scopes with subnet scope

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


GetClientContext Method

DhcpSecurityOps..::.GetClientContext Method
DhcpSecurityOps Class See Also Send Feedback
Gets a AzMan client context based on current user (HttpContext.Current.User.Identity)

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static IAzClientContext2 GetClientContext()

Return Value

Current client context used to check authorized access

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


GetGlobalPermissions Method

DhcpSecurityOps..::.GetGlobalPermissions Method
DhcpSecurityOps Class See Also Send Feedback
Gets accounts authorized in the global scope. These account belong to at least one role within the global scope.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpAzGlobalAccount[] GetGlobalPermissions()

Return Value

An array of user or group account belonging the global authorization scope

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


GetPermissions Method

DhcpSecurityOps..::.GetPermissions Method
DhcpSecurityOps Class See Also Send Feedback
Gets accounts authorized in scope. These account belong to at least one role within that scope.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static DhcpAzAccount[] GetPermissions(
    DhcpAzScope scope
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Authorization scope to retrive accounts from

Return Value

An array of user or group account belong to authorization scope

Remarks

Possible scope types: server, subnet, or ipRange

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


Init Method

DhcpSecurityOps..::.Init Method
DhcpSecurityOps Class See Also Send Feedback
Initializes the AzMan database and application store during application start-up. It uses AZ_STORE_PATH and AZ_APP_NAME from the web.config as parameters for initialization.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void Init()

Return Value

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


isAdmin Method

DhcpSecurityOps..::.isAdmin Method
DhcpSecurityOps Class See Also Send Feedback
Check if current user is a part of builtin\administrators or belongs to the GlobalAdmin role in the AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static bool isAdmin()

Return Value

True is user is a application admin, otherwise false

Remarks

builtin\administrators are consider application admins as a fail-safe

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


RemoveAzSubnetAzIpRanges Method

DhcpSecurityOps..::.RemoveAzSubnetAzIpRanges Method
DhcpSecurityOps Class See Also Send Feedback
Remove subnet authorization scope and it child scopes in AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void RemoveAzSubnetAzIpRanges(
    DhcpAzSubnetScope azSubnetScope
)

Parameters

azSubnetScope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzSubnetScope
Subnet authorization scope to delete and its children

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


RemoveGlobalPermission Method

DhcpSecurityOps..::.RemoveGlobalPermission Method
DhcpSecurityOps Class See Also Send Feedback
Removes global scope authorization from AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void RemoveGlobalPermission(
    DhcpAzGlobalRole globalRole,
    string account
)

Parameters

globalRole
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzGlobalRole
Global Role within global scope to remove account
account
Type: System..::.String
User or group account to remove authorization

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


RemovePermission Method

DhcpSecurityOps..::.RemovePermission Method
DhcpSecurityOps Class See Also Send Feedback
Remove authorization from AzMan database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public static void RemovePermission(
    DhcpAzScope scope,
    DhcpAzRole role,
    string account
)

Parameters

scope
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzScope
Authorization scope to remove account from (server, subnet, ipRange)
role
Type: Unf.Dhcp.Smo.WebServices..::.DhcpAzRole
Role within scope to remove account from
account
Type: System..::.String
User or group account to remove authorization

Remarks

Removes account from limited role at subnet level if scope is at ipRange

See Also

DhcpSecurityOps Class
Unf.Dhcp.Smo.WebServices Namespace


Global Class

Global Class
Members See Also Send Feedback
Consume global web application events

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Global : HttpApplication

Inheritance Hierarchy

System..::.Object
System.Web..::.HttpApplication
Unf.Dhcp.Smo.WebServices..::.Global

See Also

Global Members
Unf.Dhcp.Smo.WebServices Namespace


Global Members

[image]

DHCP Server Management Objects
Global Members
Global Class Constructors Methods See Also Send Feedback

The Global type exposes the following members.

Constructors

Name | Description
Global |

Methods

Name | Description
Application_Start | DHCP Web Services application start event. Initializes the Authorization Manager (AzMan) database

See Also

Global Class
Unf.Dhcp.Smo.WebServices Namespace


Global Constructor

Global Constructor
Global Class See Also Send Feedback
Initializes a new instance of the Global class.

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Global()

See Also

Global Class
Unf.Dhcp.Smo.WebServices Namespace


Global Methods

[image]

DHCP Server Management Objects
Global Methods
Global Class See Also Send Feedback

The Global type exposes the following members.

Methods

Name | Description
Application_Start | DHCP Web Services application start event. Initializes the Authorization Manager (AzMan) database

See Also

Global Class
Unf.Dhcp.Smo.WebServices Namespace


Application_Start Method

Global..::.Application_Start Method
Global Class See Also Send Feedback
DHCP Web Services application start event. Initializes the Authorization Manager (AzMan) database

Namespace: Unf.Dhcp.Smo.WebServices
Assembly: Unf.Dhcp.Smo.WebServices (in Unf.Dhcp.Smo.WebServices.dll)
Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
protected void Application_Start(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
Sender
e
Type: System..::.EventArgs
EventArgs

See Also

Global Class
Unf.Dhcp.Smo.WebServices Namespace